Author Topic: WTF! Megaman The Wily Wars (E) Rom Won't Even Boot On My Mega Ever Drive X7  (Read 2686 times)

0 Members and 1 Guest are viewing this topic.

Offline Adrian Gauna

  • Jr. Member
  • **
  • Posts: 76
  • Karma: +5/-0
    • View Profile
Hi all, just thought i'd bring this to attention:

I have for a while now updated my Mega Ever Drive X7 to Krikkz's newest os build with the SMS FM core by Necronomfive and I just browsed by the Mega Man game today and decided to go into the rom from the menu and was shocked to discover that all I got was a black screen? The original (Europe) version of the game won't load? Yet the patched (U) version and (J) versions work perfectly fine? The Sega logo boots when I load the USA or Jap versions but not the Europe version. I have a un-modified PAL Sega Mega Drive model 1 console running at my native 50Hz, I don't care for 60Hz so nobody better tell me to get it modified for 60Hz because that's not happening, there's nothing wrong with 50Hz. The game used to boot on the older os updates because I remember trying it and it booted but now on the current and newest os update the game doesn't boot it seems? On a good note, the other strange thing is that I can now use the in-game menu and snap save without Mega Man The Wily Wars glitching, (providing I use the USA patched Sram rom or the Japanese rom). Now I could have sworn the game never used to work correctly when bringing up the in-game menu feature, it would give me a blue screen and be frozen.

I am aware the (E) Europe original rom of Megaman The Wily Wars uses EEPROM, but this was never a problem with the older os updates for the X7

The SRAM (U) patched rom works perfectly fine, as long as I turn the mega key function to ON, as does the (J) Jap rom (Rockman Megaworld). The point is my machine is PAL 50Hz, and the (E) Europe rom should be working more than the other two (seeing as the other two are from 60Hz regions). Yes, I have downloaded the (E) rom from different sites making sure that it's not a dud rom and have changed the files from MD to bin and they all meet the same fate, no boot, no Sega logo or Capcom logo. Tried changing the settings in the Mega Ever Drive and still get a black screen? Very strange behaviour.

My question is this: Has anybody else noticed this recently or is it just a problem i'm having? It's cool if no one can provide a solution because I don't really care for this game but it bothers me even the slightest when a Mega Drive game (no matter how shitty or a sports title it is doesn't work on the Mega Ever Drive X7 V2).

One thing that bothers me about the patch for SRAM save: Why when applying this IPS patch to the (E) Europe rom does it automatically change the rom's region to USA and block the game from working in PAL? I don't like how the patch hijacks the European version of the game and makes it unplayable in it's own region unless the Mega Key is turned on. Check it out yourself in an emulator, make sure it's set to (Europe) https://www.romhacking.net/hacks/514/

Why is this particular game so problematic? If it's not booting up issues, it's saving issues. There are more threads on this game than anything else.
« Last Edit: February 04, 2018, 01:36 PM by Adrian Gauna »