Author Topic: UltraHDMI in-game reset hotkey goes to black screen, EverDrive v2.5 LED blinking  (Read 159 times)

0 Members and 1 Guest are viewing this topic.

Offline Sqwv

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
I recently updated to the latest firmware on the UltraHDMI (HW1) to 1.09. The UltraHDMI has an "in-game reset" which means you can press a button combo on the controller to reset the console, very handy for the EverDrive v2.5 which requires a reset to save. However after performing the firmware update I noticed an issue when rebooting in some but not all games. When I press the button combo the screen just goes black and I can see a blinking red light coming through the SD card slot opening on the EverDrive (the cart shell is not transparent). At this point pressing reset on the controller or on the console itself does nothing. The console power LED is steady, just a black screen on the TV and blinking LED on the EverDrive. I have to power the console off and back on and everything works again after that.

It happens every time but only in some games. Of the few games I've tested so far, Diddy Kong Racing and Perfect Dark were resetting to a black screen with the EverDrive blinking red, while 1080 Snowboarding, Super Mario 64, Wave Race 64 reset to the EverDrive menu like normal. For a second I thought maybe since it was two Rare games and since the EverDrive v2.5 doesn't have the Ultra CIC just a donor CIC-6102, something might be triggering the lockout chip somehow, but it looks like 1080 Snowboarding uses the same CIC-6103 chip as Diddy Kong Racing, and I didn't have an issue with that game. However, I will probably test more games to see if there is a pattern.

Some strange things I've noticed while troubleshooting: if I press reset on the console itself instead of with the button combo on the controller in DKR or Perfect Dark it resets to the EverDrive OS like normal. Also, I tested my retail cartridges of those games and they all reset without issue, with either the button combo on the controller or the reset button on the console. Only time I can recreate the issue is using the button combo on the controller to reset while the games are running from the EverDrive.

Not sure what is going on here, I've never had this issue before. Any help or ideas would be appreciated.

Offline Nemok

  • Newbie
  • *
  • Posts: 40
  • Karma: +0/-0
    • View Profile
From what you're describing here, possibly a variant of this http://krikzz.com/forum/index.php?topic=9297.0.