EverDrive Forum

General => EverDrive N8 => Topic started by: MegaMan on May 10, 2013, 04:25 AM

Title: Problem with Gimmick! sound
Post by: MegaMan on May 10, 2013, 04:25 AM
I noticed while playing Gimmick! that the sound of the charging star, jumping, and being hit were all not present, however I thought that they were all using the Sunsoft 5B mapper, which is listed as supported. Is there a problem on my end or is this happening with everybody else?
Title: Re: Problem with Gimmick! sound
Post by: shymog on May 10, 2013, 04:45 AM
It's a known problem.  If you check the unofficial compatibility list someone posted it still has issues.  I'm not sure if there are any affecting gameplay/completion, but the sound is definitely something that is broken.  I believe Gimmick! uses a different Sunsoft chip than the one you're thinking of, since the one used in Batman/etc don't have the extended audio.

EDIT:  I'm not certain if anything with expansion audio is working 100%, actually.
Title: Re: Problem with Gimmick! sound
Post by: goombakid on May 10, 2013, 04:50 AM
Are you playing off a Famicom or an NES?

Did you change the N8 sound setting in the main menu (press select on the main menu) from LO to HI?

If you're using a Fami, is it A/V modified?

I can try it later on tonight, compare it to the emulator I have on my PC ATM.
Title: Re: Problem with Gimmick! sound
Post by: MegaMan on May 10, 2013, 04:53 AM
Are you playing off a Famicom or an NES?

Did you change the N8 sound setting in the main menu (press select on the main menu) from LO to HI?

If you're using a Fami, is it A/V modified?

I can try it later on tonight, compare it to the emulator I have on my PC ATM.
I'm playing on an AV Famicom (not modded). I tried the HI and LO, but neither showed a difference.
Title: Re: Problem with Gimmick! sound
Post by: shymog on May 10, 2013, 08:06 AM
I noticed while playing Gimmick! that the sound of the charging star, jumping, and being hit were all not present, however I thought that they were all using the Sunsoft 5B mapper, which is listed as supported. Is there a problem on my end or is this happening with everybody else?

Another thing I forgot to mention, mapper 69 represents THREE Sunsoft mappers, the 5A, 5B, and FME-7.  The 5B is the one with expansion audio, and is not fully operational.
Title: Re: Problem with Gimmick! sound
Post by: goombakid on May 10, 2013, 10:28 AM
Just tried it (no-intro ROM). Yep, sound it off...I also had a picture scrolling issue; the image would start rolling down or be jittery.
Title: Re: Problem with Gimmick! sound
Post by: MegaMan on May 10, 2013, 09:15 PM
On the topic of audio mixing, with an AV Famicom which should I have it set to HI or LO?
Title: Re: Problem with Gimmick! sound
Post by: The_Atomik_Punk! on May 10, 2013, 11:43 PM
to follow up on that, what exactly does the audio mixing setting modify? What should it be set to for when my NES N8 arrives?
Title: Re: Problem with Gimmick! sound
Post by: elmo069 on May 11, 2013, 02:38 AM
For those who want to play NTSC version with full sound while waiting for expansion sound fix, I found a patch to turn the PAL Mr. Gimmick into the NTSC-U prototype. I cannot take credit for the patch. I found it at Nintendoage. Just thought it might be of interest in the mean time.
Title: Re: Problem with Gimmick! sound
Post by: KRIKzz on May 11, 2013, 04:35 AM
Sunsoft 5B was implemented, but without expansion sound
Title: Re: Problem with Gimmick! sound
Post by: MegaMan on May 11, 2013, 04:50 AM
Sunsoft 5B was implemented, but without expansion sound
Is there plans to implement the expansion sound in the future?
Title: Re: Problem with Gimmick! sound
Post by: KRIKzz on May 11, 2013, 07:55 PM
Sunsoft 5B was implemented, but without expansion sound
Is there plans to implement the expansion sound in the future?
I knowed that somebody will definitely ask it (: I just will say as always: Don't want to promise anything. Basically i don't have any long-term plans, i wake up in the morning and decide what i will doing today
Title: Re: Problem with Gimmick! sound
Post by: Drakon on May 19, 2013, 04:44 PM
Sunsoft 5B was implemented, but without expansion sound

So what you really mean is "sunsoft fme7 was implemented"

For those who want to play NTSC version with full sound while waiting for expansion sound fix, I found a patch to turn the PAL Mr. Gimmick into the NTSC-U prototype. I cannot take credit for the patch. I found it at Nintendoage. Just thought it might be of interest in the mean time.

I wish the 5b chips were more plentiful, then we could have more of these:

https://www.youtube.com/watch?v=hVJTyAoSzTM (https://www.youtube.com/watch?v=hVJTyAoSzTM)

Sounds so much better than the nes audio only version.