Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - RchGrav

Pages: [1]
1

It would be great to detect if the "select" button is held down on the first controller so could bypass the autorun to get to actually select a ROM, now that would be SWEEEEET..

Another possibility besides autorun.nes would be testing for autorun.txt file in the EDFC folder containing the path to a ROM (less junk in root)

I also kinda like the idea of not displaying the EDFC folder on the selection menu.  Now I'm probably asking a lot.. 

Thanks for your consideration on these ideas.

Rich

2
EverDrive N8 / Re: N8 testing with Analogue NT
« on: April 23, 2016, 07:04 AM »
1. Analogue Nt second run
2. Both HDMI and Composite tested (crashes w/ composite cable too)
3. 2.25/V13
4. Any Settings
5. Everdrive N8 Famicom
6. Random glitches in all games, quick screen flickers, have seen misplaced background graphics in orig SMB.. the more complex the game the more likely it will crash.  (Seems like random bit flips reading PRG/CHR srams)
SMB2 is a great test as it crashes quickly, can sometimes get past character select to play for a few seconds before crash, but ALWAYS crashes.. music stays playing but system is hard locked.

3
Do you have a system in house which is exhibiting the problem?  I would be happy to send you both my console and the N8 for testing purposes.

Rich

Thanks for the offer, Rich. Lets see if we can come up with a solution on our end first, but we'll definitely keep your offer in mind. Wouldn't want you to be without your Nt if you don't have to.

At the office we have: x2 Famicom ED & x2 NES ED

We have been unable to replicate the issue on any system, which we've of course tested many! We sent out some more Nt HW to Krikzz last week (he already had some from last year) and he'll be doing some troubleshooting as soon as he can. We'll be working together on the issue from there.

I seriously don't have a problem with sending it in, especially if you can't seem to replicate it. 

At the very least I feel as though it will get to the bottom of the issue...  I absolutely promise you can replicate it with mine.  ;-)

I'm very curious as to what you find by process of elimination with your working setup and I don't mind being without it if it helps get to the bottom of the problem.






4
It is important to us that everyone can use their ED with their Nt and we're doing our best to get to the bottom of it. With Krikzz help, I think we will find a solution! Rest assured and we appreciate your patience.

Do you have a system in house which is exhibiting the problem?  I would be happy to send you both my console and my Everdrive N8 (Famicom) for testing purposes.

If there is any benefit to doing this let me know and I'll open a ticket on your site and make arrangements.

Rich

5
I'm really hoping that it's resolved with a different power supply. Has anyone done any testing with a HD modded NES?
I received both my new power adapter and NES Everdrive. Unfortunately the tip on the new adapter is too small so I've ordered a larger one. Should be here tomorrow. The NES Everdrive, however, looks promising. No lockups so far. But..am having a very strange issue in that it only seems to work with a Kingston SD card. I've tried numerous different SanDisk, Sony, Toshiba, etc and all give a gray screen when you launch a game. The Kingston one works though. Will do more testing this weekend

I'm not holding out hope for it being a PSU issue.. I've gone as high as 12V 3A and 8A DC.. no changes.

It seems like the everdrive N8 is sensitive to the signals on the cart port which causes occasional bit flips in the data being read from the everdrive, depending on which bit flips will either cause a crash or some graphics glitches.. but when this is happening its only a matter of time before your game crashes.. I don't know if its timing related or just the quality of the signals themselves on the NT.   Krikzz clearly doesn't want to shoulder the blame for his product not working on a system that it wasn't tested on while the board was being designed.. he has publicly stated in posts that since his product works with an original retail system its the responsibility of them to design their system to work with flash carts, and not the other way around.   

That being said.. I hope he is still looking into the problem, either to find a way to resolve it in his core or if he discovers the reason why its occurring that he is forthcoming... even if it involved a hardware modification like adding a capacitor.  Making my N8 work reliably on the NT would be totally worth it..  Heck.. if someone got to the bottom of the issue on the NT I would even consider performing a MOD on the NT to make its signals more stable instead of doing it on the side of the everdrive..  Maybe it IS the revisions of the reclaimed CPU/PPU's...  if this was the case I wish some more people would step forward and speak up..  "Hey.. mine works great.. its exactly what you bought..)  I'd chase down some chips if it was a sure thing that it was the chip revision.. they are in sockets, right?

Btw, I purchased a Powerpak, and it seems more stable on the NT (maybe still a few glitches occurring on this cart too, but games seem to stay running) ... however I just like my N8 better.. I like the interface on the N8 compared to the Powerpak, and miss the expanded audio.

Here's hoping Krikzz or someone more knowledgeable than myself clues us into a solution better than bailing on the NT or the N8.

Rich

6
The Everdrive N8 Famicom Edition does work in the NES slot of the NT 2.0..   I definitely had it in backwards...   It didn't seem to resolve anything though.

It seems like I am having the most trouble with Super Mario USA (Famicom) / Super Mario Bros 2 (NES)  I can't even make it past the character select screen 80% of the time.   :o

SMB2 consistently crashes or locks the system. 



7
Has anyone tried running their Famicom N8 through a Famicom to NES converter with the NT? Since the NES N8 appears to have no issues I wonder if this would workaround the problem. I'd test myself but I don't have a converter

Yeah.. I ordered this one on Amazon.. http://amzn.com/B00NKEV5EI (Arrived Yesterday) and the cart didn't even load.  I was just left with a blue screen.  I put the cart in the adapter so that the bevels on the famicom cart matched up with the bevels on the adapter, which I assume was the correct way.  All I got was a light blue screen, and the cart menu never came up.  I didn't want to push my luck and try reversing the cart for fear it would fry.  I'm 99.9% sure I had it put in the converter correctly.

Now.. for the second thing I tried...  I ordered the proprietary composite cable from Analogue (Arrived today), which Analogue assured me would bypass the Hi-Def NES board and it would be completely inactive as if it wasn't even installed...   I wasn't able to play SMB2 for more than a minute or so before the console froze (W/ music still playing)...  Then I tested with SMB3...  I was able to enter the SMB3 but unable to complete the first level without the game locking up and the graphics going really crazy.

All of the above was tried with Everdrive N8 OS 13 first, then OS 12. 

I cleaned my contacts thoroughly with Isopropyl Alcohol using a cotton swab.. and well sadly.. It didn't help either.

So now I need to find an actual Famicom to try my Famicom Everdrive N8 in.. because I don't have one..   I also need to get my hands on an actual Famicom cart to try in my NT 2.0.

It's not looking good.  I'm open for suggestions should anyone have any.   :'(

Rich

8
My first run Nt (RGB output) freezes frequently with the famicom N8, as well. However, most of the games you mentioned are fine for me. SMB3, Gimmick! and Akumajou Densetsu don't freeze, while River City Ransom and Bubble Bobble do. /shrug

Does "Super Mario Bros. (World).nes" freeze up after a few minutes?

I would think if any game played stably it should be this one?  No?

It launches fine and seems ok, and plays for a little bit, but then it just freezes.. can't even access the Hi-Def NES menu.  Putting a SMB (NES Cart) in doesn't freeze.. plays fine.  I don't have any regular Famicom carts to test with besides my Everdrive.

9

I'm pretty much convinced of this fact now also..  I deleted my other post confirming it because I wanted to be sure.

Not only are certain files incompatible, but even the most basic of ROMs hard lock up the NT 2.0 console after a few minutes.

I've tried EVERYTHING...    I even tried using a 12V 3A adapter just in case it was a power related issue.

Anyway, I ordered a composite cable from Analogue.co to see what happens if I bypass the HDMI..  I'm guessing it will work then, but we will see.

I'm sad.. I really would have liked to play some of the games with the expanded audio..   :'(

10
I wanted to have a way to automatically divide a folder with too many files in it for the Everdrive N8 into subfolders that never exceed the maximum allowed.. So, I wrote a windows batch file that automatically splits a folder of .nes files into 256 per folder.  The script will only act upon files with the .nes extension in path you target.. If it finds .nes files in that path it will break them down into subfolders.

3 ways to run this script.  (Save it as a .bat or .cmd file..  I'm using process.cmd as the file name)

#1. Just put it in the folder you wish to process and double click it.
#2. Put this command in your path and change to the directory you want to process and type the command.
#3. Type the command and use the path you wish to process as a parameter.*   Like This--> process F:\ROMs\USA\
(*Remember to put quotes around the path if it has spaces.)

Hope its useful.
Give it a try and let me know what you think. 

RchGrav

Code: [Select]
@echo off
setlocal enabledelayedexpansion enableextensions
pushd "%1"
if exist "%~dp1*.nes" (
    echo Processing NES files.
) else (
    echo NES files not found at this path.
    EXIT /B 99
)
for %%* in (.) do set Folder=%%~nx*
set fnum=0
:top
set /a fnum+=1
set cnt=0
mkdir "!Folder! !fnum!"
echo|set /p=.
for /f "delims=:" %%A in ('DIR /ON /B *.nes') do (
    setlocal disabledelayedexpansion
    call :movenes "%%A"
    endlocal
    set /a cnt+=1
    if !cnt! == 256 goto top
)
goto done
:movenes
set "file=%~1"
setlocal enabledelayedexpansion
move "!file!" "!Folder! !fnum!" >nul
endlocal
goto:eof
:done
echo Done!
popd

Pages: [1]