Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - StriderSubzero

Pages: [1]
1
FXPAK (SD2SNES) / Can't load Satellaview games?
« on: February 25, 2019, 09:35 PM »
Hi all,

I've got a new SD2SNES (not Pro) and am unable to get Satellaview games to load. I only experience a black screen when trying to load them. I have put the BS-X.bin ROM in the sd2snes folder.

2
Super EverDrive / Freezing, black screen on load
« on: June 06, 2018, 02:56 AM »
Hi all,

I've not had many problems with the SNES Everdrive in the past, but I've been trying to play through Castlevania 4 and have encountered strange freezing glitches periodically, and always at different spots. In addition, the game almost never works on the first flash, and I'll have to flash another game, load that, and then reflash Castlevania again. Even if it worked previously, I can power the system off and will need to go through this process again once I boot it back up.

I've tried several different ROMs from various sources with the same result.

Please advise as this is incredibly frustrating. Thanks.

3
EverDrive MD / Greatest Heavyweights
« on: April 29, 2018, 04:13 PM »
Does anyone have the SRAM patch for Greatest Heavyweights? I know that EEPROM save games technically work with a reset now, but I'm playing on a Nomad so I can't reset. Typical ROMs of this game don't seem to work, but I found a dump that works so I will have to apply the patch to it. Thanks!

4
Off Topic / Retro Game Cases label printing
« on: September 05, 2017, 06:13 PM »
I'm not affiliated with Retro Game Cases but wanted to shout them out. I worked with Shane over there, who was able to print and trim me a custom-size label (they don't currently offer Game Gear labels) that I designed for my Everdrive GG. I wasn't very happy with any of the labels floating around online, so I wanted to make my own. They did a great job with the trimming and rounded corners. I definitely recommend them if you need any custom labels made.



EDIT: My watermark is my NintendoAge username as I'd originally posted this over there

5
Turbo EverDrive / US ROMs not working in PC-Engine?
« on: June 15, 2017, 01:58 AM »
Just got my Turbo Everdrive and after formatting the MicroSD card it's all good, working with my white PC Engine. The only problem is that it will not load any US ROMs. JP ROMs work flawlessly. I read before purchasing that all region ROMs should load as long as the switch is engaged to the correct system (which it is). Any ideas?

EDIT: I am using the GoodPCE set

6
Hi all,

I've had the Everdrive MD for awhile and have had no issues with it. I used a later High Definition Graphics Genesis console for awhile, as well as a Model 2 Genesis, with the Everdrive and had no problems. A few months ago I picked up an early High Definition Graphics model, what's usually referred to as a "Non-TMSS" model as it does not include the opening black screen + white text (this one: http://segaretro.org/images/0/04/Tmss.png).

There are several differences with these, including the sound chip being considered overall better. The issue I'm having is that if I start the console with no controller plugged in, or a three button controller, or a Master System controller, the menu scrolls up endlessly. More seriously, if I try to use the Master System controller in any game, the cursor is being pressed upwards constantly and I can't stop it, or go down at all. It is not an issue with the controller, because I cross-tested the Everdrive and SMS controller with my other consoles.

I no longer have my Power Base Converter so I can't test a real SMS game on the console, so I'm not sure if it's an issue with the Everdrive or the Genesis itself. Are there known compatibility issues with SMS controllers and early Genesis consoles? 

7
Hi,

I randomly started getting an ERROR 0x65 with the Super Everdrive, and I read on here that it could be related to the power supply. Mine was an official SNES adapter but it did have a short in it so you'd have to bend the cord a certain way to get power to the system. I thought this was the issue so I replaced the AC adapter with another official adapter. I still got the problem so I tried different outlets, which didn't work. Then I started getting "ERROR 0x61 SD IO ERROR" instead, which I read on here meant it couldn't write to the SD card. Weirdly after this, the reset button no longer worked.

So I bought an 8GB Lexar SD card (identical to the one I've used in the Everdrive N8 for awhile now; I was using a 16GB card on the Super Everdrive before) and copied all the files to it. It worked fine for a bit, then started giving me the error again. The reset button started working again with this card though. I tried different outlets, etc. again to no avail. Then I swapped the card back to the old one and it worked again for a bit.

Anyway, now they just stop working after 1 or 2 flashes and then I swap them and it works again. Obviously this is not ideal. Any ideas what the problem is?

8
EverDrive MD / 2 Questions revolving around the Sega CD
« on: September 20, 2015, 01:01 AM »
Hi all, I have 2 questions:

1. Is it possible to use the Everdrive MD as a Sega CD RAM cart?

2. Can you play 32X+Sega CD games using the Everdrive MD?

9
Hi all,

I bought an Everdrive MD a few weeks ago and I've really been enjoying it. I stumbled across a 32X with all the cables for a good deal at a local game store today so I snatched it up, eager to come home and check out the 32X games on the Everdrive.

Unfortunately, I just get a blank black screen after the "Produced by Sega" etc. screen when it boots up. No menu at all. I saw a similar thread on here from awhile back that suggested a faulty power supply being the culprit, so I tried a different power supply (same specs/model) and still the same result. I then tried my Genesis Model 2 with the 32X (was trying a model 1 prior) and got the same thing again. I don't have any actual 32X games to try, I may try to hunt one down tomorrow and see if it works.

Any suggestions on what could be causing the issue?

Pages: [1]