Author Topic: Problems with Mode1/msu-md at Pier Solar  (Read 692 times)

0 Members and 1 Guest are viewing this topic.

Offline staniol

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Problems with Mode1/msu-md at Pier Solar
« on: August 02, 2020, 05:06 PM »
The Mega Everdrive Pro has finally reached me. :) I'm really excited about it. The Mega-CD games all run perfectly.

Unfortunately I can't get the enhanced soundtrack from the CD to work at Pier Solar. As ROM file I use the Reprint Rev A. I have already Rev B tested. Same problem. I have tested several CD variants. First I used IMGBurn to create a file (cue + bin) from my original Pier Solar CD. Then I used the files that were also mentioned here in the forum. The problem: Either the initialization breaks or no music is played. In the game options the status is: Disc ready. The Rom Info ist: PIE+CD(10).

Does anyone have an idea or a working md, cue + bin file they can provide me with?

I use the following hardware:
Mega-ED-PRO (4.02)
Analogue Mega Sg (4.7)

UPDATE:

On Mega Sg I activated the following option: enable cartridge & cd audio. Now it works.
« Last Edit: August 02, 2020, 07:00 PM by staniol »

Offline peterlanders

  • Newbie
  • *
  • Posts: 23
  • Karma: +2/-0
    • View Profile
Re: Problems with Mode1/msu-md at Pier Solar
« Reply #1 on: August 09, 2020, 07:14 PM »
[SOLVED]: See my reply #7 below for what seems to have worked!

OK, hijacking this rather than starting a new one, because Pier Solar with CD soundtrack is now, officially, the only thing I haven%u2019t been able to get working on my shiny new MEP.

Like the OP, I have a Mega Sg on the latest non-JB firmware. I%u2019ve got the latest OS for the MEP (4.04). I%u2019m using the MCD firmware versions recommended in other places where people are tearing their hair out over this particular game (2.00C for JP, 2.00W for EU and US), though I%u2019ve tried most other official ones in varying combinations. I%u2019m using the disc CUE/BINs from the redump set (one CUE, four BINs). I%u2019m naming the CUE and the game ROM the same, other than the extension.

I%u2019ve tried each version of the ROM available in the latest no-intro set: three Reprint versions and what I assume is the original. Didn%u2019t bother with the beta.

I%u2019ve tried multiple cards with different capacities. ExFAT and FAT32. And every single time the same thing: MEP recognizes the game as PIE+CD(10) and launches, I select a language, and after a few seconds %u201Csetting up 64MEG cartridge%u201D it fails with %u201Csomething wrong happened%u201D and that%u2019s that.

I%u2019ve only found one other reference to that message and the person said it just magically fixed itself at some point, but I haven%u2019t experienced that yet. But I know it must be possible to make this work: Krikzz demonstrates it in his very first feature video, and presumably the OP got it working!

I guess it%u2019s worth noting that every one of these ROMs, without the CD files present, works perfectly.

So I assume it%u2019s something to do with the CD image, or the BIOS version. But I mean, who knows at this point? It%u2019s officially past being a fun puzzle.

Any suggestions from someone who%u2019s gotten it working?
« Last Edit: August 09, 2020, 10:24 PM by peterlanders »

Offline ym2612

  • Newbie
  • *
  • Posts: 12
  • Karma: +1/-0
    • View Profile
Re: Problems with Mode1/msu-md at Pier Solar
« Reply #2 on: August 09, 2020, 09:08 PM »
do you have the exact bin filename in the cue?


Offline peterlanders

  • Newbie
  • *
  • Posts: 23
  • Karma: +2/-0
    • View Profile
Re: Problems with Mode1/msu-md at Pier Solar
« Reply #3 on: August 09, 2020, 09:16 PM »
Yes, it matches. The latest thing I tried was to run Krikzz’s cdfix tool to merge the bins. No change.

If I launch the CD directly (after opening the folder) it opens in the CD player with the Japanese firmware, looks like. Run the CD-ROM side from there and it says to insert the cartridge.

Offline peterlanders

  • Newbie
  • *
  • Posts: 23
  • Karma: +2/-0
    • View Profile
Re: Problems with Mode1/msu-md at Pier Solar
« Reply #4 on: August 09, 2020, 09:27 PM »
To really be 100% sure about the filenames I just went and renamed them down to simply ‘pier.cue’, ‘pier.bin’, and ‘pier.md’. Updated the cue too. Thought maybe the spaces were causing trouble before, though it doesn’t seem to be a problem for any other games. Still no luck.

Lots of hassle for a game so many don’t particularly like, but making it work is a *project*...

Offline ym2612

  • Newbie
  • *
  • Posts: 12
  • Karma: +1/-0
    • View Profile
Re: Problems with Mode1/msu-md at Pier Solar
« Reply #5 on: August 09, 2020, 09:34 PM »
full content of my cue file:

FILE "20xx-Pier Solar.bin" BINARY
  TRACK 01 MODE1/2352
    INDEX 01 00:00:00

my bin filesize is 401.063.040 Bytes

md5 of my game rom is A9E1C602105AAEB9DF2AB82A1EA9A832

although I am testing this on a real japanese mega drive 1 and not on the mega sg...
« Last Edit: August 09, 2020, 09:36 PM by ym2612 »

Offline peterlanders

  • Newbie
  • *
  • Posts: 23
  • Karma: +2/-0
    • View Profile
Re: Problems with Mode1/msu-md at Pier Solar
« Reply #6 on: August 09, 2020, 09:41 PM »
Thanks, will do some comparing. Don’t have it handy right now but I’m pretty sure my bin is bigger than that. I have the one Watermelon provided via their site too, maybe will see if that one works when properly converted.

Offline peterlanders

  • Newbie
  • *
  • Posts: 23
  • Karma: +2/-0
    • View Profile
Re: Problems with Mode1/msu-md at Pier Solar
« Reply #7 on: August 09, 2020, 10:23 PM »
GOT IT!

Had to convert the Watermelon-provided ISO to CUE/BIN format first, the file size of that matched yours.

They had used the naming scheme for the Reprint A ROM in the no-intro set, so I made sure to use that one. Loaded the new set into the MEP and it worked immediately.

So clearly the issue is with the soundtrack CD image in the redump set...

Thanks for the file size clue there! :)

- - -

All that being said, I just moved the working game folder over to my %u2018official%u2019 SD card and got the error again, so I%u2019m wondering if I actually just experienced the random fix others online have mentioned for my error. Happily, I was able to get around it this time simply by copying the bram file from my test card to the main one. Now all is good.

Hopefully this thread will be useful for others...
« Last Edit: August 09, 2020, 10:25 PM by peterlanders »

Offline peterlanders

  • Newbie
  • *
  • Posts: 23
  • Karma: +2/-0
    • View Profile
Re: Problems with Mode1/msu-md at Pier Solar
« Reply #8 on: August 10, 2020, 12:03 AM »
OK, final bit of experimenting to figure out the deal with why it didn’t work at first when I copied the apparently working folder to my main card.

It gave the same error as before, but I was able to fix it by copying the save file from the other card to the main one.

With that backup save file, I felt OK with deleting the one in the main card again and messing around some more.

Bottom line: it would seem that the game is incapable of ‘setting up 64MEG cartridge’ when the CD is present.

But: if you have a copy of the same ROM, named *exactly* the same, elsewhere on your card without the CD image, *that* copy will initialize properly. And then, the copy with the CD will find the same save file and be entirely happy.

I think THIS little quirk might’ve been the real problem all along, as I’d been naming the ROM to match the cue file, not the other way around. So it didn’t match my standalone copy at any point. Oops...

Offline KRIKzz

  • Administrator
  • Hero Member
  • *****
  • Posts: 3356
  • Karma: +502/-2
    • View Profile
Re: Problems with Mode1/msu-md at Pier Solar
« Reply #9 on: August 14, 2020, 12:03 AM »
I think THIS little quirk might’ve been the real problem all along, as I’d been naming the ROM to match the cue file, not the other way around. So it didn’t match my standalone copy at any point. Oops...

Just rename cue instead of rename the rom

Offline Shu92

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: Problems with Mode1/msu-md at Pier Solar
« Reply #10 on: August 14, 2020, 02:50 AM »
I can indeed confirm that the game cannot initialize properly if the Mega CD soundtrack (cue/bin) is present when running the game for the first time.
You have to run the game without the enhanced soundtrack, let the game initialize itself, and once the save file is created, you can put the enhanced soundtrack back in the game folder.

Offline peterlanders

  • Newbie
  • *
  • Posts: 23
  • Karma: +2/-0
    • View Profile
Re: Problems with Mode1/msu-md at Pier Solar
« Reply #11 on: August 14, 2020, 04:24 AM »

Just rename cue instead of rename the rom

Exactly what I did once I realized what was going on. Works perfectly now. Just wanted to post it here since I couldn’t find a solution anywhere before I leapt down the rabbit hole...  8)

(Unless this is secret knowledge everyone is supposed to discover for themselves, in which case: sorry!)