Author Topic: Problem with a Everdrive GB X3  (Read 196 times)

0 Members and 1 Guest are viewing this topic.

Offline seifer63

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Problem with a Everdrive GB X3
« on: September 14, 2020, 10:39 PM »
Hello, since yesterday, I have had a problem with my Everdrive GB X3 : when I turn my Game Boy Color on, there is the Game Boy logo and then nothing, just a blank white screen. It was working great for almost 2 years before :/
 
I have tried many things to fix it : 
-Rewrite my SD Card,
-Replacing the SD Card with a new one,
-Replacing battery with new ones (rechargeable),
-Trying my Everdrive on my fat GB DMG, my three Game Boy Advance and my Game Boy Advance SP

In any case, I have always the same problem, exept for the DMG (the blank screen is black instead of white)  :(
If I try to use my everdrive without any SD card inside, I get exactly the same blank screen, no error message.

Do you think my Everdrive is dead ? Is there any way to repair it ?

Offline FeverDrive

  • Hero Member
  • *****
  • Posts: 1292
  • Karma: +54/-0
  • Blast Processing advocate
    • View Profile
Re: Problem with a Everdrive GB X3
« Reply #1 on: September 15, 2020, 12:42 AM »
Try cleaning the cartridge contacts using Isopropyl alcohol or electronic contact cleaner.
WELCO
METOT
HENEX
TLEVEL

Offline seifer63

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Problem with a Everdrive GB X3
« Reply #2 on: September 15, 2020, 01:16 AM »
I have tried that too but, unfortunately, it doesn't work neither :(
I have forgotten to precise it in my last post but, once there's the blank screen, the red LED is on.

Offline seifer63

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Problem with a Everdrive GB X3
« Reply #3 on: September 16, 2020, 10:37 PM »
I have made a new test today :

If I press and hold the "reset" button while I'm starting the Game Boy, I get a "Memory error" message if there is no SD card inside. Otherwise, the Game boy enters in a reset loop...

I really feel like there is a problem with the everdrive itself...Any Idea ?

Offline Richardragon87

  • SNESAdvance Revival Coder
  • Sr. Member
  • ****
  • Posts: 405
  • Karma: +5/-0
    • View Profile
Re: Problem with a Everdrive GB X3
« Reply #4 on: September 16, 2020, 11:49 PM »
I have made a new test today :

If I press and hold the "reset" button while I'm starting the Game Boy, I get a "Memory error" message if there is no SD card inside. Otherwise, the Game boy enters in a reset loop...

I really feel like there is a problem with the everdrive itself...Any Idea ?

Sounds like the SD card being the micro SDHC isn't fitting in the spring correctly. It reminds me of that time when I got a used retrotowers EDGB X3 from ebay from a seller and only after having it for a while I kept running into the game never changing and normally ran into the memory error screen when I tried to hold it down with duct tape in the end I replaced it for a new original one and didn't have that problem again.
[quote Random dating spambotJ

Quote
Post changed:

Great, the photo didn't load! Does anyone know how to fix this?
In any case, my other photos can be viewed here, I will be glad to meet you, I love flirt))

P.S Richardragon87! Don't write me again, dude! You're in ignore list!