Author Topic: Can't make NBA Jam T.E. (Mega Drive/Genesis) to work on X3  (Read 749 times)

0 Members and 1 Guest are viewing this topic.

Offline tyltyl

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Hi, I'm getting crazy trying to make NBA Jam T.E. to word on the Mega Everdrive X3 with my Mega Drive model 1 (VA6). The game only show vertical blue lines on startup.
I thought it was a problem with EEPROM saving, so I tried to find a patch to no avail. I only found one broken link, people saying that the game works out of the box and others that couldn't make it to work. I tried different ROMs but with the same result. I tried on my Super Retro Trio Plus and it's the same. I could try on my model 2 but I don't think it's worth the hassle anyway.
I even found some people having the same blue lines on the original cartridge (!!), so I don't know what could be the problem.

Funny enough, other games with EEPROM saving work fine and save without even patching them (unless I found the ROMs already patched without knowing), vanilla NBA Jam works without issues and saves, and pretty much every other game works aside from regional issues or occasional incompatibility.

Any idea?

Offline Marteicos

  • Sr. Member
  • ****
  • Posts: 329
  • Karma: +15/-0
    • View Profile
Re: Can't make NBA Jam T.E. (Mega Drive/Genesis) to work on X3
« Reply #1 on: August 16, 2020, 09:25 PM »
The Px variant of this game iirc run this game (dump from a bootleg maybe), but doesn't save. The 32x version of T. E. is the same, except a patch was made but doesn't save.


The Mega Drive version only loads and saves with unpatched rom when using the Mega Everdrive X7/V2 and Pro.
If you want to be able to save, get the original cart or X7/pro.

Afaik the 32x only saves with the cart.

I found out there a patched 32x version that don't save, but runs (no stripes screen).

Offline tyltyl

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Can't make NBA Jam T.E. (Mega Drive/Genesis) to work on X3
« Reply #2 on: August 17, 2020, 10:30 AM »
I see, too bad. I own the original 32x cart, but it would have more comfortable for me to play with the Everdrive and without attaching the 32x (which also doesn't allow to play with the Master System anyway).

Thanks.

Offline JaKSLaP

  • Newbie
  • *
  • Posts: 6
  • Karma: +1/-0
    • View Profile
Re: Can't make NBA Jam T.E. (Mega Drive/Genesis) to work on X3
« Reply #3 on: August 28, 2020, 03:02 AM »
Hi, I'm getting crazy trying to make NBA Jam T.E. to word on the Mega Everdrive X3 with my Mega Drive model 1 (VA6). The game only show vertical blue lines on startup.
I thought it was a problem with EEPROM saving, so I tried to find a patch to no avail. I only found one broken link, people saying that the game works out of the box and others that couldn't make it to work. I tried different ROMs but with the same result. I tried on my Super Retro Trio Plus and it's the same. I could try on my model 2 but I don't think it's worth the hassle anyway.
I even found some people having the same blue lines on the original cartridge (!!), so I don't know what could be the problem.

Funny enough, other games with EEPROM saving work fine and save without even patching them (unless I found the ROMs already patched without knowing), vanilla NBA Jam works without issues and saves, and pretty much every other game works aside from regional issues or occasional incompatibility.

Any idea?

Hi;

Have you tried using a PAL European ROM? i had these issues with NTSC midway games, but after loading the PAL version its all working great.
I gave up with NTSC ROMS on my PAL Mega Drive 2.

Offline JaKSLaP

  • Newbie
  • *
  • Posts: 6
  • Karma: +1/-0
    • View Profile
Re: Can't make NBA Jam T.E. (Mega Drive/Genesis) to work on X3
« Reply #4 on: September 01, 2020, 05:28 AM »
Hi;

Yep sorry i get the blue bars too. I only tested the normal version which works fine.

Offline Myklindle

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: Can't make NBA Jam T.E. (Mega Drive/Genesis) to work on X3
« Reply #5 on: September 26, 2020, 08:44 AM »
I too am having this problem.  I have tried Roms from multiple locations and the most I can get is vertical blue lines.  I have also confirmed the same roms work for friends with the mega sd.  Is there something I need to patch?  I am using a sega model 1  mega everdrive x3 with rgb to my pvm.  Could that have anything to do with it?