Author Topic: Super Everdrive X5  (Read 607 times)

0 Members and 1 Guest are viewing this topic.

Offline Dars

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Super Everdrive X5
« on: October 05, 2020, 09:57 PM »

I've just bought a X5 and I have a strange issue with it. First of all, the cartridge is ok because I've tested it on a friend's console and everything works. I thought that was my console. I tried a regular cartridge (Zelda : a link to the past) and it worked. The error I get when using the X5 on my console is a bad "MEMORY ERROR" displayed on my screen on a red background. When I power up my SNES, the red light on the cartridge flashed a very short time only.

My console seems pretty fine, I can save games on my Zelda cartridge and I have no problem powering this cartridge repetitively. It's like if my console simply do not support the X5. Is that something possible? Is there something I can do to make it work?

Here are the 2 consoles with serial number if it can be useful :

Offline rlstine

  • Full Member
  • ***
  • Posts: 137
  • Karma: +7/-0
    • View Profile
Re: Super Everdrive X5
« Reply #1 on: October 24, 2020, 09:54 PM »
This might be a silly question, but have you formatted your micro sd card properly (FAT32)? There is also a new OS KRIKzz released today that you might try with your x5.