Author Topic: X5 Mini ERROR FAT system not found  (Read 882 times)

0 Members and 1 Guest are viewing this topic.

Offline input_error

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
X5 Mini ERROR FAT system not found
« on: October 28, 2020, 03:30 AM »
Hello! Happy to be here  8)

Recently got an X5 Mini to replace my old X5.

I initially swapped my SD card from my X5 to my mini and it worked for about an hour before seemingly softlocking; I had to power cycle the GBA. When I booted it up again I had the error ERROR 6: FAT system not found and thought I had to reformat/get a different OS for the mini.

I tried the OS -- but that hasn't been updated since 2018.

I've tried reformatting the 32GB SD card in macOS via Disk Utility (FAT) -- no dice

I tried formatting the drive in Temrinal with newfs_msdos -F 16 and newfs_msdos -F 32

I tried formatting the SD card in Windows as FAT32 -- no dice

I have re-tested the SD card in my old X5 and it works as intended.

Is there anything else I can try to get this to work? Appreciate any help  :)

Offline James Cree

  • Full Member
  • ***
  • Posts: 186
  • Karma: +7/-0
    • View Profile
Re: X5 Mini ERROR FAT system not found
« Reply #1 on: October 28, 2020, 08:51 AM »
Looks like you tried everything but prayer to get that sucker working  ;)
Sorry to say, it sounds like you got one of the bad ones.