Author Topic: Yoshi's Island issue  (Read 455 times)

0 Members and 1 Guest are viewing this topic.

Offline AKG

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Yoshi's Island issue
« on: December 30, 2020, 05:37 PM »
Hi,

I recently purchased FXPAK Pro and put newest firmware to it. All ROMs I tried work well except Yoshi's Island. I tried several ROM versions and problem is the same.
After some playing (sometimes after 30 mins, sometimes right from the start) it looses video and audio. Screen and music just became black for second or two, after that it comes back. But eventually disappears again. And again, and again.

I have 1-Chip Rev1 SNES connected to OSSC, after that HDMI audio separator and video goes to Samsung monitor and audio to DAC.

FXPAK Pro settings are default.

Can this be solved?!

Thanks!
« Last Edit: December 30, 2020, 05:39 PM by AKG »

Offline Gumball

  • Gumball Bunny
  • Full Member
  • ***
  • Posts: 163
  • Karma: +18/-0
  • Heavy Metal Rabbit
    • View Profile
Re: Yoshi's Island issue
« Reply #1 on: December 30, 2020, 09:48 PM »
what are your output settings? most importantly your 240p mode. 3x 4x or 5x? 5x is great if your monitor or tv support it but can cause issues with sync aka the video dropping out on your like you describe. The super nintendo has a weird refresh rate of 60.09 hrtz.
that is the main culprit of why sync loss happens on the ossc with super nintendo. For me I use 4x output and leave it on generic 4:3 instead of any of the optimized modes for 240p because those cause sync problems on my 4k samsung. If anyone reading this notices anything I got wrong I apologize this just based on my own trial and error trouble shooting and I don't know the ins and outs of the technical no how.
All I wanna do is shred.

Offline AKG

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: Yoshi's Island issue
« Reply #2 on: December 30, 2020, 11:46 PM »
Well I use Fireband's "default" profile for SNES 256, I didn't touch it:
Code: [Select]
{
    "version": "0.86",
    "main": [
        {
            "profile_name": "SNES 256",
            "video_lpf": "9MHz (SDTV)",
            "ypbpr_cs": "Rec. 601",
            "r_f_off": "128",
            "g_f_off": "128",
            "b_f_off": "128",
            "r_f_gain": "26",
            "g_f_gain": "26",
            "b_f_gain": "26",
            "c_gain": "8",
            "clamp_offset": "128",
            "alc_v_filter": "10",
            "alc_h_filter": "3",
            "s480p_mode": "Auto",
            "s400p_mode": "VGA 640x400@70",
            "tvp_hpll2x": "On",
            "upsample2x": "Off",
            "sync_lpf": "2.5MHz (max)",
            "stc_lpf": "4.8MHz (HDTV/PC)",
            "sync_vth": "11",
            "linelen_tol": "6",
            "vsync_thold": "68",
            "pre_coast": "1 lines",
            "post_coast": "0 lines",
            "pm_240p": "Line4x",
            "pm_384p": "Line2x",
            "pm_480i": "Line4x (bob)",
            "pm_480p": "Line2x",
            "pm_1080i": "Passthru",
            "l2_mode": "256x240 optim.",
            "l3_mode": "256x240 optim.",
            "l4_mode": "256x240 optim.",
            "l5_mode": "256x240 optim.",
            "l5_fmt": "1920x1080",
            "ar_256col": "8:7",
            "tx_mode": "HDMI (RGB)",
            "hdmi_itc": "Off",
            "sl_mode": "Off",
            "sl_str": "0",
            "sl_hybr_str": "0",
            "sl_method": "Multiplication",
            "sl_altern": "On",
            "sl_id": "Top",
            "sl_altiv": "Off",
            "sl_type": "Horizontal",
            "sl_cust_l_str_1": "0",
            "sl_cust_l_str_2": "0",
            "sl_cust_l_str_3": "0",
            "sl_cust_l_str_4": "0",
            "sl_cust_l_str_5": "0",
            "sl_cust_c_str_1": "0",
            "sl_cust_c_str_2": "0",
            "sl_cust_c_str_3": "0",
            "sl_cust_c_str_4": "0",
            "sl_cust_c_str_5": "0",
            "sl_cust_c_str_6": "0",
            "h_mask": "0",
            "v_mask": "8",
            "mask_color": "Black",
            "mask_br": "0",
            "reverse_lpf": "0",
            "full_tx_setup": "Off",
            "vga_ilace_fix": "Off",
            "av3_alt_rgb": "Off",
            "panasonic_hack": "Off",
            "default_vic": "0",
            "audio_dw_sampl": "2x (fs = 48kHz)",
            "audio_swap_lr": "Off",
            "audio_gain": "12",
            "link_av": "No link",
            "export_enabled": "true"
        }
    ],
    "timing_tweaker": [
        [
            {
                "name": "512x240",
                "h_active": "512",
                "v_active": "240",
                "h_total": "682",
                "h_total_adj": "0",
                "h_backporch": "75",
                "v_backporch": "15",
                "h_synclen": "50",
                "v_synclen": "3",
                "sampler_phase": "22"
            },
            {
                "name": "384x240",
                "h_active": "384",
                "v_active": "240",
                "h_total": "487",
                "h_total_adj": "17",
                "h_backporch": "41",
                "v_backporch": "14",
                "h_synclen": "37",
                "v_synclen": "3",
                "sampler_phase": "23"
            },
            {
                "name": "320x240",
                "h_active": "320",
                "v_active": "240",
                "h_total": "427",
                "h_total_adj": "0",
                "h_backporch": "49",
                "v_backporch": "15",
                "h_synclen": "31",
                "v_synclen": "3",
                "sampler_phase": "16"
            },
            {
                "name": "256x240",
                "h_active": "256",
                "v_active": "240",
                "h_total": "341",
                "h_total_adj": "0",
                "h_backporch": "38",
                "v_backporch": "15",
                "h_synclen": "25",
                "v_synclen": "3",
                "sampler_phase": "22"
            },
            {
                "name": "480i",
                "h_active": "704",
                "v_active": "240",
                "h_total": "910",
                "h_total_adj": "0",
                "h_backporch": "98",
                "v_backporch": "15",
                "h_synclen": "62",
                "v_synclen": "3",
                "sampler_phase": "2"
            },
            {
                "name": "480p",
                "h_active": "720",
                "v_active": "480",
                "h_total": "858",
                "h_total_adj": "0",
                "h_backporch": "59",
                "v_backporch": "30",
                "h_synclen": "62",
                "v_synclen": "6",
                "sampler_phase": "6"
            }
        ]
    ]
}

And you are rigt I think, it drops sync because red LED on OSSC goes on during this drops. But I don't experience this on and other game so far, that is strange to me.

Offline Gumball

  • Gumball Bunny
  • Full Member
  • ***
  • Posts: 163
  • Karma: +18/-0
  • Heavy Metal Rabbit
    • View Profile
Re: Yoshi's Island issue
« Reply #3 on: December 31, 2020, 12:53 AM »
put it on generic 4:3 instead of the optimized modes. those cause issues with certain monitors and screens when using super nintendo. I've had several monitors lose sync in those modes.
All I wanna do is shred.