Author Topic: "Save&Quit" not working?  (Read 944 times)

0 Members and 1 Guest are viewing this topic.

Offline Lazorblind

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
"Save&Quit" not working?
« on: January 11, 2020, 11:18 PM »
So recently I have been playing Rocket: Robot on Wheels. Its a decent enough games as far as kids games go. Got some challenge to it, probably both from the game itself and 3d platforming being kinda cruddy back in those days.

But here is the thing. I paused, selected save and quit, went back to the title screen, pressed reset on the 64 (I'm still using an old ED64 v2) and went to bed. When I came back to it the next day, all of the save slots were empty. "WTF?" I thought and started to investigate. At first I thought it was a save type discrepancy, and forced both types of EEPROM save options. That didn't work, so as I was getting ready to try and force SRAM and Flash saves, right as I was about to hit reset is when I realized that after doing a save and quit back to the title screen, my save slot said "New Game"

So it seems that as per usual, the Everdrive was correct about the save type, and the .eep file was loading just fine, but that the file had no data in the save slot, because the game itself just quit, instead of saving and then quitting!

Has anyone seen anything like this before? Is it just this game and perhaps the save feature is bugged? Is there a fix? I have left my system on for three days now to keep my progress, but that cant last forever, and I would happily restart again if I could fix this.

Offline nuu

  • Hero Member
  • *****
  • Posts: 1570
  • Karma: +74/-2
    • View Profile
Re: "Save&Quit" not working?
« Reply #1 on: January 12, 2020, 12:31 AM »
I've experienced the ED64 (v2) failing to update the save file on the SD card. I had ended a Mario Party session and before turning off I hit reset to save my earned stars and coins. But the Everdrive hanged instead of going back to the menu and copy the file. I turned it off then on again to see if it saved, and it turned out that whole session was lost.

Is that what happened for you? You didn't say what happened between hitting reset and going to bed.
If it works properly, it should return to the Everdrive menu and a popup window (often really quick) should say that it's writing to SD card or something like that. After that you can turn off the power.

Offline Lazorblind

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: "Save&Quit" not working?
« Reply #2 on: January 12, 2020, 12:59 AM »
I didn't really pay much attention, but it went back to the everdrive menu, and I believe I saw the save message flash.

As I said, it seems as if the save function inside the game itself is failing to work. When you pause the game, there is three options you can select. Controls, Hints/Stats, and Save&Quit. As I was getting ready to mess with different save types in the ever drive menu, before I pressed reset on the system, I looked at the three save slots the game offers and slot A, which I was using said New Game, so it was completely empty, and I verified that by selecting it and it started the game over, so I lost my progress before even going back to the everdrive menu.

So as I said, the everdrive wrote the .eep to the SD card just fine, but despite having sunk a couple hours into it, the progress didn't get saved into slot A by the game itself, so the everdrive wrote an effectively empty save file for the game, which is then being loaded properly by the everdrive.

I'm leaning more toward this is some kind of glitch with the game itself or the ROM, but since I'm running it on the everdrive, thought this would be a good place to seek help.

This could p

Offline Amarth

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: "Save&Quit" not working?
« Reply #3 on: August 04, 2020, 05:01 AM »
Hi, I'm likely having the same issue here. I've played a few sessions of this game, probably 3-4 hours total, and it was saving and loading fine.
Like OP, I hit save & quit before resetting the console and then turning it off.
Today I started up the game, and the save file is gone. I checked my saves folder, and there is a file there. I booted up some other games with save files, and they're all fine. I took my save file into windows and compared it to my donkey kong 64 file, and I know they are different games, but they're pretty similar in type. The rocket robot on wheels save data was vastly shorter than DK64, and so I'm guessing OP is correct in their theory.

I guess this is a problem with this game specifically?
OP, did you ever find a solution? Do we just need to wait longer after hitting save and quit or something?
Thanks.

Offline nuu

  • Hero Member
  • *****
  • Posts: 1570
  • Karma: +74/-2
    • View Profile
Re: "Save&Quit" not working?
« Reply #4 on: August 04, 2020, 12:08 PM »
Try this:
1) Force EEPROM 4kb save type and save in the game and see if it works.
2) If not, delete the EEP file first and then try again forcing EEPROM 16kb.
3) If it still doesn't work, try forcing each of the other save types and delete the save file on the SD card before trying the next one.
4) I don't know, try inserting a controller pak and then save.