Author Topic: My SD2SNES stopped working suddenly  (Read 4059 times)

0 Members and 1 Guest are viewing this topic.

Offline Nodoyuna

  • Newbie
  • *
  • Posts: 35
  • Karma: +0/-0
    • View Profile
My SD2SNES stopped working suddenly
« on: May 14, 2014, 09:21 PM »
Hi
Suddenly, my SD2SNES has stopeed working... While playin a game, it hangs and shows garbled graphics on screen, and from then on, it does not work anymore
Reset does not seems to do anything
When I plug the SNES, the 2 lights on top acts like usual, and then the green light on front is green, but again, nothing shows on screen!
Do you have any idea on how to solve this issue?
Thanks in advance

Offline goombakid

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1153
  • Karma: +74/-8
    • View Profile
Re: My SD2SNES stopped working suddenly
« Reply #1 on: May 15, 2014, 06:54 AM »
Try a different console if you have one available.

Are you using a stock adapter or a 3rd party one?

Otherwise, try playing a game that has one of the expansion chips (CX4 ie. Megaman X2 or SFX ie. Starfox). It could be that the "outer" pins on your SNES may be dirty.

Offline Nodoyuna

  • Newbie
  • *
  • Posts: 35
  • Karma: +0/-0
    • View Profile
Re: My SD2SNES stopped working suddenly
« Reply #2 on: May 15, 2014, 01:17 PM »
Hi
It seems the problem has been resolved by itself, at least from now...
Thank for the tips, I'll try them is the problem appears again

Offline Nodoyuna

  • Newbie
  • *
  • Posts: 35
  • Karma: +0/-0
    • View Profile
Re: My SD2SNES stopped working suddenly
« Reply #3 on: May 18, 2014, 09:47 AM »
Finally, the problem was in the SD card I was using, I've changed it to a new one, and everything is right now, no more flaws or anything strange ;)

Now, time to check that SNES library :)