Author Topic: Save Issues with Shining Force  (Read 10639 times)

0 Members and 1 Guest are viewing this topic.

Offline 61revisited

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Save Issues with Shining Force
« on: January 20, 2013, 05:05 AM »
I've had my Everdrive MD for awhile now and Love it!! Recently, I starting playing Shining Force and I am having issues with saving my game. I played for awhile, and I didn't seem to have any problems; then suddenly my saved file was mysteriously gone and now when I start a new game and save it, it does not load the next time I start the game-again it mysteriously disappears. Is this a known issue with Shining Force? I hope to play this and other RPG's with my Everdrive MD, so if anyone has advice I would really appreciate it!! 

Offline KRIKzz

  • Administrator
  • Hero Member
  • *****
  • Posts: 3359
  • Karma: +504/-2
    • View Profile
Re: Save Issues with Shining Force
« Reply #1 on: January 21, 2013, 01:52 AM »
try to play some other games which have save abilities, sonic3 for example. You may send your cart to me for check, if saves in other games does not work also

Offline STONEDSTONER

  • Newbie
  • *
  • Posts: 24
  • Karma: +1/-0
    • View Profile
Re: Save Issues with Shining Force
« Reply #2 on: February 02, 2013, 04:14 PM »
EDIT

problem fixed, dont use slot 1 for save data on both Shining Force I and II, i used slot/data 2 and it saved perfect

seems strange these games have problems saving in Slot/data 1 tho?









Im having the same problem with Shining Force II, It seems to save good if you dont change games,but if you power off and change game, next time you load up Shining Force II you will get this message

"Ooops! Record 1 has vanished!"

The save file (.srm) is still there in EDMD/SAVE it just doesnt work anymore

Sonic 3 saves fine, no problems

KRIKzz please fix this problem, if you would like to try yourself, its really quick to save point on Shining Force II , start the game and leave your house, look in the middle of the town for a house with a Priest , he will let you save the game
« Last Edit: February 02, 2013, 04:56 PM by STONEDSTONER »

Offline ceramiclion

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: Save Issues with Shining Force
« Reply #3 on: February 02, 2013, 07:06 PM »
I played shining force 1 and finished it and I never had that issue.

Offline stonie

  • the red eye'd mage
  • Sr. Member
  • ****
  • Posts: 256
  • Karma: +11/-18
    • View Profile
Re: Save Issues with Shining Force
« Reply #4 on: February 02, 2013, 10:15 PM »
i was having that same issue, at first i thoguht it was cuz the prog 100 error i was getting but i fixxed that and my shining force save still disappears, could it posibly be the rom itself do you think?
flashcarts- acecard 2i, everdrive md, everdrive n8, cyclo ievolution

Offline STONEDSTONER

  • Newbie
  • *
  • Posts: 24
  • Karma: +1/-0
    • View Profile
Re: Save Issues with Shining Force
« Reply #5 on: February 02, 2013, 10:46 PM »
i was having that same issue, at first i thoguht it was cuz the prog 100 error i was getting but i fixxed that and my shining force save still disappears, could it posibly be the rom itself do you think?
Try slot/data 2 , worked for me

Offline stonie

  • the red eye'd mage
  • Sr. Member
  • ****
  • Posts: 256
  • Karma: +11/-18
    • View Profile
Re: Save Issues with Shining Force
« Reply #6 on: March 08, 2013, 11:09 PM »
ok i got really far into this game this time, was saving in slot 2 the whole time. and it happened again this time in save slot 2. i guess i am not going to be able to keep a save in either of these games.

edit: yep lol
« Last Edit: March 21, 2013, 02:40 AM by stonie »
flashcarts- acecard 2i, everdrive md, everdrive n8, cyclo ievolution

Offline Chrono256

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: Save Issues with Shining Force
« Reply #7 on: January 29, 2016, 06:50 PM »
Hello.
Sorry for necroposting but... has anyone resolved this issue?
I tried saving in the second slot and it worked only for a while, now it's broken too. :(
Oh damn, I was so excited to finally play Shining Force on my MegaDrive. :'(
The strange part is that the game knows the save state is broken, but can't do nothing.
« Last Edit: January 29, 2016, 07:19 PM by Chrono256 »

Offline jaumao

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: Save Issues with Shining Force
« Reply #8 on: February 26, 2016, 09:04 PM »
Hello!

The everdrive have worked perfectly until today. But this afternoon it happens the same Issue with Shinning force 2, all my progress was lost ! :(

I checked with another games like sonic 3 or Beyond the Oasis and it's the same thing.

There is no solution for this?

Thank's!

Offline goombas

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: Save Issues with Shining Force
« Reply #9 on: July 02, 2018, 05:22 AM »
Same problem here with Shinning force 1 using a mega everdrive v2 running megaos 3.06 on a Genesis 2.

I started to play the game and completed Chapter I in one shot, saved and turned off the console
-> no backup available in game when I restarted the game the next day.

I deleted the sram dump in /MEGA/SAVE and restarted the game from scratch.
I've been able to save and restore my progress 3 or 4 times successfully over a week but after the completion of chapter II, the backup has vanished.

Now I don't want to play the game anymore :-/
It's a pity that this bug first reported in January 2013 is still not fixed 5 years later :p