Author Topic: Everdrive N8 Problem  (Read 2927 times)

0 Members and 1 Guest are viewing this topic.

Offline blanchfor

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Everdrive N8 Problem
« on: June 29, 2015, 07:19 PM »
Hello,

I'm having an issue with my everdrive.  Here is a youtube video of me trying to get it to work.  i've tried everything recommended other than a different NES.  Is there anyway I can get assistance with returning the drive or more troubleshooting options?  I've tried 4, 8, and 16 GB SD  card with no success.  My NES is a NTSC american version.  The 72 pin connector works with official games I have.

Offline blanchfor

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Everdrive N8 Problem
« Reply #1 on: June 29, 2015, 07:20 PM »

Offline teltaste

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: Everdrive N8 Problem
« Reply #2 on: June 30, 2015, 02:55 AM »
Seems to be a common issue... It would be nice if we could get some resolution on this or at least suggestions. The only thing I've heard really is to try a different power supply which I have now tried 5 separate ones.

Offline Troyus

  • Full Member
  • ***
  • Posts: 241
  • Karma: +8/-2
    • View Profile
Re: Everdrive N8 Problem
« Reply #3 on: June 30, 2015, 03:56 AM »
You were told to try it on another NES.

Try pm krikzz for a responce on sending it back.
Flash carts: game gear ED, megadrive ED, SNES ED, nintendo64 ED, N8 ED, GB ED, GBA ED, PSIO

Offline goombakid

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1153
  • Karma: +74/-8
    • View Profile
Re: Everdrive N8 Problem
« Reply #4 on: June 30, 2015, 05:56 AM »
Try:
Different power supplies (Model 1 Genesis adapters usually recommended).
Different console.
Format SD card and reinstall OS.
Reconfigure CIC.
Clean/replace connector (even if regular carts work, dirty/worn connectors can mess with flash carts).

Worse case scenario, contact KRIKzz for repair.

Offline teltaste

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: Everdrive N8 Problem
« Reply #5 on: June 30, 2015, 10:50 PM »
Thanks for the reply, I'm gonna try buying a new power supply before I pm krikzz. The main thing is it just needing to be 9v and around 1-1.3A right?

As I said in my 1st post I don't have access to another NES nor do I know anyone in my area that still owns one so that's out. However, I do know my connector is spotless and I'm on an original NTSC American.

It can't be the SD card because I'm getting the issue even without the SD card in. I'm hoping its just the power supply...