Author Topic: EverDrive-GB OS v2  (Read 44854 times)

0 Members and 2 Guests are viewing this topic.

Offline goombakid

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1153
  • Karma: +74/-8
    • View Profile
Re: EverDrive-GB OS v2
« Reply #15 on: September 07, 2015, 08:22 PM »
Weird. I just updated mine. My GBC, GBASP (with a super low battery charge), and GB Pocket all load up fine.

Perhaps try formatting the card?

Offline fille1976

  • Sr. Member
  • ****
  • Posts: 353
  • Karma: +13/-0
    • View Profile
Re: EverDrive-GB OS v2
« Reply #16 on: September 07, 2015, 08:49 PM »
here also working on gba sp and my game boy color.

Offline shadowcaster

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Re: EverDrive-GB OS v2
« Reply #17 on: September 07, 2015, 10:00 PM »
Weird. I just updated mine. My GBC, GBASP (with a super low battery charge), and GB Pocket all load up fine.

Perhaps try formatting the card?

Tried that, with sdformatter. Didn't help. When update file is removed boots fine on GBC. Updated os resets.
Works perfectly on GB classic.
« Last Edit: September 07, 2015, 10:06 PM by shadowcaster »

Offline KRIKzz

  • Administrator
  • Hero Member
  • *****
  • Posts: 3378
  • Karma: +508/-2
    • View Profile
Re: EverDrive-GB OS v2
« Reply #18 on: September 07, 2015, 10:11 PM »
Just try yo reinsert sd card, probably cart can not read sd card and launch last game, even not boot OS at all

Tried that. With no manipulation with sd card EDGB with OSv2 in gameboy classic works (blinks init twice, than boots os v2), in gameboy color blinks init twice (like striggles to load os v2), resets to last game. Absolutely reproducible. Maybe GBC current or voltage is low to drive edgb osv2 boot? It's only 2 batteries, after all.

Working fine on my gbc, so this is not batteries

Offline fille1976

  • Sr. Member
  • ****
  • Posts: 353
  • Karma: +13/-0
    • View Profile
Re: EverDrive-GB OS v2
« Reply #19 on: September 07, 2015, 10:42 PM »
did you try another sdcard?
tryed here on gameboy dmg-gameboy color and gba sp,all working fine,maybe try other sdcard.

Offline zstandig

  • Jr. Member
  • **
  • Posts: 67
  • Karma: +0/-0
    • View Profile
Re: EverDrive-GB OS v2
« Reply #20 on: September 07, 2015, 11:16 PM »
I'm using a Super Gameboy 2, stuck on 'init...'

*edit*

I reset it a few times and it went through without a hitch. Thanks for the update KRIKzz.
« Last Edit: September 07, 2015, 11:37 PM by zstandig »

Offline Great Hierophant

  • Sr. Member
  • ****
  • Posts: 295
  • Karma: +19/-0
    • View Profile
Re: EverDrive-GB OS v2
« Reply #21 on: September 08, 2015, 01:21 AM »
I tried it on my DMG-001 Game Boy, my Game Boy Advance w/Afterburner and GBA SP Backlit and it all worked fine. 

Game Boy Pocket test anyone?  8)
Check Out My Vintage Video Game & Computing Blog : http://nerdlypleasures.blogspot.com/

Offline goombakid

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1153
  • Karma: +74/-8
    • View Profile
Re: EverDrive-GB OS v2
« Reply #22 on: September 08, 2015, 04:53 AM »
Game Boy Pocket test anyone?  8)

Weird. I just updated mine. My GBC, GBASP (with a super low battery charge), and GB Pocket all load up fine.
:P

I'm about to get my SNES set up so I can test the Super GB, and I'll also test out the GB Player as well.

Offline lee4

  • codetype specialist
  • Hero Member
  • *****
  • Posts: 796
  • Karma: +45/-0
    • View Profile
    • gamehacking.org
Re: EverDrive-GB OS v2
« Reply #23 on: September 08, 2015, 06:57 AM »
EverDrive-GB OS v2, works fine on both the Super Gameboy (USA) and GBA SP (USA).
ED64 v2.0, 3.0 & X7 | EDMD v3 | MEGAED X7 M15 v2.01 & PRO rev B | TED v2.4 | EDN8 v1.2N | SED v2.1 | SD2SNES rev E1 & PRO rev.B | EDGB v1.1 & X7 M17 rev B | EDGBA X5 M16 rev A & Mini M19 Rev B
SNES jr | Super NT | Mega SG | Super Retro Advance | SGB v1 | PCE+SSD3

Offline trekeyus

  • Jr. Member
  • **
  • Posts: 99
  • Karma: +6/-0
    • View Profile
    • my soundcloud
Re: EverDrive-GB OS v2
« Reply #24 on: September 08, 2015, 09:06 AM »
EverDrive-GB OS v2, works fine on both the Super Gameboy (USA) and GBA SP (USA).
Might just be bad luck on my part maybe my micro sd card is getting flacky. could be due for a new Micro sd card.
Chaos reigns within - Reflect, repent and reboot - Order shall return

Offline goombakid

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1153
  • Karma: +74/-8
    • View Profile
Re: EverDrive-GB OS v2
« Reply #25 on: September 08, 2015, 11:50 AM »
Power cycling a couple of times doesn't work for you, either?

Offline olsenn

  • Newbie
  • *
  • Posts: 48
  • Karma: +0/-1
    • View Profile
Re: EverDrive-GB OS v2
« Reply #26 on: September 08, 2015, 06:46 PM »
That's it? Swapped buttons on boot screen and a minor bugfix? Haha, sounds more like a v1.01 than a v2.0. Nevertheless, thanks Krikzz

Offline fille1976

  • Sr. Member
  • ****
  • Posts: 353
  • Karma: +13/-0
    • View Profile
Re: EverDrive-GB OS v2
« Reply #27 on: September 08, 2015, 07:10 PM »
i will test on my pocket now.
tested and working fine on my pocket.
« Last Edit: September 08, 2015, 07:14 PM by fille1976 »

Offline xamphear

  • Newbie
  • *
  • Posts: 13
  • Karma: +0/-0
    • View Profile
Re: EverDrive-GB OS v2
« Reply #28 on: September 08, 2015, 11:04 PM »
Here's my test results, using the same microSD card:

US Super Gameboy: Works.
JP Super Gameboy 2: Works.
US Gameboy Advance (non-SP): Reboots into last loaded game.
US Gameboy Player on US Gamecube: Reboots into last loaded game.

Has anyone out there gotten v2 working on a non-SP GBA or the Gamecube Gameboy Player?

Offline shadowcaster

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Re: EverDrive-GB OS v2
« Reply #29 on: September 09, 2015, 01:39 AM »
Here's my test results, using the same microSD card:

US Super Gameboy: Works.
JP Super Gameboy 2: Works.
US Gameboy Advance (non-SP): Reboots into last loaded game.
US Gameboy Player on US Gamecube: Reboots into last loaded game.

Has anyone out there gotten v2 working on a non-SP GBA or the Gamecube Gameboy Player?

I found a reason for my problem - it's sd card. EDGB is picky aboud sd cards, but OSv2 is even more demanding.
I started swapping sd cards, and absolutely unbranded 2G microsd card from aliexpress worked! silicon power 8g microsd(hc) booted OSv2 only on classic brick, verbatim 8g microsd(hc) made EDGB to show hex error on power on.

So, now I got OSv2 tested working on: Classic DMG-01, Color CGB-001, Advance AGB-001, Advance SP AGS-101.
Format tool used: windows format to FAT32, sector size 4k.
Card used: noname 2gb microsd card (only one that worked for v2 on every device I could test)

« Last Edit: September 09, 2015, 02:23 AM by shadowcaster »