Author Topic: New Everdrive N8 - Green screen + garbled graphics  (Read 5541 times)

0 Members and 1 Guest are viewing this topic.

Offline sqwirral

  • Newbie
  • *
  • Posts: 25
  • Karma: +0/-0
    • View Profile
New Everdrive N8 - Green screen + garbled graphics
« on: September 24, 2015, 06:06 PM »
Hi my N8 just arrived today (from RetroTowers, not from Krikzz).

It's showing a green screen for a couple of seconds, then garbled graphics.

This occurs every time, with no variation, reseating cleaning etc does nothing. Both with and without SD card installed.

Original Famicom hardware, all original carts work fine, the power adapter is the correct spec (original Sega Mega Drive model 1 rated up to 1200mA).

Pics:




On searching I found someone else with the same issue:
http://krikzz.com/forum/index.php?topic=1986.msg24571#msg24571
Quote
It used to work fine. Lately i tried to use it but it shows a green screen for about 2 sec (blinking red led) an after that some scrambled garbage on the screen. I use it on a Famicom


Should I just return it to RetroTowers and order one from Krikzz instead?

Offline KRIKzz

  • Administrator
  • Hero Member
  • *****
  • Posts: 3378
  • Karma: +508/-2
    • View Profile
Re: New Everdrive N8 - Green screen + garbled graphics
« Reply #1 on: September 24, 2015, 10:24 PM »
Probably you should return it or send to me for repair

Offline sqwirral

  • Newbie
  • *
  • Posts: 25
  • Karma: +0/-0
    • View Profile
Re: New Everdrive N8 - Green screen + garbled graphics
« Reply #2 on: October 02, 2015, 02:46 AM »
Hi Krikzz or anyone else...

I returned this to Retrotowers and he kindly gave me a refund, but I asked if he could test it on his Famicom -- and he says it's working.

So the problem is my end.

Any idea what would cause this? The Fami was purchased pre-AV modded from a shop in Japan, is there anything the modder could have done to cause it?

I've cleaned the slot contacts. I've got 15 original carts here that all work fine - but I do have a Chinese 150-in-1 pirate cart which also doesn't work (blank screen, not green screen). I had assumed the Chinese cart was faulty but now I'm wondering if there's a connection between that and the Everdrive issue. I don't have access to another Famicom, or even a NES, to test this on right now.

I bought the Fami just so I could use an Everdrive so this is quite annoying!

Offline lee4

  • codetype specialist
  • Hero Member
  • *****
  • Posts: 796
  • Karma: +45/-0
    • View Profile
    • gamehacking.org
Re: New Everdrive N8 - Green screen + garbled graphics
« Reply #3 on: October 02, 2015, 06:35 AM »
most likely the modder did something wrong.

Both Everdrive and Chinese 150-in-1 pirate cart

use same operation to boot menu and run game
ED64 v2.0, 3.0 & X7 | EDMD v3 | MEGAED X7 M15 v2.01 & PRO rev B | TED v2.4 | EDN8 v1.2N | SED v2.1 | SD2SNES rev E1 & PRO rev.B | EDGB v1.1 & X7 M17 rev B | EDGBA X5 M16 rev A & Mini M19 Rev B
SNES jr | Super NT | Mega SG | Super Retro Advance | SGB v1 | PCE+SSD3

Offline KRIKzz

  • Administrator
  • Hero Member
  • *****
  • Posts: 3378
  • Karma: +508/-2
    • View Profile
Re: New Everdrive N8 - Green screen + garbled graphics
« Reply #4 on: October 02, 2015, 09:26 AM »
Hi Krikzz or anyone else...

I returned this to Retrotowers and he kindly gave me a refund, but I asked if he could test it on his Famicom -- and he says it's working.

So the problem is my end.

Any idea what would cause this? The Fami was purchased pre-AV modded from a shop in Japan, is there anything the modder could have done to cause it?

I've cleaned the slot contacts. I've got 15 original carts here that all work fine - but I do have a Chinese 150-in-1 pirate cart which also doesn't work (blank screen, not green screen). I had assumed the Chinese cart was faulty but now I'm wondering if there's a connection between that and the Everdrive issue. I don't have access to another Famicom, or even a NES, to test this on right now.

I bought the Fami just so I could use an Everdrive so this is quite annoying!
Probably video ram on your everdrive were damaged. That's it. Or M2 signal does not working on your famicom, some games may work fine without M2, but not everdrive
« Last Edit: October 02, 2015, 09:30 AM by KRIKzz »

Offline Kir98

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: New Everdrive N8 - Green screen + garbled graphics
« Reply #5 on: September 21, 2017, 08:16 PM »
Hello!
I have the same problem as in 1 post of this topic.
The first time showed a gray screen, and then a green one.
Now all the time shows a green screen at startup.

Other Dandy cartridges work.
It worked and suddenly stopped running.
What could be the problem? The Everdrive N8 without I2C and USB ports.

Offline asper

  • Newbie
  • *
  • Posts: 9
  • Karma: +1/-0
    • View Profile
Re: New Everdrive N8 - Green screen + garbled graphics
« Reply #6 on: February 01, 2020, 06:10 PM »
Sorry to resume this topic but I think I got the real root of this issue:

the problem seems to be the CPU (chip named RP2A03); if you have RP2A03 you will probably have issues while using RP2A03G (chip revision G) all the problems seem to be gone. RP2A03 may be named just RP2A03 or RP2A03H or with other letters; G letter seems to be the best one for compatibility with EverDrive and multi-in-1 cartridges (usually black screen with multi-in-1).
« Last Edit: February 01, 2020, 06:13 PM by asper »