Author Topic: Games Not Working / Bug Reporting Thread  (Read 43956 times)

0 Members and 1 Guest are viewing this topic.

Offline Jincman

  • Newbie
  • *
  • Posts: 22
  • Karma: +1/-0
    • View Profile
Re: Games Not Working / Bug Reporting Thread
« Reply #75 on: September 02, 2016, 02:18 PM »
Space Shuttle Project (USA); the graphic of the Space Shuttle at the very beginning is all screwed up.

This is still an issue ... for whatever reason.

I noticed the scrambled graphics last night ... again.

Offline GadgetUK

  • Jr. Member
  • **
  • Posts: 62
  • Karma: +2/-0
    • View Profile
Re: Games Not Working / Bug Reporting Thread
« Reply #76 on: September 02, 2016, 03:35 PM »
Space Shuttle Project (USA); the graphic of the Space Shuttle at the very beginning is all screwed up.

This is still an issue ... for whatever reason.

I noticed the scrambled graphics last night ... again.
I think its an issue related to mirroring - I could be wrong, but it looks that way (notice how if you reset it sometimes the bottom half of the shuttle is OK).  I think Mapper 1 gives control to the program over H or V mirroring and I think that probably is used in this game.  I did notice that Adams Family seems to work using the same mapper and the cart DB seems to suggest that has control over mirroring as well but I am not sure without digging into the ROM code to see if that game uses it, or if that has a similar problem or not.

Offline Great Hierophant

  • Sr. Member
  • ****
  • Posts: 292
  • Karma: +19/-0
    • View Profile
Re: Games Not Working / Bug Reporting Thread
« Reply #77 on: September 03, 2016, 07:19 PM »
Space Shuttle Project does work correctly on the NES PowerPak.  MMC1 games control mirroring in through the mapper chip.  The type of error I have seen suggests that it is a CHR bankswitching issue, not a mirroring issue.
Check Out My Vintage Video Game & Computing Blog : http://nerdlypleasures.blogspot.com/

Offline GadgetUK

  • Jr. Member
  • **
  • Posts: 62
  • Karma: +2/-0
    • View Profile
Re: Games Not Working / Bug Reporting Thread
« Reply #78 on: September 03, 2016, 08:05 PM »
Space Shuttle Project does work correctly on the NES PowerPak.  MMC1 games control mirroring in through the mapper chip.  The type of error I have seen suggests that it is a CHR bankswitching issue, not a mirroring issue.
Very interesting!  I did wonder what if anything we could do about it.  I spent some time last night looking at the ROM and the header but I didn't get very far.  I don't think it is mirroring because the feature seems to work on other ROMs with the same header and mirror type.

Offline Erizisto

  • Newbie
  • *
  • Posts: 19
  • Karma: +3/-0
    • View Profile
Re: Games Not Working / Bug Reporting Thread
« Reply #79 on: September 04, 2016, 08:58 PM »
I played through Space Shuttle Project not too long ago.  The game is playable from start to finish, as none of the gameplay screens are affected by this display problem.

There seems to be only a handful of screens throughout the game that have this issue.  The title screen, the pre-launch cockpit screen, and some (but not all) of the post-mission screens, like the newspaper if I recall correctly.

I found this old forum post that looks like it might explain the issue.  Maybe someone will understand the technical part better than I can.

http://forums.nesdev.com/viewtopic.php?t=4243#p35209

Quote
Part way down the screen its switching which pattern table is used for the background. Those emulators aren't getting that switch so the bottom half is using the same tile set as the top half. Its doing that on scanline ~119 (likely sprite 0 hit) by changing the $C000 MMC1 register to select a 4KB chr bank at $1000.

Hope this helps.  :)

Offline Retro Rah

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: Games Not Working / Bug Reporting Thread
« Reply #80 on: October 23, 2016, 10:59 PM »
Great work everyone!

Not sure if i am helping or not but i would like to report:

I have not found a working copy of Power Blade 1 OR 2.

Carry on

Offline thecavalry

  • Jr. Member
  • **
  • Posts: 97
  • Karma: +11/-0
    • View Profile
Re: Games Not Working / Bug Reporting Thread
« Reply #81 on: October 24, 2016, 11:02 AM »
Great work everyone!

Not sure if i am helping or not but i would like to report:

I have not found a working copy of Power Blade 1 OR 2.

Carry on

Dunno why you wanted to resurrect an old post AND create a new post of your own to say the same thing.

You need to find the smokemonster everdrive pack on the epforums. Those copies of Powerblade 1 and 2 work. If that's what you have, redownload the pack. Reformat your sd. Reload the software.

Offline Retro Rah

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: Games Not Working / Bug Reporting Thread
« Reply #82 on: October 24, 2016, 07:43 PM »
Great work everyone!

Not sure if i am helping or not but i would like to report:

I have not found a working copy of Power Blade 1 OR 2.

Carry on

Dunno why you wanted to resurrect an old post AND create a new post of your own to say the same thing.

You need to find the smokemonster everdrive pack on the epforums. Those copies of Powerblade 1 and 2 work. If that's what you have, redownload the pack. Reformat your sd. Reload the software.

Some things are not for you to understand. Thank you for the information, I will look into it and hopefully achieve my quest!