Author Topic: How to update firmware to 1.15?  (Read 5587 times)

0 Members and 1 Guest are viewing this topic.

Offline StarshipUK

  • Newbie
  • *
  • Posts: 14
  • Karma: +2/-0
    • View Profile
How to update firmware to 1.15?
« on: April 04, 2013, 03:54 AM »
I am still having problems getting USA Games to load on my Everdrive 64, while every Japan game loads fine (WHY IS IT ALWAYS ME ARGH!!!) and have noticed it has an old firmware 1.12.

Firmware 1.1.5 says if fixes: 1) boot/reboot hangs was fixed

So I am wondering if updating the firmware might fix the issue. But how can I update to this firmware? I can not fine any instructions anywhere or options inside the cart menus, despite the website saying:
Firmware updates can be performed easily, using a SD card.

Can someone help please before I loose the will to live.

Offline saturnu

  • ヽ(^o^)丿
  • Hero Member
  • *****
  • Posts: 1182
  • Karma: +156/-0
    • View Profile
    • :D
Re: How to update firmware to 1.15?
« Reply #1 on: April 04, 2013, 05:07 PM »
hi, here is the link to the related video:

ED64 firmware update tutorial
http://www.youtube.com/watch?v=64uI7r7KCzg

Offline KRIKzz

  • Administrator
  • Hero Member
  • *****
  • Posts: 3356
  • Karma: +502/-2
    • View Profile
Re: How to update firmware to 1.15?
« Reply #2 on: April 05, 2013, 01:30 AM »
I still belive that your problem not in firmware or region, japanese and usa region is same, original japanese cart will work on US system and visa versa, cuz they 100% identical. In terms of hardware no any differences between jap and usa systems, key on the plastick shell is the only difference

Offline StarshipUK

  • Newbie
  • *
  • Posts: 14
  • Karma: +2/-0
    • View Profile
Re: How to update firmware to 1.15?
« Reply #3 on: April 07, 2013, 12:44 AM »
Thanks. I have created another thread asking if anyone else could try the exact same config I have to try and for once and for all solve this issue. There must be a way to get this USA No Intro set to work, and I can't see how I am the only person having this problem.

Offline KRIKzz

  • Administrator
  • Hero Member
  • *****
  • Posts: 3356
  • Karma: +502/-2
    • View Profile
Re: How to update firmware to 1.15?
« Reply #4 on: April 07, 2013, 05:56 PM »
would be good if you will try goodset, i use goodset only

Offline StarshipUK

  • Newbie
  • *
  • Posts: 14
  • Karma: +2/-0
    • View Profile
Re: How to update firmware to 1.15?
« Reply #5 on: June 10, 2013, 04:56 AM »
Possibly the longest on going problem ever (sorry)- But I finally managed to get hold of the Goodtools set before UG went offline - I have tried some USA ROMS from the set and none of them work either, so I am now thinking the cart is faulty or there is something wrong with it.

The only thing I have not tried is updating the firmware - I did buy a JTAG USB Blaster, but dont have a JTAG socket to plug it into (Stupid me thinking it would come with this!), but from what KRIKzz has said in other posts, it sounds like updating the firmware will not fix the problem anyway.

Checking my E-Mail I can see I bought it on 3 Sep 2011: Description:everdrive-64, Item no:14353687 , Option: ver. 1.01 (USB) w/ CIC-6102 from kitsch-bent.com but after all the this time I doubt I can send it back for replacement or repair now anyway  :(

It looks like my only option is to buy a V2 (gonna order one now hoping it will arrive before a big gaming event at the end of the month), and throw this one in the bin - just my ongoing bad luck I guess :(


Offline StarshipUK

  • Newbie
  • *
  • Posts: 14
  • Karma: +2/-0
    • View Profile
Re: How to update firmware to 1.15?
« Reply #6 on: June 10, 2013, 06:22 AM »
As one final test I just tried something I have not tried yet - A different OS. I noticed is was still running 1.28, so I updated to 1.29 and now every USA rom I have tried (No Intro or Goodtools) has loaded with no problems - after all this time it looks like there may have been a bug in 1.28 which was causing the problem.

I had just ordered another N64 Everdrive from Retrogate. Can this be cancelled? Sorry to be a pain.