Author Topic: No picture ED64 v3.03  (Read 3678 times)

0 Members and 1 Guest are viewing this topic.

Offline Linkmunken

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
No picture ED64 v3.03
« on: July 26, 2016, 11:05 PM »
Hi all!

I'm fairly new to this whole everdrive stuff. I've got one for the NES, SNES and for Mega Drive. All of them were no real hassle to get up n' running. The Everdrive 64 proved to be a bit trickier.

So, here's my story. I bought a brand new cart from an online store here in Sweden called Retrospelboxar.se. Opening the cart up the circuit bord tells me it's a v3.03.
I downloaded  the OS-V2.12.zip from Krikzz.com, unzipped it and dragged the ED64 folder to my 16GB Sandisc Ultra SD card. I then went on and created another folder for my ROM games and put some in. That should have been it right? Wrong.

When I try to start the cartridge up nothing happens. I mean nothing. Black screen, no sound. Same thing if I try it without the SD card inserted. Nothing.

So I tried to reformat the SD card (on a MAC though) setting the format to FAT. "Reinstalled" the folders and had yet another go. Nothing!
Tried cleaning both the cart and the actual console aaand...nothing. *sob*

My original carts boot just fine on my PAL N64. I use nothing but original cords and I have an Expansion Pak installed. What the hell am I doing wrong?!
I can see no trace of any tearing och the ED64, no trace of bumps or scrape marks.

Please help me get this fixed! I can't even stand the thought of the procedure I would have to go thru sending it back and having to wait for another one.

Offline Linkmunken

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: No picture ED64 v3.03
« Reply #1 on: July 26, 2016, 11:15 PM »
Oh! And one more thing. Looking at my order from the store it says "CiC chip: no". But as I remember it I wasn't even given the option. Is that what causing my issue?

It does however state in the tech specs that "CIC boot emulator. Enough to have CIC6102/CIC7101 to play any games". What ever that really means...

Offline Aroenai

  • Sr. Member
  • ****
  • Posts: 264
  • Karma: +20/-0
  • Sentient Hunk of Green Cheese
    • View Profile
Re: No picture ED64 v3.03
« Reply #2 on: July 26, 2016, 11:41 PM »
When you look at the board do you see a switch that says NTSC/PAL, or is there a space where it looks like a chip is missing?

The Everdrive 64 still needs a CIC chip, either original or an UltraCIC II (this is has the NTSC/PAL switch and can bypass other protections), to boot on the console and it also needs to match your console's region.
---
Mostly working on Zelda OoT & MM GC patches
Also, breaking region protections
Everdrive 64 v2.01 modified with an UltraCIC II, 64drive HW2

Offline Linkmunken

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: No picture ED64 v3.03
« Reply #3 on: July 26, 2016, 11:58 PM »
I just looked in to that but mine does not have a switch, which is weird because when I ordered it was not like I opt out from a CiC chip. All I could choose from was either v2.5 or v.3 and the color of the shell...

So what's the best thing to do now? Send it back or have someone install the right components? How could it even be possible to order a cartridge without all the necessities?

Offline FeverDrive

  • Hero Member
  • *****
  • Posts: 1292
  • Karma: +54/-0
  • Blast Processing advocate
    • View Profile
Re: No picture ED64 v3.03
« Reply #4 on: July 27, 2016, 09:47 PM »
It does however state in the tech specs that "CIC boot emulator. Enough to have CIC6102/CIC7101 to play any games". What ever that really means...
That means that if your machine is NTSC you need to install an original CIC6102, if yours is PAL you have to install an original CIC7101 and the Everdrive emulates the other CIC chips depending on the game.
(In any case it's better to install an UltraCIC II)

Please ask the store from where you ordered the product if your Everdrive did come with a CIC chip, also you can open up the cartridge and see for yourself if there is a CIC installed, post photos here if you aren't sure.
WELCO
METOT
HENEX
TLEVEL

Offline Aroenai

  • Sr. Member
  • ****
  • Posts: 264
  • Karma: +20/-0
  • Sentient Hunk of Green Cheese
    • View Profile
Re: No picture ED64 v3.03
« Reply #5 on: July 27, 2016, 10:35 PM »
Order one of these: http://www.aliexpress.com/item/UltraCIC-PAL-NTSC-Version-CIC-Chip-for-EVERDRIVE-64-ED64Plus-N64-Flash-Cart/32431977887.html

Then have someone with fine soldering skills install it on the board for you.
---
Mostly working on Zelda OoT & MM GC patches
Also, breaking region protections
Everdrive 64 v2.01 modified with an UltraCIC II, 64drive HW2

Offline Linkmunken

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: No picture ED64 v3.03
« Reply #6 on: July 29, 2016, 01:55 PM »
Contacted the store and sure enough - I'd ordered a cart with no CiC installed. Bummer. I'm gonna send it back to have it fixed. Thank you all for support!