Author Topic: Micro SD issues with EverDrive GBA  (Read 128549 times)

0 Members and 1 Guest are viewing this topic.

Offline narshe

  • Newbie
  • *
  • Posts: 17
  • Karma: +1/-0
    • View Profile
Re: Micro SD issues with EverDrive GBA
« Reply #90 on: August 19, 2016, 06:05 PM »
I tried several different class and size Sandisk cards, and none of them worked. I tried all the various ways of formatting them too.

I went to Target and bought a Dane brand 32 GB class 10 I, and it works great out of the box. No formatting needed. Game saves work fine. This card doesn't seem to be on their website at all, but is in stores.

Offline Sgt. Sasuke

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: Micro SD issues with EverDrive GBA
« Reply #91 on: August 19, 2016, 10:29 PM »
Still no confirmation on ADATA? It wasn't shown on the spreadsheet. (Great thing BTW. Much helpful.)

Offline retronintendonerd

  • Newbie
  • *
  • Posts: 24
  • Karma: +0/-0
    • View Profile
    • Candi's Classic Game Shrine
Re: Micro SD issues with EverDrive GBA
« Reply #92 on: August 20, 2016, 05:04 AM »
The 2gb is the only one that works and that even took some screwing with. That one originally gave the FAT error.

Out of interest, what kind of screwing around got it to work? I have my 2GB microSD from my R4 in my ED, and that works, but the 32GB microSD I want to use gives an F6 "FAT system not found" error. This is despite me having zeroed the first 15MB or so of the disk, repartitioning, and making a FAT32 volume with what seem to be the same parameters as the card I have that works, and I am most confused. (A different microSD I have of the same type gives me the D3 error that I assume most people in this thread are referring to, even if an error code is rarely explicitly mentioned.)

Perhaps I shouldn't read too much into the different error message and it's actually the same problem, just behaving slightly differently.
My husband said he took the formatting advice from the first few posts on this thread.

Offline dr0psh0ck

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: Micro SD issues with EverDrive GBA
« Reply #93 on: August 20, 2016, 05:50 AM »
Dane brand works, just like the ^ ^ above poster.
I got the 16GB sdhc class 10 u1 from Target, worked right out of the box.

Although, when I powered it on, it prompted for a reset to default settings?
anyway, it works... for now : P

Offline Shadow666

  • Sr. Member
  • ****
  • Posts: 465
  • Karma: +13/-0
    • View Profile
Re: Micro SD issues with EverDrive GBA
« Reply #94 on: August 20, 2016, 05:58 AM »
Dane brand works, just like the ^ ^ above poster.
I got the 16GB sdhc class 10 u1 from Target, worked right out of the box.

Although, when I powered it on, it prompted for a reset to default settings?
anyway, it works... for now : P

"prompted for a reset to default settings"

is normal

Offline EthanW

  • EthanW
  • Full Member
  • ***
  • Posts: 201
  • Karma: +9/-0
  • Was "Ridj"
    • View Profile
Re: Micro SD issues with EverDrive GBA
« Reply #95 on: August 20, 2016, 12:29 PM »
the default settings thing is normal
Everdrives i own: EDN8, EDGB, EDGBx7, EDGBAx5, EDGG

Offline Deoncy

  • Newbie
  • *
  • Posts: 19
  • Karma: +1/-0
    • View Profile
Re: Micro SD issues with EverDrive GBA
« Reply #96 on: August 20, 2016, 02:01 PM »
My husband said he took the formatting advice from the first few posts on this thread.
Ah, I've pretty much followed that with lots of other FAT settings and have yet to make mine work. Thanks anyway! (A 2GB card is more than enough for me for the moment anyway.)

Offline stlpaul

  • Jr. Member
  • **
  • Posts: 54
  • Karma: +3/-0
    • View Profile
Re: Micro SD issues with EverDrive GBA
« Reply #97 on: August 20, 2016, 06:03 PM »
Sandisk class 4, 32GB. Error D3
Adata class 10/UHS I 16GB. Error D3.

Both cards are formatted with the official SD Foundation format utility which sets proper cluster sizes, alignments, etc. Same as when a card is brand new. Both work on other everdrives.

I then used windows to format with 4K cluster size, this results in error F6 (FAT system not found). Same with 8K and 16K.

Then I reformatted with 32K cluster size, this resulted in FILE NOT FOUND error 38 (but the file is definitely there) . Formatted 64K, same error 38.

So it would seem to perhaps be a file system or partition issue more than a card issue... Still trying to find the right combination. My computer is not near my gamecube so it's a slow process to try these combinations. I'm try some repartitioning later today.

Offline chopsticksamurai

  • Newbie
  • *
  • Posts: 17
  • Karma: +1/-0
    • View Profile
    • ChopstickSamurai.com
Micro SD issues with EverDrive GBA
« Reply #98 on: August 20, 2016, 10:07 PM »
I had no luck with a SanDisk 32GB Pixtor card I had, but a old 2GB Kingston worked fine. I took a chance on romance and bought this card:

Kingston Digital 32 GB Class 4 microSDHC Flash Card with SD Adapter (SDC4/32GBET):

https://www.amazon.com/dp/B00DYQYLP2/ref=cm_sw_r_cp_api_xMkUxb5JCTZG1

And  so far I've had no problems with it working with my Everdrive.  I just formatted it normally on my Windows 7 PC. Hope this helps you guys out!



Offline Floob

  • Jr. Member
  • **
  • Posts: 59
  • Karma: +7/-0
    • View Profile
    • Retrogaming on a Raspberry Pi
Re: Micro SD issues with EverDrive GBA
« Reply #99 on: August 20, 2016, 11:32 PM »
Retro Gaming on the Raspberry Pi
http://www.youtube.com/c/SmartretroCoUk-Gaming

Offline rayrayrayraydog

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Micro SD issues with EverDrive GBA
« Reply #100 on: August 21, 2016, 06:17 AM »
Another confirmation for the 32GB Kingston Class 10 -- this exact item: https://www.amazon.com/gp/product/B00519BEQY/ref=oh_aui_detailpage_o00_s00?ie=UTF8&psc=1

Use the method posted earlier in the thread:
- diskpart
- select disk XXX
- create partition primary
- format fs=fat32 quick

I got one SDIO error after copying over the No-Intro rom-set, but then it worked every time after that. 

Offline phoenixdownita

  • Sr. Member
  • ****
  • Posts: 438
  • Karma: +36/-7
    • View Profile
Re: Micro SD issues with EverDrive GBA
« Reply #101 on: August 21, 2016, 09:30 PM »
Anyone had the chance to try the X5 on more than one GBA?

Mine will arrive in due time and I'll have available a GBA Micro, a DS first series and the GBPlayer, but until then I have no clue as to what SD card to buy (or simply wait it out a little).

Anyone tried to see if the issues are only with specific combinations?

[anyway given the high rate of issues I expect Krikzz to release an updated OS to address at least some of the incompatibilities]

Offline lee4

  • codetype specialist
  • Hero Member
  • *****
  • Posts: 776
  • Karma: +45/-0
    • View Profile
    • gamehacking.org
Re: Micro SD issues with EverDrive GBA
« Reply #102 on: August 21, 2016, 10:05 PM »
Anyone had the chance to try the X5 on more than one GBA?

Mine will arrive in due time and I'll have available a GBA Micro, a DS first series and the GBPlayer, but until then I have no clue as to what SD card to buy (or simply wait it out a little).

Anyone tried to see if the issues are only with specific combinations?

[anyway given the high rate of issues I expect Krikzz to release an updated OS to address at least some of the incompatibilities]
mostly Sandisk brand having problem
ED64 v2.0, 3.0 & X7 | EDMD v3 | MEGAED X7 M15 v2.01 | TED v2.4 | EDN8 v1.2N | SED v2.1 | SD2SNES rev E1 & PRO rev.B | EDGB v1.1 & X7 M17 rev B | EDGBA X5 M16 rev A
Super NT | Mega SG | Super Retro Advance | SGB v1 | PCE+SSD3

Offline Mobyone

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: Micro SD issues with EverDrive GBA
« Reply #103 on: August 21, 2016, 10:38 PM »
Mine is working with my DS tank and my GBA micro but not with my GBA SP (no nintendo logo during bootscreen).

I only have two micro SD cards: Kingston 32GB class 10 and Sandisk 2GB.
Both cards are working fine.

Offline butfluffy

  • Hero Member
  • *****
  • Posts: 860
  • Karma: +46/-8
    • View Profile
Re: Micro SD issues with EverDrive GBA
« Reply #104 on: August 22, 2016, 12:29 AM »
i'm waiting on my new sd card to arrive before trying my x5 but al my other everdrives work fine with sandisk cards of various sizes and ages.
 hy would sandisk cards start having issues on the newest everdrive type, it don't make sense, surely card support wont get worse over time? if anything older everdrives/versions should be having sd card issues.
 what a annoying situation this is for so many users, i hope my card works when it arrives but i ordered it before reading posts here about card issues and as usual i ordered sandisk because i never have problems withy that brand and did not expect and issue with sandisk on an everdrive product.