Author Topic: Famicom N8 (+ adapter) gets no power on US frontloader (NESRGB modded)  (Read 2556 times)

0 Members and 1 Guest are viewing this topic.

Offline Meista

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
I'm trying to use a Famicom N8 + 60 to 72 pin adapter (one diy adapter and one cheap-ish asian adapter)
on my NESRGB modded US frontloader, but the cart doesn't seem to get any power. Not even the LED is blinking.

It is working fine on my Famicom (this one isn't NESRGB modded, though).

I'm using the same power supply for both consoles (9V DC 1,3A) and everything works fine,
except for the N8 on the frontloader. Shouldn't 1,3A be plenty to power the NES, NESRGB board and N8 ?
I know that the NES usually wants AC, but it's working fine with normal carts.

I don't have any other Famicom carts to test the adapter with.

Also, I'm in Europe, so the original power supply is not an option.
I could try to get my hands on a european SNES power supply.
That one is still outputting 1,3A, but at least it's AC, if that even makes a difference ?!

As far as I know, the NES still has the old 7805.

Has anyone encountered a similar problem before ?
« Last Edit: April 06, 2017, 10:38 AM by Meista »


Offline Meista

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
http://krikzz.com/forum/index.php?topic=2553.msg25532#msg25532

totally different problems, i'm not getting any glitches, i'm getting nothing at all.


http://krikzz.com/forum/index.php?topic=2554.0

i know the basics, cause the n8 is working flawlessly on another console.
but yeah, i might try another power supply.

Offline Meista

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
Just tried an NES N8 in the frontloader and it works without any problems, so it is definitely not the power supply.

Anyone else got any sugggestions ?