Author Topic: Everdrive 64v3 acts up when starting certain roms  (Read 2588 times)

0 Members and 1 Guest are viewing this topic.

Offline Sjimpanservogn

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Everdrive 64v3 acts up when starting certain roms
« on: September 21, 2016, 09:39 PM »
Hi!
I'm having some issues with my newly aquired Everdrive 64 v3. I was unsure wether or not to make a thread for this, but I've scoured these forums for a long time now for a solution, and I'm at my witts end. I just want to make sure that there isn't something I've missed before contacting Krikkz about this:

So, the Everdrive 64 seems to working fine with alot of the games I've tried, but starts acting up when I start certain games. Some examples are Mario Golf, Mario Party 1 and 2, and Snowboard Kids 1 and 2. Every time I start one of these games, I get the warning message "Corrupted ROM, BAD CRC" and the screen goes to black.


When I reset or turn the console off and on after this, I'm usually welcomed by the error screen: "Error: FA + SDR, FAT system not found".


Sometimes, the Error screen doesn't pop, and Everdrive seems to start normally, but all text in the file browser is messed up. At this point, the error screen usually show ups after loading any rom.

After this, I will keep getting the same error, resetting or turning off and on won't help. I usually have to format the SD card in order to be able to start Everdrive normally again. Sometimes in sufficient to just turn of the console, remove the SD card, and putting it back in.

I'm using the roms from epforums http://www.epforums.org/showthread.php?101715-MULTI-ROM-SET-EverDrive-Packs-Release-Thread which should be good to go for use with the Everdrive. I've tried 4-5 other roms from other sources for these games, and all of them result in the same problems.

I've tried 5 different SDHC cards, and several ways to format them. For the most part I've been formating them to Fat32, allocation unit size 32 kilobytes, cardname empty.
I've tried using the normal Windows 10 formater, and the SD Formatter 4.0.
I've tried using the Everdrive 64 on a PAL console (with the UltraCiC switch set to PAL) and on a JPN console (with the UltraCiC swith set to NTSC).
I've tried several OSes, but been experimenting mosly using the 2.12 version.

With all the different setups I've tried, the results are the same. The games that work, work fine regardless of setup. The games that don't work, mess the system up, regardless of setup.

I would really appreciate it if anyone could offer any tips or could point out if I'm doing something wrong. Thanks!
« Last Edit: September 23, 2016, 02:37 PM by Sjimpanservogn »

Offline rafaelalvesals

  • Hue Hue BR BR
  • Sr. Member
  • ****
  • Posts: 359
  • Karma: +19/-0
    • View Profile
Re: Everdrive 64v3 acts up when starting certain roms
« Reply #1 on: September 21, 2016, 10:31 PM »
did you use a normal size sd card or a mini with adapter?

Offline Sjimpanservogn

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Everdrive 64v3 acts up when starting certain roms
« Reply #2 on: September 21, 2016, 11:19 PM »
I've tried several types, these are the SD cards I've tried so far:

32GB  Sandisk Micro SD Class 4 in a SD adapter (new, from a big retail chain),
8GB Sony Mini SD in a SD Adapter (from a older camera lying around),
32 GB Kingston SD Class 4 (new, from a big retail chain),
16 GB Sandisk Extreme SD Class 10 (new, from a big retail chain).
16 GB Sony SDHC UHS-I (new, from a big retail chain).

All of them seems to be netting the same results described in OP.
« Last Edit: September 23, 2016, 02:24 PM by Sjimpanservogn »

Offline thecavalry

  • Jr. Member
  • **
  • Posts: 97
  • Karma: +11/-0
    • View Profile
Re: Everdrive 64v3 acts up when starting certain roms
« Reply #3 on: September 23, 2016, 01:58 AM »
Have you done the self test from the Everdrive 64 menu options? Does everything check out OK? Or is there a failure somewhere in the hardware?

Offline Sjimpanservogn

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Everdrive 64v3 acts up when starting certain roms
« Reply #4 on: September 23, 2016, 02:31 PM »


I've tried doing the self test before running the games that mess it up, and it seems to be all OK at that point.
« Last Edit: September 24, 2016, 11:26 AM by Sjimpanservogn »