Author Topic: My Ultra Everdrive 64 v3 only shows a black screen...what am I doing wrong? :(  (Read 2911 times)

0 Members and 1 Guest are viewing this topic.

Offline Estil

  • Jr. Member
  • **
  • Posts: 64
  • Karma: +0/-0
    • View Profile
So I got an Ultra Everdrive 64 v3 from Stone Age Gamer (where I also got all my other Everdrives) and for whatever reason when I turn it on all I get is a black screen :(  I tried two sd cards already and I put in the ED64 folder downloaded from SAG exactly like I'm supposed to...what am I doing wrong?  I mean this is supposed to be the best N64 everdrive yet it won't work at all :(  I live in the US by the way.
« Last Edit: November 08, 2016, 08:16 PM by Estil »

Offline saturnu

  • ヽ(^o^)丿
  • Hero Member
  • *****
  • Posts: 1182
  • Karma: +156/-0
    • View Profile
    • :D
check the ultracic switch in the sdcard slot.
maybe it's set to the wrong tv-type.

Offline Estil

  • Jr. Member
  • **
  • Posts: 64
  • Karma: +0/-0
    • View Profile
I wasn't too happy about having to unscrew it, but YES, the little switch was in the PAL position (I guess seeing as how Ukraine is in Europe/PAL I guess it would make perfect sense for Krizz to have that set by default.  I switched to NTSC and it works mostly perfect...but for some reason the menu screen kinda looks like it's shaking a little (not the games thankfully).

So now I got Everdrives (which are like master keys for each console) for NES (N8), SNES (SDSNES), GEN/MS (Mega Everdrive), Everdrive GB, and GBA Everdrive X5...yay! ;D  I guess the Harmony (Atari 2600) should be next?
« Last Edit: November 08, 2016, 11:12 PM by Estil »

Offline KRIKzz

  • Administrator
  • Hero Member
  • *****
  • Posts: 3378
  • Karma: +508/-2
    • View Profile
Actually you do not need to unscrew it, you can toggle switch via SD hole. Those switch usually in NTSC position by default