Author Topic: [Solved] Issues with translated roms  (Read 3672 times)

0 Members and 1 Guest are viewing this topic.

Offline sonicjhn

  • Newbie
  • *
  • Posts: 42
  • Karma: +1/-0
    • View Profile
[Solved] Issues with translated roms
« on: November 25, 2016, 10:27 PM »
Hi everyone! Does the Everdrive 64 v3 has issues with translated roms?

I'm trying to play a Zelda Ocarina of Time rom with translation patch to portuguese (my language), and the game is showing some text glitches in some dialogues and eventually crashing at some point of the game.
« Last Edit: November 28, 2016, 06:11 AM by sonicjhn »

Offline MaarioS

  • Newbie
  • *
  • Posts: 46
  • Karma: +2/-0
    • View Profile
Re: Issues with translated roms
« Reply #1 on: November 25, 2016, 10:29 PM »
I tried out Zelda Ocarina of Time Polish translation and as I can remember it worked prefectly fine and I beat the entire game. Your patch is probably bad or incorrectly applied. Maybe PAL/NTSC issue??

Offline Aroenai

  • Sr. Member
  • ****
  • Posts: 264
  • Karma: +20/-0
  • Sentient Hunk of Green Cheese
    • View Profile
Re: Issues with translated roms
« Reply #2 on: November 26, 2016, 02:02 AM »
Which patch did you use?
---
Mostly working on Zelda OoT & MM GC patches
Also, breaking region protections
Everdrive 64 v2.01 modified with an UltraCIC II, 64drive HW2

Offline sonicjhn

  • Newbie
  • *
  • Posts: 42
  • Karma: +1/-0
    • View Profile
Re: Issues with translated roms
« Reply #3 on: November 28, 2016, 03:28 AM »
I tried out Zelda Ocarina of Time Polish translation and as I can remember it worked prefectly fine and I beat the entire game. Your patch is probably bad or incorrectly applied. Maybe PAL/NTSC issue??

What's the version of your Zelda ROM? 1.0 or 1.1?

I've tried these 2 roms with translation patch:

Legend of Zelda, The - Ocarina of Time (U) (V1.1) [T+Por1.0]             25.45 Mo   
Legend of Zelda, The - Ocarina of Time (U) (V1.1) [T+Por100%]             25.45 Mo
« Last Edit: November 28, 2016, 03:31 AM by sonicjhn »

Offline sonicjhn

  • Newbie
  • *
  • Posts: 42
  • Karma: +1/-0
    • View Profile
Re: Issues with translated roms
« Reply #4 on: November 28, 2016, 06:10 AM »
Problem solved! Thanks guys!

I've tried now the following rom revision, and now works fine: Legend of Zelda, The - Ocarina of Time (U) (V1.0) [T+Por1.5BetaFinal]

Looks like the original translation patch wasn't made to work properly with Zelda's 1.1 version.

Offline Aroenai

  • Sr. Member
  • ****
  • Posts: 264
  • Karma: +20/-0
  • Sentient Hunk of Green Cheese
    • View Profile
Re: [Solved] Issues with translated roms
« Reply #5 on: November 28, 2016, 04:58 PM »
There's a 1.7 patch by Fserve with some additional corrections if you're interested. http://www.romhackers.org/modules/PDdownloads/singlefile.php?cid=23&lid=58 (also for 1.0)

I'm also working on a patch for the GC roms with additional translated menu textures, right now it's only for Master Quest though.
---
Mostly working on Zelda OoT & MM GC patches
Also, breaking region protections
Everdrive 64 v2.01 modified with an UltraCIC II, 64drive HW2