Author Topic: Everdrive N8 with Hi-Def NES  (Read 3851 times)

0 Members and 1 Guest are viewing this topic.

Offline jaredprice

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Everdrive N8 with Hi-Def NES
« on: January 12, 2017, 08:23 PM »
I've read about the various issues others have had and am posting this because I don't see where anyone is describing this specific symptom. First, I have had my Everdrive work sporadically since installing the Hi-Def NES. Sometimes reseating the cart in my front loader would do the trick. Here recently, it's become almost unusable as little seems to work to get it to boot. I've reformatted the sd card and copied over the latest os and rom pack. Currently, when turning on the console I see a green screen then a blue screen and then it goes to black and hangs. I've tried the method of removing the HDMI cord during power on, waiting 5-10 seconds, and then plugging in and have had intermittent success (1 out of 10 tries). But shortly after gaining access to the Everdrive menu, things get corrupted and freeze. Any ideas on what might be going on here?

Offline protheanbeacon

  • Full Member
  • ***
  • Posts: 128
  • Karma: +6/-0
    • View Profile
Re: Everdrive N8 with Hi-Def NES
« Reply #1 on: January 12, 2017, 11:50 PM »
Did you install the Hi Def NES yourself or have a professional like Wes Almond of retrofixes.com (my go to guy for console modding) or Voultar (GameTechUS's recommended installer) install it for you?

If you installed it yourself maybe you made some sort of mistake that led to a short over time leading to your current Everdrive problems? (which then obviously wouldn't be Everdrive problems technically but that of a messed up Hi Def Nes install).

Or maybe surprisingly enough you just need to try a different SD card brand altogether?

And yes I know how ridiculous that last one sounds but for whatever reason I have found out personally through trial and error this is usually what ends up fixing 99.9% of ALL Everdrive related problems.

For example I have the best version of the Sega Genesis Everdrive and I had everything all set up and working perfectly but packed the Genesis away for several months and when I went to boot things up again the Everdrive no longer worked despite my various attempts to format and fix things and even put the latest OS on it, etc.

What finally DID end up fixing things for me was trying out a different card altogether and now it works like a charm again with the latest OS and everything.

So krikzz products can be a little bit finicky and weird at times but usually just trying a different SD card solves the problem.

I actually sent in an Everdrive 64 to krikzz engineer before as when I got it and tried things out on the SD card I had ready for it, it just gave me an error code.

The engineer sent it back to me without telling me what to do or if anything was wrong and I was pretty pissed trying to get it to work again and still getting the same error code.

Well somehow I had the bright idea finally to test out a different SD card and that totally solved the problem and where I finally figured out that this is typically the way to fix Krikzz's products.

I wouldn't be surprised if you even have to try a few different brands before getting things to work again.

Anyway if I knew this whole different SD card thing sooner it would've saved me about a month or two without my Everdrive 64.  :P
« Last Edit: January 12, 2017, 11:53 PM by protheanbeacon »
krikzz products I own: SD2SNES, Joyzz, Everdrive GB X7, Everdrive GBA X5, Mega Everdrive X7, Everdrive 64 v3, Everdrive N8, Turbo Everdrive v2, Master Everdrive X7.

Offline kjetil_f

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Re: Everdrive N8 with Hi-Def NES
« Reply #2 on: January 13, 2017, 12:42 PM »
For some reason the ROMs on my Everdrive are flickering when playing (no problem with the ED screen). When I try playing the same games from the original cartridge it seems to be no problems at all. The Everdrive ROMs are dumps from my actual cartridge so in theory they are identical.

I have not installed the kit myself, but used an installer recommended by game-tech.us, and he said that it seems like the red hdnes kit have some compatibility issues with PAL.

edit: Seems it have some troubles with the PAL ppu chips, rp2c07-0 rev
« Last Edit: January 13, 2017, 12:45 PM by kjetil_f »

Offline protheanbeacon

  • Full Member
  • ***
  • Posts: 128
  • Karma: +6/-0
    • View Profile
Re: Everdrive N8 with Hi-Def NES
« Reply #3 on: January 14, 2017, 10:04 PM »
@kjetil_f

You could try testing the Hi Def NES's despeckle feature and see if that solves your problem.

I was having a problem with Super Mario Brothers 3 where a genuine SMB3 cart had perfectly stable picture/background graphics yet using the Everdrive N8 I'd get a shaking screen whenever I began flying with Mario's regular racoon power up (not the Tanooki suit).

Well once I selected level 1 despeckle from the Hi Def NES's menu options SMB3 on the Everdrive performed just as flawlessly as the real cart.
krikzz products I own: SD2SNES, Joyzz, Everdrive GB X7, Everdrive GBA X5, Mega Everdrive X7, Everdrive 64 v3, Everdrive N8, Turbo Everdrive v2, Master Everdrive X7.

Offline FrenchyToasty

  • Full Member
  • ***
  • Posts: 127
  • Karma: +9/-0
    • View Profile
Re: Everdrive N8 with Hi-Def NES
« Reply #4 on: January 16, 2017, 04:16 AM »
I installed mine myself and everything works great, you have to play with despeckle option on many games so it's not visually glitched out.

Offline kjetil_f

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Re: Everdrive N8 with Hi-Def NES
« Reply #5 on: January 20, 2017, 10:18 AM »
I've been playing around with despeckle feature and seems like SMB3 (EDN8 version) works better with level 1 despeckle, but it still glitches when i am in the overworld or in a place with black background (like the end of the level). Tried Mega Man 2 (EDN8 version) as well and I don't get any glitches (almost) when playing, but the menu screen of the game are shaking  :o Basically none of the games I've been trying from my Everdrive are glitchfree no matter what despackle level I have been using  :'(

Offline thecavalry

  • Jr. Member
  • **
  • Posts: 97
  • Karma: +11/-0
    • View Profile
Re: Everdrive N8 with Hi-Def NES
« Reply #6 on: January 20, 2017, 08:52 PM »
Check that the ppu is seated properly inside and test for cold soldering points. You might have an issue with the ppu connection. I haven't had to tool with any settings for my hi def mod and i don't have any of the issues you are describing

Offline kjetil_f

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Re: Everdrive N8 with Hi-Def NES
« Reply #7 on: January 30, 2017, 09:51 AM »
Too bad I don't have the tools nor the skills to do so :-\

Offline thecavalry

  • Jr. Member
  • **
  • Posts: 97
  • Karma: +11/-0
    • View Profile
Re: Everdrive N8 with Hi-Def NES
« Reply #8 on: January 30, 2017, 08:50 PM »
Then you need to reach out to whoever did your mod work and let them troubleshoot how to fix the problem for you. I don't have any issues with mine, so maybe they need to recheck their work or fix something.

Offline flamepanther

  • Newbie
  • *
  • Posts: 29
  • Karma: +1/-0
    • View Profile
Re: Everdrive N8 with Hi-Def NES
« Reply #9 on: January 31, 2017, 09:38 PM »
If reseating the cart used to sometimes work, I would try reconditioning or replacing the 72 pin connector before doing anything more involved.