Author Topic: krikzz, are you interested in debugging white artifacting issue?  (Read 14116 times)

0 Members and 1 Guest are viewing this topic.

Offline desy

  • Newbie
  • *
  • Posts: 24
  • Karma: +0/-0
    • View Profile
In reference to http://krikzz.com/forum/index.php?topic=5295.0

The community is finding that some NES models exhibit "white artifacting" for certain games on the everdrive. Basically little lines flicker very quickly around the screen with a ranging interval of 0.5s-5s.

Is there any specific data that you would be interested in seeing? Is this something you think could be fixed through a software update, or is it just a HW incompatibility (ie. bad luck NES console, or future EDN8 HW rev) ?

An NES exhibiting this behavior could be mailed to you as well if you are unable to reproduce.  I still need to pop open my NESes and see if they match up to findings from Donholio and zansatsu0 and folks

Some observations:
  • Approximately 8 out of my 10 NES I own show this issue. 2 of them don't.
  • Not all games exhibit this. Ones that do include Tetris title, Punch-Out while boxing
  • Original carts of games like Tetris and Punch-Out have no issue on any systems
  • Does not seem related to the wall power brick itself, likely the type of PSU
  • NES-CPU-6 + ALPS power board = no issue
  • NES-CPU-8 + Mitsumi power board = no issue
  • NES-CPU-10 + Mitsumi power board = ISSUE
  • NES-CPU-10 + ALPS power board = ISSUE (but less bad)
  • The problem seems to always follow the board / EVN8 combo
  • Recapping didn't seem to help
  • Not related to 72PIN connection issues, both cleaned and replaced did not help across many systems.
  • Members are willing to do scope probing if that helps

Please let us know if further investigation may deem fruitful. Thank you, and we love your products!




Offline thecavalry

  • Jr. Member
  • **
  • Posts: 97
  • Karma: +11/-0
    • View Profile
Re: krikzz, are you interested in debugging white artifacting issue?
« Reply #1 on: January 28, 2017, 07:24 PM »
I don't have this issue on any of my NES systems with the Everdrive. I own both Everdrive N8 NES and Famicom. I use an AV Famicom (with Hi-def NES mod), NES (standard composite), and an AVS.

I have never seen these artifcats on my games, and Metroid and Punch-out! are definitely games I have played on all three systems with both everdrives.

Offline desy

  • Newbie
  • *
  • Posts: 24
  • Karma: +0/-0
    • View Profile
Re: krikzz, are you interested in debugging white artifacting issue?
« Reply #2 on: January 28, 2017, 08:04 PM »
Yeah seems hit or miss depending on the NES. Try Nintendo's Tetris and watch the first splash to see if you notice anything.

Offline thecavalry

  • Jr. Member
  • **
  • Posts: 97
  • Karma: +11/-0
    • View Profile
Re: krikzz, are you interested in debugging white artifacting issue?
« Reply #3 on: January 29, 2017, 01:02 AM »
Just tested on the AV Fami since it was nearby. No artifacts.

Where are you sourcing the ROMs from?

Offline Donholio

  • Newbie
  • *
  • Posts: 4
  • Karma: +2/-0
    • View Profile
Re: krikzz, are you interested in debugging white artifacting issue?
« Reply #4 on: January 29, 2017, 04:26 AM »
I usually source from SmokeMonster ROM set. The issue follows the board revision. CPU-10 systems I have all show this issue.

Offline brianvgplayer

  • Sr. Member
  • ****
  • Posts: 281
  • Karma: +5/-0
    • View Profile
Re: krikzz, are you interested in debugging white artifacting issue?
« Reply #5 on: January 29, 2017, 04:43 AM »
One thing I noticed is that the latest stable firmware for AVS doesn't have the artifacting issue, but the beta firmware does.

Offline jordiway73

  • Newbie
  • *
  • Posts: 8
  • Karma: +2/-0
    • View Profile
Re: krikzz, are you interested in debugging white artifacting issue?
« Reply #6 on: January 29, 2017, 11:42 PM »
I thought it was my TV was going bad lol
« Last Edit: April 09, 2017, 02:35 PM by jordiway73 »

Offline desy

  • Newbie
  • *
  • Posts: 24
  • Karma: +0/-0
    • View Profile
Re: krikzz, are you interested in debugging white artifacting issue?
« Reply #7 on: February 01, 2017, 02:54 AM »
We are seeing the issue with front-loader NES.

Offline Brachabre

  • Newbie
  • *
  • Posts: 36
  • Karma: +1/-0
    • View Profile
Re: krikzz, are you interested in debugging white artifacting issue?
« Reply #8 on: February 01, 2017, 10:59 PM »
Same, but need to verify if it's still happening after the latest OS update(s).

USA front-loader + ALPS power board + NES-CPU-10 (also need to verify)

Offline EvilMilkshake

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Re: krikzz, are you interested in debugging white artifacting issue?
« Reply #9 on: February 02, 2017, 05:54 PM »
Same, but need to verify if it's still happening after the latest OS update(s).

USA front-loader + ALPS power board + NES-CPU-10 (also need to verify)

He may have been referring to the AVS update, not the N8 firmware, as I still have this issue on V15.

Also, I have this issue on my CPU-07 with a Mitsumi. It does have the revision G PPU.
« Last Edit: February 02, 2017, 05:56 PM by EvilMilkshake »

Offline onegoodsoul

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: krikzz, are you interested in debugging white artifacting issue?
« Reply #10 on: February 04, 2017, 12:55 AM »
Same issues here - Everdrive N8 from StoneAgeGamer.com + latest OS installed.

Offline desy

  • Newbie
  • *
  • Posts: 24
  • Karma: +0/-0
    • View Profile
Re: krikzz, are you interested in debugging white artifacting issue?
« Reply #11 on: February 20, 2017, 03:36 PM »
bump... now that krikzz is back

Offline KRIKzz

  • Administrator
  • Hero Member
  • *****
  • Posts: 3086
  • Karma: +477/-2
    • View Profile
Re: krikzz, are you interested in debugging white artifacting issue?
« Reply #12 on: February 23, 2017, 11:31 PM »
Droped it to my todo list. Will look on this when will working over next update

Offline desy

  • Newbie
  • *
  • Posts: 24
  • Karma: +0/-0
    • View Profile
Re: krikzz, are you interested in debugging white artifacting issue?
« Reply #13 on: February 24, 2017, 02:52 AM »
Thank you krikzz. Let us know if we can help.

Offline Bester

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: krikzz, are you interested in debugging white artifacting issue?
« Reply #14 on: April 06, 2017, 03:38 PM »
I have an AV Famicom (NTSC-J) with an "EverDrive N8 Famicom" and a Toploader (PAL) with an "EverDrive N8 NES". ROM set is smokemonster, sdcards are sandisk, powersupplies are 3rd party but of precise recommended spec/known to be good. Both are NESRGB modded by an installer Tim recommends.

I have no issues with the AV Famicom & Everdrive period (it's flawless). However I have the issue described here i.e. "white artifacting" on the Toploader with some of the games mentioned by others (i.e. Metroid). If I use the original Metroid cart, no problems ever.

If you require any further information please let me know.
« Last Edit: April 06, 2017, 03:42 PM by Bester »