Author Topic: Everdrive lag  (Read 1584 times)

0 Members and 1 Guest are viewing this topic.

Offline mooseknuckle

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Everdrive lag
« on: February 05, 2017, 09:25 PM »
Hi all

I just bought an n8. arrived (finally) but some issues persist. there is noticeable lag when playing some games, especially with a lot of sprites or sprite movements ( kirbys, contra, mario).. sprites seem to flash or game slows down.. not sure what is going on..

Also i get a disk read error 65 from toime to time but the games load fine ( yes i have tried multiple sd cards and different brands, formated correctly) ... is there a definitive guide as to how to spot a fake (for all carts)? ..... yes mine came from approved seller but i saw a picture floating around here with an n8 with extra holes that was fake and it just made me wonder.

Offline thecavalry

  • Jr. Member
  • **
  • Posts: 97
  • Karma: +11/-0
    • View Profile
Re: Everdrive lag
« Reply #1 on: February 06, 2017, 05:57 AM »
The slowdown and flickering is normal for the NES. I'm assuming you did not play when the console was new, to know that - or haven't played recently enough to remember it.

When there are multiple sprites there has always been slowdown and flickering. It's not the Everdrive. Those are NES operational limitations. It can only display so many sprites on each line, and when the limit is exceeded you get flickering.

It can only do so much on the screen without slowdown. You see the same kind of slowdown in modern games when the graphics processing (framerates) can't keep up with what's on the screen.
« Last Edit: February 06, 2017, 05:59 AM by thecavalry »

Offline mooseknuckle

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: Everdrive lag
« Reply #2 on: February 06, 2017, 06:12 AM »
I know there are some slow downs and flickering sprites that are normal... Yes I did play it new and loved it... in fact (because of your comment lolol) I put in the original games (instead of n8) to check that im not going nuts. Turns out I was right... Kirby, mario, contra (especially contra) work beautifully.. I mean within the norm. I can get a lot more sprites on screen in kirby (and contra) before flickering and slow downs occur. contra works exactly as i remembered. and ahhh mario.. gosh it brings me back everytime, but also works without issue (again with what is expected).

To add to the list of issues, I noticed a lot of glitching in contra and kirby on the n8 (where the entire screen would glitch, poorly drawn scene and sprites; very reminiscent of (as a kid) when an nes would get bumped and the cart would move thus shifting the connector and causing artifacts and frozen games at times).

fyi my connector was just fixed (more so cleaned and adjusted by me).

im curious if it may be the sd (less likely) or a bad rom... hey for all i know the cpu and ppu could be dying (wouldnt explain the working originals)

« Last Edit: February 06, 2017, 06:14 AM by mooseknuckle »

Offline SmokeMonster

  • Puzzle Bobbler
  • Sr. Member
  • ****
  • Posts: 412
  • Karma: +59/-0
  • tsst tchh chh ch ch ch
    • View Profile
    • SmokeMonster YouTube Channel
Re: Everdrive lag
« Reply #3 on: February 06, 2017, 04:08 PM »
What are your rom sources? Also, are you using an original power supply? I suggest trying No-Intro roms, and another SD card.
« Last Edit: February 06, 2017, 04:17 PM by SmokeMonster »