Author Topic: Problems with new GBA x5  (Read 2776 times)

0 Members and 1 Guest are viewing this topic.

Offline Tzakiel

  • Jr. Member
  • **
  • Posts: 62
  • Karma: +0/-0
    • View Profile
Problems with new GBA x5
« on: November 01, 2017, 08:21 AM »
I just got a GBA x5 and it only boots up 50% of the time. I am using a gamecube game boy player and when I load it up I get a white screen and some crackling (no gameboy advance logo) 50% of the time and the other 50% of the time it boots up the x5. I have to hit reset a bunch of times to get it working often. I know the player is fine because the GB ED works fine.

Also, tonight I noticed this on screen at the last bootup: "internal battery has run dry" - is that for real? Do I need to get a replacement from Stone Age? It's about 2 weeks old. EDIT: I see the battery is easy to replace so I can do that, but what of the booting problems?

I'm using a sandisk 16gb microsd card formatted fat32.
« Last Edit: November 01, 2017, 08:52 AM by Tzakiel »

Offline FeverDrive

  • Hero Member
  • *****
  • Posts: 1299
  • Karma: +54/-0
  • Blast Processing advocate
    • View Profile
Re: Problems with new GBA x5
« Reply #1 on: November 01, 2017, 07:50 PM »
Have you tested the Everdrive in a GBA console?
You can replace the battery, it uses a CR1220.
WELCO
METOT
HENEX
TLEVEL

Offline Tzakiel

  • Jr. Member
  • **
  • Posts: 62
  • Karma: +0/-0
    • View Profile
Re: Problems with new GBA x5
« Reply #2 on: November 01, 2017, 07:52 PM »
Don't have a GBA to test. But the gamecube player works fine with the everdrive GB and real carts.

I replaced the battery. Still have the boot issues. Going to send back to Stone Age.