Author Topic: SD card stopped working - ERROR D2 / SD IO error  (Read 6641 times)

0 Members and 1 Guest are viewing this topic.

Offline 16bitego

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
SD card stopped working - ERROR D2 / SD IO error
« on: June 21, 2017, 11:27 PM »
I got my Mega Everdrive x7 for my birthday as a gift a few weeks ago. I found an old SD card that worked, an SanDisk 1GB micro SD. It worked great for a while. I was playing games on it and using the save/load feature and everything was fine. One day I turned it on and it stopped working on the bootloader screen. At the top it says "ERROR:D2" and in the middle of the screen it says SD IO error.

So I bought a brand new SD card, a SanDisk 8GB micro SD, and put the MEGA folder and ROMs there in the same fashion I had before and I still get the error. I'm now worried that it is the Mega Everdrive that is broken and not the SD cards -- I saw a similar issue posted on the forums.

I spent a lot of money getting this, and my SCART game capture setup put together, only to have the Mega Everdrive stop working once I got all the pieces connected. What are my support options?

Thanks!

Offline Adrian Gauna

  • Jr. Member
  • **
  • Posts: 67
  • Karma: +5/-0
    • View Profile
Re: SD card stopped working - ERROR D2 / SD IO error
« Reply #1 on: June 22, 2017, 12:02 PM »
I got my Mega Everdrive x7 for my birthday as a gift a few weeks ago. I found an old SD card that worked, an SanDisk 1GB micro SD. It worked great for a while. I was playing games on it and using the save/load feature and everything was fine. One day I turned it on and it stopped working on the bootloader screen. At the top it says "ERROR:D2" and in the middle of the screen it says SD IO error.

So I bought a brand new SD card, a SanDisk 8GB micro SD, and put the MEGA folder and ROMs there in the same fashion I had before and I still get the error. I'm now worried that it is the Mega Everdrive that is broken and not the SD cards -- I saw a similar issue posted on the forums.

I spent a lot of money getting this, and my SCART game capture setup put together, only to have the Mega Everdrive stop working once I got all the pieces connected. What are my support options?

Thanks!


Hi there, I highly doubt it's the Mega EverDrive cart thats at fault, maybe your PC corrupted the files on the SD card when adding roms to the card?

ry different brand SD cards, I know for a fact that the Mega EverDrive cartridge is picky about brands for instance the Sony brand mini SD cards won't work on the Mega EverDrive. I know this first hand because I recently tried to upgrade from a 4 Gigabyte card to a 16 Gigabyte card but the Mega EverDrive cart kept saying ''SD IO error'' because it was Sony.

To my knowledge Sandisk should be okay, Kingston is a brand that will definitely work as that's the brand SD card that came with mine. If changing card brands doesn't work try downloading the OS of your choice again and check that all the files needed to run the OS on the cart are all there in the MEGA folder, MEGAOS bin, MEGA.RBF,MEGA etc. For the folder name make sure it only says ''MEGA'' and not MEGA DRIVE or GENESIS/GAME.

If just one of these files is missing you'll be greeted with an error message upon bootloader again.

Offline EverDriver

  • Administrator
  • Hero Member
  • *****
  • Posts: 547
  • Karma: +42/-0
  • support
    • View Profile
Re: SD card stopped working - ERROR D2 / SD IO error
« Reply #2 on: June 22, 2017, 07:41 PM »
Please try to use another new SD cards of another brands.
If it doesn't help then please contact us using the store's contact form.

Offline 16bitego

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: SD card stopped working - ERROR D2 / SD IO error
« Reply #3 on: June 22, 2017, 09:02 PM »
Hi there, I highly doubt it's the Mega EverDrive cart thats at fault, maybe your PC corrupted the files on the SD card when adding roms to the card?

ry different brand SD cards, I know for a fact that the Mega EverDrive cartridge is picky about brands for instance the Sony brand mini SD cards won't work on the Mega EverDrive. I know this first hand because I recently tried to upgrade from a 4 Gigabyte card to a 16 Gigabyte card but the Mega EverDrive cart kept saying ''SD IO error'' because it was Sony.

To my knowledge Sandisk should be okay, Kingston is a brand that will definitely work as that's the brand SD card that came with mine. If changing card brands doesn't work try downloading the OS of your choice again and check that all the files needed to run the OS on the cart are all there in the MEGA folder, MEGAOS bin, MEGA.RBF,MEGA etc. For the folder name make sure it only says ''MEGA'' and not MEGA DRIVE or GENESIS/GAME.

If just one of these files is missing you'll be greeted with an error message upon bootloader again.

It had nothing to do with the PC because the SD card never left the Everdrive once it was working. The MEGA folder was set up correctly and everything was working fine, now it isn't. Sandisk was definitely OK because as I said, it was working fine. To reiterate: It was working, it one day stopped working without me doing anything to it.

Offline Adrian Gauna

  • Jr. Member
  • **
  • Posts: 67
  • Karma: +5/-0
    • View Profile
Re: SD card stopped working - ERROR D2 / SD IO error
« Reply #4 on: June 23, 2017, 08:48 AM »
Hi there, I highly doubt it's the Mega EverDrive cart thats at fault, maybe your PC corrupted the files on the SD card when adding roms to the card?

ry different brand SD cards, I know for a fact that the Mega EverDrive cartridge is picky about brands for instance the Sony brand mini SD cards won't work on the Mega EverDrive. I know this first hand because I recently tried to upgrade from a 4 Gigabyte card to a 16 Gigabyte card but the Mega EverDrive cart kept saying ''SD IO error'' because it was Sony.

To my knowledge Sandisk should be okay, Kingston is a brand that will definitely work as that's the brand SD card that came with mine. If changing card brands doesn't work try downloading the OS of your choice again and check that all the files needed to run the OS on the cart are all there in the MEGA folder, MEGAOS bin, MEGA.RBF,MEGA etc. For the folder name make sure it only says ''MEGA'' and not MEGA DRIVE or GENESIS/GAME.

If just one of these files is missing you'll be greeted with an error message upon bootloader again.

It had nothing to do with the PC because the SD card never left the Everdrive once it was working. The MEGA folder was set up correctly and everything was working fine, now it isn't. Sandisk was definitely OK because as I said, it was working fine. To reiterate: It was working, it one day stopped working without me doing anything to it.

Ok then. It seems like a card issue. I suppose it's not entirely impossible that a card can stop working for no reason.

I still doubt it's the Mega EverDrive cart thats faulty, those things are quite strong, I know because I have a habit of leaving my Mega EverDrive cart inside my console when I go to sleep at night and me and my wife leave our cat in at night and one night our cat must have tried to jump on my Mega Drive console and accidently knocked it off it's spot and it fell behind the TV unit with the Mega EverDrive cart almost crushed between the brick wall and the TV unit while still inside the cartridge slot of the console. It only suffered a bit of plastic tear on the top left hand side, very lucky.

The point i'm making is that it still works like brand new despite being nearly wrecked. So if that didn't make it faulty I find it hard to accept that yours could just stop working for no reason.

I wish I could offer some solutions other than what Krikzz said that to keep trying different brand SD cards.

Offline EverDriver

  • Administrator
  • Hero Member
  • *****
  • Posts: 547
  • Karma: +42/-0
  • support
    • View Profile
Re: SD card stopped working - ERROR D2 / SD IO error
« Reply #5 on: June 23, 2017, 11:40 AM »
All three devices: the console, the SD card, the EverDrive may be faulty.
All of them are not perfect.

If you have a problem your goal is to solve the problem.
Not to make a false assumption and make a wrong action.

Fortunately there is a simple and reliable algorithm to solve the problem.
One doesn't need to think out anything. Just follow the algorithm.

First:
The console is the least "perfect" thing. They are the most fault-prone devices.
One should try to use another console. Perfectly an unmodded "clean" console with the standard power supply (an EverDrive needs more power than a regular cartridge).
The argument "my regular cartridges work very well" doesn't work. EverDrives are not regular cartridges.
One can check this if runs some advanced regular cartridge on his/her faulty console. It won't work unlike the primitive ones.

Second:
The SD card is the second not perfect thing.
One should try to use another SD cards. Perfectly brand new. Another brand than the current one.
Very often people get somewhere an old faulty SD card and start to blame the EverDrive without even trying to use another SD card.

Third:
Nothing is perfect. EverDrives may be faulty as well.
If one has already tried everything on his/her side and it didn't help then there is the only thing one can do: send it to us for repair or replacement.
One should contact us using the contact form in the Krikzz's store.
« Last Edit: June 23, 2017, 11:42 AM by krikzz team »

Offline 16bitego

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: SD card stopped working - ERROR D2 / SD IO error
« Reply #6 on: June 23, 2017, 11:49 PM »
All three devices: the console, the SD card, the EverDrive may be faulty.
All of them are not perfect.

First:
The console is the least "perfect" thing. They are the most fault-prone devices.
One should try to use another console. Perfectly an unmodded "clean" console with the standard power supply (an EverDrive needs more power than a regular cartridge).
The argument "my regular cartridges work very well" doesn't work. EverDrives are not regular cartridges.
One can check this if runs some advanced regular cartridge on his/her faulty console. It won't work unlike the primitive ones.

I don't have another Genesis to test it with. This is my original Sega Genesis from when I was a kid, unmodded with the original power supply.

Second:
The SD card is the second not perfect thing.
One should try to use another SD cards. Perfectly brand new. Another brand than the current one.
Very often people get somewhere an old faulty SD card and start to blame the EverDrive without even trying to use another SD card.

As I said, it was working with the older Sandisk before it stopped. The 2nd brand new Sandisk gives the same error. I have ordered yet another SD card, a Kingston this time and I can report back when I get it to test.

Third:
Nothing is perfect. EverDrives may be faulty as well.
If one has already tried everything on his/her side and it didn't help then there is the only thing one can do: send it to us for repair or replacement.
One should contact us using the contact form in the Krikzz's store.

I hope not, but we'll see.


Offline EverDriver

  • Administrator
  • Hero Member
  • *****
  • Posts: 547
  • Karma: +42/-0
  • support
    • View Profile
Re: SD card stopped working - ERROR D2 / SD IO error
« Reply #7 on: June 24, 2017, 12:33 AM »
To have the console from when you was a kid is really cool! My first Sega unfortunately is lost... I really would like to have it.

Ok! I hope it will help.

We will see.

Offline 16bitego

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: SD card stopped working - ERROR D2 / SD IO error
« Reply #8 on: June 25, 2017, 09:12 PM »
To have the console from when you was a kid is really cool! My first Sega unfortunately is lost... I really would like to have it.

Ok! I hope it will help.

We will see.

Unfortunately the 3rd SD card has the exact same issue. Here's a screen shot: https://imgur.com/a/Z0NTg

+ bonus shot of sega


Offline EverDriver

  • Administrator
  • Hero Member
  • *****
  • Posts: 547
  • Karma: +42/-0
  • support
    • View Profile
Re: SD card stopped working - ERROR D2 / SD IO error
« Reply #9 on: June 26, 2017, 01:21 AM »
Bad.

Please contact us using the contact form in the store.

Offline Annmathew

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
    • deardesk
Re: SD card stopped working - ERROR D2 / SD IO error
« Reply #10 on: July 08, 2017, 10:45 AM »
Try using SD card of another brand. that might really help.

Offline MaarioS

  • Newbie
  • *
  • Posts: 46
  • Karma: +2/-0
    • View Profile
Re: SD card stopped working - ERROR D2 / SD IO error
« Reply #11 on: June 28, 2018, 07:08 PM »
Just to tell my few cents I also received Mega Everdrive recently and experienced the same exact error right on the start. What I actually found out is that the SD card was corrupted. I think I noticed that same SD card was glitching and corrupting some files on my phone previously for no reason. It is Kingston 8GB class 4 card and I always buy Kingston cards from the same places and never noticed anything like that before. I know this can happen sometimes but why this specific SD card started to corrupt data I have no idea lol (I tried using another Kingston SD card on that Mega Everdrive and it started to work)

Offline cybercylon

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Re: SD card stopped working - ERROR D2 / SD IO error
« Reply #12 on: July 14, 2018, 08:05 PM »
I wonder if the original poster was trying to run his overdrive with the 32X attached. I get this error sometimes with the 32X. Eventually, it will work and seems fine once it is going.

I don't see this issue when I take the 32X out of the equation.