Author Topic: everdrive GB x3, saves not working  (Read 2340 times)

0 Members and 1 Guest are viewing this topic.

Offline sntrenter

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
everdrive GB x3, saves not working
« on: February 25, 2018, 06:03 AM »
So i just started up LSDJ and tried to write a song and when i went to save it and check to make sure it would come actually save it didn't show up.

also tried this with zelda tetris and super mario land and the games act as if the cartridge battery is dead. I got my everdrive 2 days ago, so me not knowing how to use this is a high possibility, if someone could point me to a guide or something that would be great.

Offline EverDriver

  • Administrator
  • Hero Member
  • *****
  • Posts: 547
  • Karma: +42/-0
  • support
    • View Profile
Re: everdrive GB x3, saves not working
« Reply #1 on: February 25, 2018, 05:03 PM »
To save your progress please press the button before turning your console off.
To press the button please squeeze the top part of the cartridge.