Author Topic: Weird Issue on PC Engine  (Read 4102 times)

0 Members and 1 Guest are viewing this topic.

Offline KRIKzz

  • Administrator
  • Hero Member
  • *****
  • Posts: 3016
  • Karma: +459/-2
    • View Profile
Re: Weird Issue on PC Engine
« Reply #60 on: June 18, 2018, 01:39 PM »
I made timings optimizations and sent test sample to NeoMK, he confirmed that cart now works fine on his setup. Anyone who has mentioned graphics artifacts may send his cart to us for exchange. Please use contact us form to submit request: https://krikzz.com/store/contact-us

Offline FeverDrive

  • Hero Member
  • *****
  • Posts: 952
  • Karma: +36/-0
  • GOTTA GO FAST
    • View Profile
Re: Weird Issue on PC Engine
« Reply #61 on: June 19, 2018, 06:44 AM »
I made timings optimizations and sent test sample to NeoMK, he confirmed that cart now works fine on his setup. Anyone who has mentioned graphics artifacts may send his cart to us for exchange. Please use contact us form to submit request: https://krikzz.com/store/contact-us
Wow great news Krikzz, this was really much needed.
Previously known as DC/AC

Offline SnoopKatt

  • Newbie
  • *
  • Posts: 46
  • Karma: +1/-0
    • View Profile
Re: Weird Issue on PC Engine
« Reply #62 on: June 19, 2018, 08:13 PM »
I made timings optimizations and sent test sample to NeoMK, he confirmed that cart now works fine on his setup. Anyone who has mentioned graphics artifacts may send his cart to us for exchange. Please use contact us form to submit request: https://krikzz.com/store/contact-us
Thanks! Really appreciate it.

Offline pdiggitydogg

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Re: Weird Issue on PC Engine
« Reply #63 on: June 20, 2018, 05:30 PM »
This is great news. I've had these exact issues since I received my TED at the start of the year, but just figured it was bad caps and a "I'll deal with this later" issue. I had tried numerous different sd cards and two separate consoles. Looks like I'll fill out the form. No way this can be fixed via software updates?

Offline SnoopKatt

  • Newbie
  • *
  • Posts: 46
  • Karma: +1/-0
    • View Profile
Re: Weird Issue on PC Engine
« Reply #64 on: June 22, 2018, 04:58 PM »
I made timings optimizations and sent test sample to NeoMK, he confirmed that cart now works fine on his setup. Anyone who has mentioned graphics artifacts may send his cart to us for exchange. Please use contact us form to submit request: https://krikzz.com/store/contact-us
Is the tweak something we can do ourselves, or is it rather complicated? Just wondering since if it's a simple soldering job I could save myself 30 bucks to ship it!

Offline NeoMK

  • Newbie
  • *
  • Posts: 24
  • Karma: +0/-0
    • View Profile
Re: Weird Issue on PC Engine
« Reply #65 on: June 25, 2018, 12:20 AM »
Evening All,

I have been waiting for KRIKzz to give the all clear. I can confirm that v2.4 TBED does not have the graphical glitches that v2.5 cards have. As KRIKzz has confirmed, there are memory timing issues with v2.5 cards in combination with some PC engine/TG16 configs. This varies depending on the quality of the memory chips inside the unit in question. Chips capable of higher speeds may not exhibit graphic glitch problems etc. KRIKzz has therefore done some clever tweaks on the v2.5 board which appear to have made the difference. Of course, who knows if it will work with all configurations out there - but all I can say is if you have a white PC Engine which is RGB modded - then you now have hope. Lets hope the TBED changes cover all scenarios out there.

Offline netbeui

  • Newbie
  • *
  • Posts: 25
  • Karma: +1/-0
    • View Profile
Re: Weird Issue on PC Engine
« Reply #66 on: June 25, 2018, 08:59 AM »
I made timings optimizations and sent test sample to NeoMK, he confirmed that cart now works fine on his setup. Anyone who has mentioned graphics artifacts may send his cart to us for exchange. Please use contact us form to submit request: https://krikzz.com/store/contact-us

Should I send mine in even if I don’t have any issues? I’m using a TED 2.5 and white PC Engine which has a composite mod. The menu looks fine and I’ve played a few games with no problem, there are no graphical issues at all. Just wondering if this will be a problem down the road at some point if I don’t send it in.

Offline FeverDrive

  • Hero Member
  • *****
  • Posts: 952
  • Karma: +36/-0
  • GOTTA GO FAST
    • View Profile
Re: Weird Issue on PC Engine
« Reply #67 on: June 28, 2018, 06:52 AM »
Should I send mine in even if I don’t have any issues? I’m using a TED 2.5 and white PC Engine which has a composite mod. The menu looks fine and I’ve played a few games with no problem, there are no graphical issues at all. Just wondering if this will be a problem down the road at some point if I don’t send it in.
I think you should't right now. If you have issues in the future you can always send back your Everdrive to Krikzz.
Previously known as DC/AC

Offline senkun

  • Newbie
  • *
  • Posts: 13
  • Karma: +0/-0
    • View Profile
Re: Weird Issue on PC Engine
« Reply #68 on: June 28, 2018, 02:06 PM »
I made timings optimizations and sent test sample to NeoMK, he confirmed that cart now works fine on his setup. Anyone who has mentioned graphics artifacts may send his cart to us for exchange. Please use contact us form to submit request: https://krikzz.com/store/contact-us

Thanks for hearing us out and fixing the issue. As others have asked, is this fixable by the end user? I'd prefer to not have to send mine in for a replacement, to save on time and shipping costs, and it saves on return shipping cost on your end too.

Also, when will the fixed /tweaked TEDs (v2. 6?) be available for purchase? I might just keep my glitchy one for use on my spare pce if I could buy a working one for my IFU-30 setup. Saves us all the hassle of replacing.

Offline KRIKzz

  • Administrator
  • Hero Member
  • *****
  • Posts: 3016
  • Karma: +459/-2
    • View Profile
Re: Weird Issue on PC Engine
« Reply #69 on: July 03, 2018, 01:50 PM »
I made timings optimizations and sent test sample to NeoMK, he confirmed that cart now works fine on his setup. Anyone who has mentioned graphics artifacts may send his cart to us for exchange. Please use contact us form to submit request: https://krikzz.com/store/contact-us

Thanks for hearing us out and fixing the issue. As others have asked, is this fixable by the end user? I'd prefer to not have to send mine in for a replacement, to save on time and shipping costs, and it saves on return shipping cost on your end too.

Also, when will the fixed /tweaked TEDs (v2. 6?) be available for purchase? I might just keep my glitchy one for use on my spare pce if I could buy a working one for my IFU-30 setup. Saves us all the hassle of replacing.

There is not be new board release, only 2.5 with new fpga core. There is no way to fix problem without sending it back, unfortunately.

Offline BumbleChump

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Weird Issue on PC Engine
« Reply #70 on: July 14, 2018, 04:31 AM »
Hi all,

I recently ordered a turbo everdrive direct from Krikzz, and specially asked about having the timing optimizations. They said that it would be optimized.

That being said, I can confirm that this optimized turbo everdrive works on my pc engine/ cd rom^2 combo now! No more menu or graphical glitches! Very happy with it.