Author Topic: EDN8 OS v4  (Read 14313 times)

0 Members and 1 Guest are viewing this topic.

Offline KRIKzz

  • Administrator
  • Hero Member
  • *****
  • Posts: 3286
  • Karma: +491/-2
    • View Profile
Re: EDN8 OS v4
« Reply #15 on: July 07, 2013, 12:57 PM »
Problem with short codes loadin is fixed: http://krikzz.com/pub/support/everdrive-n8/OS/nesos-v5.zip
Some improvements for MMC3 was implemented as well.
Now i going to make deep research of real MMC3 chip, seems like available information is good enough for software implementations in emulators, but not for accurate hardware implementation. Logic analyzer already help me to open some MMC3 secrets (:

Offline netbeui

  • Newbie
  • *
  • Posts: 26
  • Karma: +1/-0
    • View Profile
Re: EDN8 OS v4
« Reply #16 on: July 08, 2013, 04:51 AM »
Thanks Krikzz. With the newest OS version 5 should we enter the short codes as XXXX-XX-- or XXX-XXX?

Offline netbeui

  • Newbie
  • *
  • Posts: 26
  • Karma: +1/-0
    • View Profile
Re: EDN8 OS v4
« Reply #17 on: July 08, 2013, 09:01 AM »
Hmm I just tried os5 and I'm getting a black screen whenever I try to run any game. At first I thought it might be my cheat codes so I tried turning them off but that didn't help. So I tried resetting my NES but that also took me to a black screen. I was getting worried at this point so I went back to os4 and everything is back to normal again.

The only thing different is that I extracted and copied the os5 files from my Linux machine. I usually do that from a windows machine but I don't have access to one at the moment. Anyway everything is back to normal with os4. Is anyone else experiencing issues with os5?


Offline KRIKzz

  • Administrator
  • Hero Member
  • *****
  • Posts: 3286
  • Karma: +491/-2
    • View Profile
Re: EDN8 OS v4
« Reply #18 on: July 08, 2013, 09:52 AM »
Thanks Krikzz. With the newest OS version 5 should we enter the short codes as XXXX-XX-- or XXX-XXX?
Should be as XXX-XXX

Offline nettou

  • Newbie
  • *
  • Posts: 14
  • Karma: +1/-0
    • View Profile
Re: EDN8 OS v4
« Reply #19 on: July 08, 2013, 05:11 PM »
hey Krikzz, quick bug report on OSv5 > tried it on my everdrive on the (real nintendo) Famicom and yep I only get grey / blank screen on boot up... rolling back to OSv4 made it work just fine, tried several times to make sure it was not a random glitch: just thought I'd let you know as it seems similar to the other person above who had problems

Offline KRIKzz

  • Administrator
  • Hero Member
  • *****
  • Posts: 3286
  • Karma: +491/-2
    • View Profile
Re: EDN8 OS v4
« Reply #20 on: July 08, 2013, 05:50 PM »
hey Krikzz, quick bug report on OSv5 > tried it on my everdrive on the (real nintendo) Famicom and yep I only get grey / blank screen on boot up... rolling back to OSv4 made it work just fine, tried several times to make sure it was not a random glitch: just thought I'd let you know as it seems similar to the other person above who had problems
He can't load the game, so his problem is not same. I can't reproduce any problems with OS v5, so, i think problem is not on my side.

Offline nettou

  • Newbie
  • *
  • Posts: 14
  • Karma: +1/-0
    • View Profile
Re: EDN8 OS v4
« Reply #21 on: July 08, 2013, 07:14 PM »
krizzk - could it be because of previously loaded rom? I had been playing some diff games after rolling back and saw your post + retried the update and its working fine now :) very strange :)

Offline KRIKzz

  • Administrator
  • Hero Member
  • *****
  • Posts: 3286
  • Karma: +491/-2
    • View Profile
Re: EDN8 OS v4
« Reply #22 on: July 08, 2013, 07:32 PM »
krizzk - could it be because of previously loaded rom? I had been playing some diff games after rolling back and saw your post + retried the update and its working fine now :) very strange :)
Nope, rom can not make any problems

Offline belik

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Re: EDN8 OS v4
« Reply #23 on: July 08, 2013, 09:23 PM »
hey Krikzz, quick bug report on OSv5 > tried it on my everdrive on the (real nintendo) Famicom and yep I only get grey / blank screen on boot up... rolling back to OSv4 made it work just fine, tried several times to make sure it was not a random glitch: just thought I'd let you know as it seems similar to the other person above who had problems
у меня была такая проблема, решилось дефрагментацией флешки,
были фрагментированы 2 файла из папки MAPS

Offline KRIKzz

  • Administrator
  • Hero Member
  • *****
  • Posts: 3286
  • Karma: +491/-2
    • View Profile
Re: EDN8 OS v4
« Reply #24 on: July 08, 2013, 10:13 PM »
hey Krikzz, quick bug report on OSv5 > tried it on my everdrive on the (real nintendo) Famicom and yep I only get grey / blank screen on boot up... rolling back to OSv4 made it work just fine, tried several times to make sure it was not a random glitch: just thought I'd let you know as it seems similar to the other person above who had problems
у меня была такая проблема, решилось дефрагментацией флешки,
были фрагментированы 2 файла из папки MAPS
Да, дефрагментированные системные файлы могут привести к такому результату. А чем копировались? Стандартные виндовые средства не фрагментируют мелкие файлы как правило, а вот всякие тотал камандеры с удовольствием готовы раздробить любой файл, даже очень маленький

Offline nettou

  • Newbie
  • *
  • Posts: 14
  • Karma: +1/-0
    • View Profile
Re: EDN8 OS v4
« Reply #25 on: July 08, 2013, 10:27 PM »
^ I did delete + copy the directory over the 2nd time when it worked rather than over-writing :) that might explain it; obv. not the h/w fault at all, SD cards can be odd sometimes :)
« Last Edit: July 08, 2013, 10:29 PM by nettou »

Offline belik

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Re: EDN8 OS v4
« Reply #26 on: July 08, 2013, 11:59 PM »
а вот всякие тотал камандеры с удовольствием готовы раздробить любой файл, даже очень маленький
ну да, именно тотал коммандером и копировал

Offline netbeui

  • Newbie
  • *
  • Posts: 26
  • Karma: +1/-0
    • View Profile
Re: EDN8 OS v4
« Reply #27 on: July 09, 2013, 09:07 AM »
There must have been a problem with one of the files when I copied os5 the first time. I just deleted and re-copied the files and everything is working perfectly again  :)

Offline Martin

  • Newbie
  • *
  • Posts: 14
  • Karma: +2/-2
    • View Profile
Re: EDN8 OS v4
« Reply #28 on: July 11, 2013, 03:35 PM »
TNXXXXXXXXXXXXX!  8)