Author Topic: Compatibility issue with Firehawk, of all things.  (Read 1093 times)

0 Members and 1 Guest are viewing this topic.

Offline drachenstern

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Compatibility issue with Firehawk, of all things.
« on: May 10, 2018, 11:12 AM »
Hey there guys

Just got my cart a few weeks back and have been having the usual expected mapper issues with Codemasters/Camerica games like The Fantastic Adventures of Dizzy, and when I went to look for a solution it turned out of course that, supposedly, the Everdrive can't do Codemasters games, excluding Firehawk, without the ROM being hacked to set the mapper to 2. I did that on FAoD, it worked fantastically, then I never played it again because I own a real cart and aren't tempted to use save states that way. :P :P :P

The curiosity came for me when I put on a couple more games: namely Dizzy the Adventurer and Firehawk itself. Neither of which I modified the header to. Well, by some strange turn of fate Dizzy worked fine (and I completed the game through, just to make sure the bugs weren't hiding further into the game or something) and meanwhile Firehawk won't load at all. It gives a grey screen, similar to any other incompatible game.

And while we're on the subject of games that don't seem to work right, Super C is glitched graphically on the Everdrive for me. I am horrible at Contra so I have no clue if it actually crashes (since I go game over before that has the chance to happen  :D ) but it gets pretty bad.

Do you think that this is just my roms? As far as I know my everdrive should be up to date, since it's soooo new. It plays all the weird Hummer Team pirates like a charm (Super Mario World with poor jump physics and screeching music, anyone?) but can't play a couple of actually good games for me, which is a bit sad.  :(