Author Topic: EDN8 OS v20-BETA. Large update incoming  (Read 286357 times)

0 Members and 1 Guest are viewing this topic.

Offline Arnold101

  • Sr. Member
  • ****
  • Posts: 382
  • Karma: +4/-1
    • View Profile
Re: EDN8 OS v20-BETA. Large update incoming
« Reply #645 on: September 01, 2018, 04:37 AM »
exactly
Well, since you ignore the fact that KRIKzz cannot raise the volume higher in software because of terrible digital distortion, maybe it's time for you to mod your famicom or N8 to fit your volume preferences?
I can only assume you will not be happy with that either, and respond with some rude comment.
and where is rude?
when you receive your famicom you'll see i was right
if someone tell me how to mod it i'll be happy to do it

Offline flex

  • Newbie
  • *
  • Posts: 42
  • Karma: +4/-0
    • View Profile
Re: EDN8 OS v20-BETA. Large update incoming
« Reply #646 on: September 01, 2018, 05:37 AM »
I have to say I am getting a lot of odd IO related errors and sometimes garbled characters for folder names popping up on RC6 / 7 if i browse through the files or menus too fast... I am using a decent Sandisk 16GB SD card which I have formatted with the largest allocation unit size and copied everything back to the card everytime i switch firmware and have been using this card for a long time in my N8 without issue. Definitely something not quite right, just thought I would mention it to give some feedback in case there is an issue that has been introduced as I know a couple of other people have mentioned this.


Offline brianvgplayer

  • Sr. Member
  • ****
  • Posts: 308
  • Karma: +5/-0
    • View Profile
Re: EDN8 OS v20-BETA. Large update incoming
« Reply #647 on: September 01, 2018, 05:42 AM »
Whats the SHA1 checksum of the rom that you are using?

835FEE060B15700163A1F8AD9716A163BF79C8FD

Offline flex

  • Newbie
  • *
  • Posts: 42
  • Karma: +4/-0
    • View Profile
Re: EDN8 OS v20-BETA. Large update incoming
« Reply #648 on: September 01, 2018, 06:27 AM »
I actually cannot get any version of OS v20 to work in my PAL NES unit at all. It either gets stuck on OS Init... shows some odd characters or gives Error: 10. When I place the N8 back in the AV Famicom everything is working correctly though, also if I downgrade to v16 everything works on the PAL unit again. I am formatting my memory card every time and I even tried nothing on the card other than the EDFC folder for v20 by itself and it still has the same issue.

Has anyone else tested with a PAL unit?

Offline brianvgplayer

  • Sr. Member
  • ****
  • Posts: 308
  • Karma: +5/-0
    • View Profile
Re: EDN8 OS v20-BETA. Large update incoming
« Reply #649 on: September 01, 2018, 08:53 AM »
I actually cannot get any version of OS v20 to work in my PAL NES unit at all. It either gets stuck on OS Init... shows some odd characters or gives Error: 10. When I place the N8 back in the AV Famicom everything is working correctly though, also if I downgrade to v16 everything works on the PAL unit again. I am formatting my memory card every time and I even tried nothing on the card other than the EDFC folder for v20 by itself and it still has the same issue.

Has anyone else tested with a PAL unit?

I tested on RC6 with AVS set to PAL. It runs fine in NTSC, but I either get garbage (when I switch to PAL after returning to menu from a NTSC game) or Error 63 messages (when console is turned on in PAL mode) when the console is set to PAL. Error 63 messages don't occur after taking out and reinserting SD card (after power off, of course) and going back to NTSC.

Offline densy

  • Newbie
  • *
  • Posts: 18
  • Karma: +2/-0
    • View Profile
Re: EDN8 OS v20-BETA. Large update incoming
« Reply #650 on: September 01, 2018, 10:38 AM »
Whats the SHA1 checksum of the rom that you are using?

835FEE060B15700163A1F8AD9716A163BF79C8FD

Thanks! Looks like we’re using the same rom.

Offline marionintendo

  • Newbie
  • *
  • Posts: 21
  • Karma: +1/-0
    • View Profile
Re: EDN8 OS v20-BETA. Large update incoming
« Reply #651 on: September 01, 2018, 08:41 PM »
This is amazing! Fingers crossed for random game feature in the future

Offline Quantum

  • Newbie
  • *
  • Posts: 11
  • Karma: +0/-0
    • View Profile
Re: EDN8 OS v20-BETA. Large update incoming
« Reply #652 on: September 01, 2018, 08:48 PM »
Hi again, I'm trying to nail down the OS errors because this firmware is closer to release. With the latest firmware I still get tons of OS errors and menu corruptions.

Going back to the thought that it might be a power issue, I went and connected the external regulator to the NESRGB (I had previously disconnected it due to some NESRGB noise issues which have now been resolved).

My error rates are as follows:

Without extra NESRGB voltage regulator -- 90% error rate on loading game
with extra NESRGB voltage regulator -- 10% error rate on loading games (unknown rom format, OS error, crashes, game loads fine on second try or power cycle)

I also tried putting a 470uF capacitor on the +5v power rail right at the cart connecter (on the blinking light win, so it's right next to the cartridge) and I can't really tell if it helps or not. Do you think this could be simply a power issue? Should I try and put a larger capacitor on the cartridge port power rail?

« Last Edit: September 01, 2018, 08:52 PM by Quantum »

Offline Quantum

  • Newbie
  • *
  • Posts: 11
  • Karma: +0/-0
    • View Profile
Re: EDN8 OS v20-BETA. Large update incoming
« Reply #653 on: September 01, 2018, 09:10 PM »
Could I ask anyone that is having OS errors to fill out this survey? Maybe we can find some patterns.

If you don't have any errors and have a moment you can fill it out too, maybe there is some information in there as well.

https://goo.gl/forms/uo9YRvMnrfHmBj8f2

Offline flex

  • Newbie
  • *
  • Posts: 42
  • Karma: +4/-0
    • View Profile
Re: EDN8 OS v20-BETA. Large update incoming
« Reply #654 on: September 02, 2018, 01:15 AM »
Hi again, I'm trying to nail down the OS errors because this firmware is closer to release. With the latest firmware I still get tons of OS errors and menu corruptions.

Going back to the thought that it might be a power issue, I went and connected the external regulator to the NESRGB (I had previously disconnected it due to some NESRGB noise issues which have now been resolved).

My error rates are as follows:

Without extra NESRGB voltage regulator -- 90% error rate on loading game
with extra NESRGB voltage regulator -- 10% error rate on loading games (unknown rom format, OS error, crashes, game loads fine on second try or power cycle)

I also tried putting a 470uF capacitor on the +5v power rail right at the cart connecter (on the blinking light win, so it's right next to the cartridge) and I can't really tell if it helps or not. Do you think this could be simply a power issue? Should I try and put a larger capacitor on the cartridge port power rail?

Without being rude I am struggling to understand why hardware issues are coming into the equation when no OS errors exist under v16 which shows clearly they are software related issues with v20 otherwise they would happen on the older OS as well, end of discussion.

It is well documented that if you are using a NESRGB on a Front Loader you should install the voltage regulator so I assume this scenario will effect you but not sure how it relates to others having issues.

« Last Edit: September 02, 2018, 01:20 AM by flex »

Offline Jegriva

  • Full Member
  • ***
  • Posts: 126
  • Karma: +3/-0
    • View Profile
Re: EDN8 OS v20-BETA. Large update incoming
« Reply #655 on: September 02, 2018, 01:43 AM »
Could I ask anyone that is having OS errors to fill out this survey? Maybe we can find some patterns.

If you don't have any errors and have a moment you can fill it out too, maybe there is some information in there as well.

https://goo.gl/forms/uo9YRvMnrfHmBj8f2

Filled it!

With RC7 I still get the Error 52, 62 and 63 every time I scroll too fast. (stock AV Famicom, no problem whatsoever with v16)
« Last Edit: September 02, 2018, 01:48 AM by Jegriva »

Offline Quantum

  • Newbie
  • *
  • Posts: 11
  • Karma: +0/-0
    • View Profile
Re: EDN8 OS v20-BETA. Large update incoming
« Reply #656 on: September 02, 2018, 02:50 AM »

Without being rude I am struggling to understand why hardware issues are coming into the equation when no OS errors exist under v16 which shows clearly they are software related issues with v20 otherwise they would happen on the older OS as well, end of discussion.

It is well documented that if you are using a NESRGB on a Front Loader you should install the voltage regulator so I assume this scenario will effect you but not sure how it relates to others having issues.

I'm sorry I came across that way -- I absolutely agree that there are software related issues with v20. As I've said, I still get a lot of errors with the regulator installed, but it has greatly improved.

Additionally, I do not get any errors with v16 with or without the additional vreg.

Again, I'm not implying it's a purely hardware issue, but there's definitely something to consider here.

I'm getting a fair amount of responses on the survey and at a cursory glance I'm not really seeing anything that stands out, modded and unmodded systems are having the same issues and lots of SD cards have been tested, but I'll look more closely once some more responses come in.

Offline brianvgplayer

  • Sr. Member
  • ****
  • Posts: 308
  • Karma: +5/-0
    • View Profile
Re: EDN8 OS v20-BETA. Large update incoming
« Reply #657 on: September 02, 2018, 07:10 AM »
Are most people getting the errors using PAL consoles? Something definitely seems to be screwed up with PAL mode on the recent OS. 

Offline iliek

  • Newbie
  • *
  • Posts: 5
  • Karma: +1/-0
    • View Profile
Re: EDN8 OS v20-BETA. Large update incoming
« Reply #658 on: September 02, 2018, 08:04 AM »
Just chiming in to say I was getting endless IO errors to the point where it was unusable with the beta versions of v20, but the RC versions are working.  Nothing about my setup has changed other than installing the new OS.  The only issue I have seen now is ERROR:65 (Disk IO error) when resetting from an FDS image.

Offline densy

  • Newbie
  • *
  • Posts: 18
  • Karma: +2/-0
    • View Profile
Re: EDN8 OS v20-BETA. Large update incoming
« Reply #659 on: September 02, 2018, 10:23 AM »
Are most people getting the errors using PAL consoles? Something definitely seems to be screwed up with PAL mode on the recent OS.

I hadn’t tested it in PAL mode yet on AVS. I just did and..it’s a mess. The menu is really garbled. Managed to get it looking properly again with a reset but after going through folders a bit it starts to look like mess again.