Author Topic: Bug? Unable to load Master System image via USB (X7)  (Read 1211 times)

0 Members and 1 Guest are viewing this topic.

Offline csoren

  • Newbie
  • *
  • Posts: 8
  • Karma: +1/-0
    • View Profile
Bug? Unable to load Master System image via USB (X7)
« on: November 13, 2018, 08:39 PM »
I'm unable to load Master System images via USB. Genesis images work fine. I'm using a Mega Everdrive X7 (obviously) with OS 3.06.

The same images work fine when loaded onto the SD card and selected from there.

The command I'm trying is simply
Code: [Select]
mega-usb.exe "Sprite Test #2 v1.00 (2002)(MacDonald, Charles)(PD).bin"

Adding -sms onto the end, such as

Code: [Select]
mega-usb.exe "Sprite Test #2 v1.00 (2002)(MacDonald, Charles)(PD).bin" -sms

doesn't help. A black screen is the result. No titles play music. Can anyone confirm whether they can load Master System images via USB or whether it's just broken at the moment?
« Last Edit: November 14, 2018, 01:21 PM by csoren »

Offline csoren

  • Newbie
  • *
  • Posts: 8
  • Karma: +1/-0
    • View Profile
Re: Bug - Unable to load Master System image via USB (X7)
« Reply #1 on: November 19, 2018, 05:42 PM »
All right, I tried the previous OS'es. 3.04 is the last version where loading a Master System image via USB works ("usb-tool.exe imgname.sms").

Attempting to load a Master System image via USB on 3.05 and 3.06 results in a black screen.

The USB port is so very, VERY handy for dev and it was a major selling point for me :( For now I can revert to 3.04, but definitely not an optimal solution in the long run.
« Last Edit: November 19, 2018, 10:12 PM by csoren »

Offline csoren

  • Newbie
  • *
  • Posts: 8
  • Karma: +1/-0
    • View Profile
Re: Bug? Unable to load Master System image via USB (X7)
« Reply #2 on: January 19, 2019, 02:08 PM »
I have tested the new 3.07 OS and this regression is still present. Loading a Master System image over USB simply results in a black screen.

Offline FeverDrive

  • Hero Member
  • *****
  • Posts: 1199
  • Karma: +53/-0
  • Blast Processing™ inside
    • View Profile
Re: Bug? Unable to load Master System image via USB (X7)
« Reply #3 on: January 19, 2019, 07:23 PM »
I don't think using an older OS alters the way your game works, right?
And so I go fast.

Offline csoren

  • Newbie
  • *
  • Posts: 8
  • Karma: +1/-0
    • View Profile
Re: Bug? Unable to load Master System image via USB (X7)
« Reply #4 on: January 19, 2019, 08:42 PM »
I doubt it, loading a Master System image from SD works the same on all the firmware versions.

Offline csoren

  • Newbie
  • *
  • Posts: 8
  • Karma: +1/-0
    • View Profile
Re: Bug? Unable to load Master System image via USB (X7)
« Reply #5 on: September 11, 2019, 11:44 AM »
Tested on 3.08 - this bug is still present. This is really quite annoying, the last version that works properly is 3.04 and there has been improvements to FM sound and now 4 MB image support in later revisions that we're missing out on.

@krikzz Can you please get this fixed so the Mega EverDrive can once again be a great choice for SMS dev?