Author Topic: Mega Everdrive X5 issues when connected to Sega CD  (Read 7552 times)

0 Members and 1 Guest are viewing this topic.

Offline ricard350

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Mega Everdrive X5 issues when connected to Sega CD
« on: December 13, 2018, 05:56 PM »
Hi, I just fired up my newly acquired Master Everdrive X5 last night, have the 3.06 firmware installed, and when I went and explored the menu, I saw a diagnostic mode in the toolbox menu.  Because I am an aircraft avionics technician by trade, I had no choice but to run it. :P

I came upon this error during the diagnostic test mode.




With that error, I still tried some classic game like Street of Rage 2, and the game freeze within about 20-30 sec of gameplay.

My setup is a Model 2 Genesis hooked up to a Model 2 Sega CD unit.

I have discovered that when I disconnect the Genesis and run the diagnostic test again it passes all test and Street of Rage 2 Works flawlessly.

Is this normal behavior for this flashcart, that it dosent work good when Genesis is connected to SegaCD?  I find this a bit irritating having to disconnect it from the CD unit everytime I want to play a genesis game....  The expansion port connector of a Genesis is not gold plated and seems a bit more fragile, I find that it could lead to premature wear of my connector.

Does anyone else experience these issues?

Offline ricard350

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: Mega Everdrive X5 issues when connected to Sega CD
« Reply #1 on: January 20, 2019, 05:07 PM »
So my everdrive must be faulty right since nobody else seem to experience this...
Can anybody try to reproduce that error?
I would like to know if its a normal behavior of the everdrive.
Maybe cause when the cd unit is detected the everdrive goes in ramcart mode to be used for segacd save and that affect its primary function?

Offline FeverDrive

  • Hero Member
  • *****
  • Posts: 1299
  • Karma: +54/-0
  • Blast Processing advocate
    • View Profile
Re: Mega Everdrive X5 issues when connected to Sega CD
« Reply #2 on: January 21, 2019, 12:13 AM »
I think this is normal behaviour, if I remember right Krikzz said a while ago that the Sega CD introduced some memory bus conflict.
If I have time I'll check with my setup (Genesis model 2 + Sega CD model 2 + MEGA ED X5).
WELCO
METOT
HENEX
TLEVEL

Offline nzChris

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: Mega Everdrive X5 issues when connected to Sega CD
« Reply #3 on: January 22, 2019, 06:42 PM »
When I get the chance, I will check my Mega Drive Model 1 and Mega CD 1 + X7 as a comparison.

Offline nzChris

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: Mega Everdrive X5 issues when connected to Sega CD
« Reply #4 on: January 23, 2019, 04:27 PM »
I tried the diagnostic test with my X7 and had no problems.

Offline Mcheza

  • Newbie
  • *
  • Posts: 17
  • Karma: +0/-0
    • View Profile
Re: Mega Everdrive X5 issues when connected to Sega CD
« Reply #5 on: February 07, 2019, 11:12 PM »
I've never run any diagnostic, but I have a Mega EverDrive X5 on a Model 2 Genesis + Model 2 Sega CD + 32X and everything works fine. I play Genesis, 32X, and CD games all the time without disconnecting anything.

When I get a chance I'll try running the diagnostic and removing the 32X from the equation.

Offline mkontrov

  • Newbie
  • *
  • Posts: 6
  • Karma: +1/-0
    • View Profile
Re: Mega Everdrive X5 issues when connected to Sega CD
« Reply #6 on: February 17, 2019, 04:23 AM »
It's probably won't help at all, but have you formatted the RAM cart for sega CD yet? Maybe that's why it's throwing an error?

Offline ifury512

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: Mega Everdrive X5 issues when connected to Sega CD
« Reply #7 on: March 21, 2019, 11:20 PM »
@Krikzz, i will have to agree with the OP. I have same issues if i don't have the 32x connected certain game will not work Streets of Rage 2, Comix zone and this only happens on the model 2 sega genesis, my model 1 HD works perfectly attach to the sega cd. I try turning off every option on the menu and no luck. I will like to know  if this is normal for X5 to behave this way with a model 2 genesis and sega cd?? Or my X5 needs to be replace?? Any ideas or fixes will be highly appreciated. Thx in advance.

Offline PatxiEverdrive

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: Mega Everdrive X5 issues when connected to Sega CD
« Reply #8 on: May 14, 2019, 02:24 AM »
Hi all. I have the same problem as @ricard350 with Mega Everdrive X5, but in my case I do not have a Mega CD or 32X connected. My megadrive is a model version 2 PAL. When I load a ROM, at the beginning everything is fine, but suddenly the game freezes and I get 'Error: 01' in the 'RAM data test' section of the diagnostics. Did you finally solve the problem or the X5 was defective? Someone to guide me on this subject will be welcome Thanks and regards!

Offline Goldanas

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
Re: Mega Everdrive X5 issues when connected to Sega CD
« Reply #9 on: September 02, 2019, 12:24 AM »
I'm adding on to this to say that my x5 is the same. Without the Sega CD, games play fine, but with it attached, many games will freeze, or some will have graphical errors. Ram test is fine without the Sega CD, but Error 01 with it attached.

Additionally, when you try to use the x5 as a RAM cart with Sega CD games, it causes problems. For example, Popful Mail will display the Main CPU error l, which displays when RAM isn't formatted, but it displays it all garbled. Also, when viewing the Memory manager on the CD player menu, it seems to incorrectly report the space used on the Sega CD and the RAM cart itself, giving different values each time you go in.

This is all on Model 2 Genesis and Model 2 Sega CD, no 32X. I'm curious if I get a 32X if it will solve it. It basically seems like there's some kind of conflict when both units are attached.

Edit:
It looks like the battery for the onboard Sega CD RAM may be done. It holds a charge for a bit of time after the unit has been powered off, but will need a format due to a wipe, if left powered off for long enough.

I have a feeling replacing that battery may solve the issue, as another thread seemed to remark as such for a similar if not the same issue. I will report back with what I find.
« Last Edit: September 02, 2019, 12:40 AM by Goldanas »

Offline Goldanas

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
Re: Mega Everdrive X5 issues when connected to Sega CD
« Reply #10 on: September 18, 2019, 02:13 AM »
I've installed the new battery, and can confirm that the unit is now storing saves even when disconnected from power for extended periods of time.

Unfortunately, the issue is still there, specifically while the Model 2 is connected I get the Error:01 message for RAM data. The issue with the distorted readout in the memory manager on the Sega CD is also still present, but I was able to read and copy a save from the RAM cart of the Everdrive back to the Sega CD, so I guess that portion is still functioning. Jusst some kind of issue with the shared RAM space that's affected specifically when the CD extends it.

If there's a fix to this, I'd love to know, but it sounds like I need to replace the X5.

Offline Sid

  • Administrator
  • Newbie
  • *****
  • Posts: 19
  • Karma: +2/-0
    • View Profile
Re: Mega Everdrive X5 issues when connected to Sega CD
« Reply #11 on: September 23, 2019, 09:45 AM »
Dear Customers, please write me what revision of Mega X5 do you have. You can contact me throught https://krikzz.com/store/contact-us
EverDrive support team

Offline Goldanas

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
Re: Mega Everdrive X5 issues when connected to Sega CD
« Reply #12 on: September 25, 2019, 07:40 AM »
Final update and Potentially Fixed:
I got the 32X, and it's not a problem anymore. Ram check passes, games load correctly, and booting to the Sega CD and looking at the Memory to check the saves shows as expected (no corruption and it has an accurate data count).

In essence, it looks like it's just a bus conflict, possibly specifically related to my specific revision of Model 2 Genesis (it's the smaller base plate one).

Hopefully this helps anyone else who has this problem, just buy a 32X (haha), or perhaps if the Everdrive team wants more information, I can provide it to help find a solution.

Offline Dontpanic42

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Re: Mega Everdrive X5 issues when connected to Sega CD
« Reply #13 on: September 26, 2019, 12:07 PM »
I'm having the same problem but unlike you guys I have a Model 1 Genesis, Model 2 Sega CD, and a 32x.  I haven't turned on the Genesis in a while so I came to see if needed to update.  So I'm going to try that first.

Edit:  Have you guys tried pulling off the 32x and putting it back in again?  That seems to fix it.
« Last Edit: September 26, 2019, 12:13 PM by Dontpanic42 »

Offline Goldanas

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
Re: Mega Everdrive X5 issues when connected to Sega CD
« Reply #14 on: September 26, 2019, 06:45 PM »
I'm having the same problem but unlike you guys I have a Model 1 Genesis, Model 2 Sega CD, and a 32x.  I haven't turned on the Genesis in a while so I came to see if needed to update.  So I'm going to try that first.

Edit:  Have you guys tried pulling off the 32x and putting it back in again?  That seems to fix it.

I've been speaking with the support staff, and they seem to suggest that this may be a fault of a specific revision of the x5. Open up your cart and check the board. If you see Model 16 rev. C on the PCB, then you may need to send it in to get rev. D.