Author Topic: SD2SNES DIAGNOSTICS "RAM FAILED" / Kirby Super Star with v1.9.0 not working  (Read 5138 times)

0 Members and 1 Guest are viewing this topic.

Offline Richardragon87

  • SNESAdvance Revival Coder
  • Sr. Member
  • ****
  • Posts: 301
  • Karma: +4/-0
    • View Profile
Kirby Super Star is a weird one for sure on SA1 emulated on a SD2SNES for sure...

The USA version has a weird line going through the middle of the screen as well as lines in some sprite enemies and Kirby

The Europe version has the above though it will always be the more based off below version due to effects and stuff

The Japan version has hardly any glitches though some lines are below a few sprites and dying causes lines to appear

If you get it to work and experience these problems it happens to everyone not just on your received SD2SNES.
[quote Random dating spambotJ

Quote
Post changed:

Great, the photo didn't load! Does anyone know how to fix this?
In any case, my other photos can be viewed here, I will be glad to meet you, I love flirt))

P.S Richardragon87! Don't write me again, dude! You're in ignore list!

Offline BambooShadow

  • Newbie
  • *
  • Posts: 21
  • Karma: +0/-0
    • View Profile
    • BambooShadow @ twitch.tv
Quote
The USA version has a weird line going through the middle of the screen as well as lines in some sprite enemies and Kirby

The Europe version has the above though it will always be the more based off below version due to effects and stuff

The Japan version has hardly any glitches though some lines are below a few sprites and dying causes lines to appear

oh that's surely interesting... well I hope, I'll be able to try it out, once my SD2SNES gets repaired

Offline BambooShadow

  • Newbie
  • *
  • Posts: 21
  • Karma: +0/-0
    • View Profile
    • BambooShadow @ twitch.tv
Alrighty, my repaired/new (I think they did just send me a new unit) arrived just today and I immediately ran the SD2SNES diagnostics:
Full log: https://pastebin.com/jPZnANGL

Quote
TEST SUMMARY
============

flash check:   1111-4-33b04504-dfb09a7f-b8-11-0 
Test      Result
----------------
SD        Passed
USB       not implemented
RTC       Passed
CIC       no run
FPGA      Passed
RAM       Passed
SD DMA    Passed
CLK       Passed
DAC       not implemented
SNES IRQ  FAILED
SNES RAM  Passed
SNES PA   Passed

I did run KSS and it worked! So seems it was a problem with the ram after all!

Any idea what's up with that "SNES IRQ"?

thanks & greetings
bamboo

Offline alan-932

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Hello everyone, my SD2NES does not start anything. The log had several RAM failures.

===log opened===
derp
SD test... please insert card
=============================
data=111133b04504
crc1 = d805a1bf crc2 = d805a1bf PASSED

RTC Test
========
setting clock to 2011-01-01 00:00:00
2011-01-01 00:00:00
waiting 5 seconds
new time: 2011-01-01 00:00:05
PASSED

FPGA test
=========
configuring fpga...
fpga_pgm: 212501 bytes programmed
FPGA configured
basic communication test...PASSED

RAM test
========
Testing RAM0 (128Mbit) - clearing RAM - writing RAM - verifying RAM -error @0x000040: expected 0x40, got 0x00
error @0x0000c0: expected 0xc0, got 0x80
error @0x000140: expected 0x41, got 0x01
error @0x0001c0: expected 0xc1, got 0x81
error @0x00023e: expected 0x40, got 0x00
error @0x0002be: expected 0xc0, got 0x80
error @0x00033e: expected 0x41, got 0x01
error @0x0003be: expected 0xc1, got 0x81
error @0x00043c: expected 0x40, got 0x00
error @0x0004bc: expected 0xc0, got 0x80
error @0x00053c: expected 0x41, got 0x01
error @0x0005bc: expected 0xc1, got 0x81
error @0x00063a: expected 0x40, got 0x00
error @0x0006ba: expected 0xc0, got 0x80
error @0x00073a: expected 0x41, got 0x01
error @0x0007ba: expected 0xc1, got 0x81
error @0x000838: expected 0x40, got 0x00
error @0x0008b8: expected 0xc0, got 0x80
error @0x000938: expected 0x41, got 0x01
error @0x0009b8: expected 0xc1, got 0x81
error @0x000a36: expected 0x40, got 0x00
too many errors, aborting
RAM0 FAILED
Testing RAM1 (4Mbit) - writing RAM - verifying RAM...RAM1 PASSED

SD DMA test
===========
clearing RAM - loading test file - verifying -error @0x000040: expected 0x40, got 0x00
error @0x0000c0: expected 0xc0, got 0x80
error @0x000140: expected 0x41, got 0x01
error @0x0001c0: expected 0xc1, got 0x81
error @0x00023e: expected 0x40, got 0x00
error @0x0002be: expected 0xc0, got 0x80
error @0x00033e: expected 0x41, got 0x01
error @0x0003be: expected 0xc1, got 0x81
error @0x00043c: expected 0x40, got 0x00
error @0x0004bc: expected 0xc0, got 0x80
error @0x00053c: expected 0x41, got 0x01
error @0x0005bc: expected 0xc1, got 0x81
error @0x00063a: expected 0x40, got 0x00
error @0x0006ba: expected 0xc0, got 0x80
error @0x00073a: expected 0x41, got 0x01
error @0x0007ba: expected 0xc1, got 0x81
error @0x000838: expected 0x40, got 0x00
error @0x0008b8: expected 0xc0, got 0x80
error @0x000938: expected 0x41, got 0x01
error @0x0009b8: expected 0xc1, got 0x81
error @0x000a36: expected 0x40, got 0x00
too many errors, aborting
FAILED

Loading SNES test ROM
=====================
sysclk test
===========
measuring SNES clock...
21453838 Hz
21453838 Hz diff = 0 max = 0
21453839 Hz diff = 1 max = 1
21453838 Hz diff = 1 max = 1
CPUCLK: 3470780
READCLK: 0
WRITECLK: 0
PARDCLK: 0
PAWRCLK: 0
REFRCLK: 78645
ROMSELCLK: 0
PASSED

SNES test status: IRQ: 00 PA: 00 MEM: 00/00
Timeout! SNES appears to be dead!

TEST SUMMARY
============

flash check: 1111-4-33b04504-dfb09a7f-ba-11-0
Test Result
----------------
SD Passed
USB not implemented
RTC Passed
CIC no run
FPGA Passed
RAM FAILED
SD DMA FAILED
CLK Passed
DAC not implemented
SNES IRQ FAILED
SNES RAM FAILED
SNES PA FAILED

Offline EverDriver

  • Administrator
  • Hero Member
  • *****
  • Posts: 547
  • Karma: +42/-0
  • support
    • View Profile
Hi alan!

It seems your device has been damaged while being delivered and it needs to be repaired or replaced.
I wrote to you in the store. Please check it.

Offline alan-932

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
TKS Everdriver!

Offline alan-932

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
I've been trying to reach Krikzz's support since day 29/04/2019 and I have no answer. What's happening?

Offline EverDriver

  • Administrator
  • Hero Member
  • *****
  • Posts: 547
  • Karma: +42/-0
  • support
    • View Profile
Could you please PM me your email that you used in the store?
Also please be sure that our messages haven't been moved to the spam.
Unfortunately the only email service that does it very often is hotmail.

Offline alan-932

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile

The e-mail address used for sending is alan-932@hotmail.com.

Offline EverDriver

  • Administrator
  • Hero Member
  • *****
  • Posts: 547
  • Karma: +42/-0
  • support
    • View Profile
I can see that your package should be here but we can't find it yet.
After we find your package I will write back to you.

Offline EverDriver

  • Administrator
  • Hero Member
  • *****
  • Posts: 547
  • Karma: +42/-0
  • support
    • View Profile
We found your device.
Sorry for the delay.
The new one will be shipped as soon as possible.