Author Topic: EverDrive 64 2.5v isnt working  (Read 1326 times)

0 Members and 1 Guest are viewing this topic.

Offline Djflash816

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
EverDrive 64 2.5v isnt working
« on: January 17, 2019, 03:43 AM »
I just received my everdrive about a week ago. Formatted my sd card, added OS-V2.12 & downloaded my games etc. But when I put the game in, nothing happens. It's like it doesnt even register.

My first question is, even without the SD card, if I put the everdrive cartridge in, should something still come up on the screen? Cause I Get Nothing w/ or w/o the SD card in it... And i know my n64 works because the other games i have still works... any idea what a going on?

Offline Grizzmeister

  • Jr. Member
  • **
  • Posts: 50
  • Karma: +2/-0
    • View Profile
Re: EverDrive 64 2.5v isnt working
« Reply #1 on: January 17, 2019, 04:03 AM »
Confirm that your EverDrive is set to the correct region. There's a small switch inside by the hole for the SD card that switches it between PAL and NTSC. If that doesn't work then remove the case and try slotting just the PCB in your N64. That's what I had to do to get mine to work. Here's a picture of what it looks like.


Offline FeverDrive

  • Hero Member
  • *****
  • Posts: 1299
  • Karma: +54/-0
  • Blast Processing advocate
    • View Profile
Re: EverDrive 64 2.5v isnt working
« Reply #2 on: January 17, 2019, 05:32 AM »
Check the region switch and also check if your Everdrive actually has the CIC chip installed.
WELCO
METOT
HENEX
TLEVEL

Offline Djflash816

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: EverDrive 64 2.5v isnt working
« Reply #3 on: January 17, 2019, 05:16 PM »
Man yall are geniuses!!! Sure enough I hit the switch over and it worked!!! Finally!! Thank you.... idk why this thang dont come with instructions... how the heck was I suppose to know that?! Smh anyway, I appreciate it!!!