Author Topic: Firmware v1.10.3 are out.  (Read 5186 times)

0 Members and 1 Guest are viewing this topic.

Offline lee4

  • codetype specialist
  • Hero Member
  • *****
  • Posts: 758
  • Karma: +43/-0
    • View Profile
    • gamehacking.org
Firmware v1.10.3 are out.
« on: April 05, 2019, 01:45 AM »
changelog:

    [Mk2] Revert S-DD1 bitfile to earlier build which happens to less expose a timing hazard. This will need further examination for a proper fix. Fixes severe glitches with S-DD1.
    [All] Fix swapped logic terms in SA-1 and SuperFX RAM write cycles. Fixes severe glitches on SA-1 and SuperFX on Mk.II units; The bug was also present in the Pro firmware but didn’t seem to have much of an effect.
    [All] Fix game video mode setting in SuperCIC pair mode.

source:
https://sd2snes.de/blog/archives/1072
« Last Edit: April 07, 2019, 02:58 AM by lee4 »
ED64 v2.0, 3.0 & X7 | EDMD v3 | MEGAED X7 M15 v2.01 | TED v2.4 | EDN8 v1.2N | SED v2.1 | SD2SNES rev E1 & PRO rev.B | EDGB v1.1 & X7 M17 rev B | EDGBA X5 M16 rev A
Super NT | Mega SG | Super Retro Advance | SGB v1 | PCE+SSD3

Offline Jagasian

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Re: Firmware v1.10.3 are out.
« Reply #1 on: April 05, 2019, 06:13 AM »
No other FPGA device for console gaming has been actively supported and improved as long as sd2snes.  It has always been the best flash cart for the SNES, and it continues to add more and more functionality that the other flash carts lack.

Offline Kobe

  • Newbie
  • *
  • Posts: 25
  • Karma: +0/-0
    • View Profile
Re: Firmware v1.10.3 are out.
« Reply #2 on: April 05, 2019, 11:17 AM »
This says for "MkII" models. Did a new SD2SNES come out recently? Or will this firmware work with my unit that I bought 4 years ago?

Offline Richardragon87

  • SNESAdvance Revival Coder
  • Sr. Member
  • ****
  • Posts: 266
  • Karma: +4/-0
    • View Profile
Re: Firmware v1.10.3 are out.
« Reply #3 on: April 05, 2019, 11:48 AM »
This says for "MkII" models. Did a new SD2SNES come out recently? Or will this firmware work with my unit that I bought 4 years ago?

I think the MKII is just a current example of the latest version. I have been using MK II updates of my 4 year one or which ever one Retrotowers have been using and all systems are a go with it.
[quote Random dating spambotJ

Quote
Post changed:

Great, the photo didn't load! Does anyone know how to fix this?
In any case, my other photos can be viewed here, I will be glad to meet you, I love flirt))

P.S Richardragon87! Don't write me again, dude! You're in ignore list!

Offline gaavoid

  • Newbie
  • *
  • Posts: 24
  • Karma: +1/-0
    • View Profile
Re: Firmware v1.10.3 are out.
« Reply #4 on: April 05, 2019, 12:14 PM »
Just pinned by Ikari on the classic gaming Discord:

*** v1.10.3 DOWNLOAD REMOVED - DO NOT USE *** - saved game corruption hazard on SuperFX + SA-1. For now I recommend to keep using v1.10.1 (on Mk.2) or v1.10.2 (on Pro).

Offline the_randomizer

  • Full Member
  • ***
  • Posts: 165
  • Karma: +6/-0
    • View Profile
Re: Firmware v1.10.3 are out.
« Reply #5 on: April 05, 2019, 10:00 PM »
I hate to criticize, but is there a reason the recent firmware versions have been, well, unstable lately?

It seems like the last few releases have been cursed.

Offline gaavoid

  • Newbie
  • *
  • Posts: 24
  • Karma: +1/-0
    • View Profile
Re: Firmware v1.10.3 are out.
« Reply #6 on: April 06, 2019, 01:14 AM »
I hate to criticize, but is there a reason the recent firmware versions have been, well, unstable lately?

It seems like the last few releases have been cursed.
Looks like the last error was caused by a simple typo. Should hopefully be all fixed soon.

Offline the_randomizer

  • Full Member
  • ***
  • Posts: 165
  • Karma: +6/-0
    • View Profile
Re: Firmware v1.10.3 are out.
« Reply #7 on: April 06, 2019, 02:52 AM »
I hate to criticize, but is there a reason the recent firmware versions have been, well, unstable lately?

It seems like the last few releases have been cursed.
Looks like the last error was caused by a simple typo. Should hopefully be all fixed soon.

Hmm, I hope the custom ALTTP theme will still work with it, only themes I've seen support up to 1.10.1.

Offline lee4

  • codetype specialist
  • Hero Member
  • *****
  • Posts: 758
  • Karma: +43/-0
    • View Profile
    • gamehacking.org
Re: Firmware v1.10.3 are out.
« Reply #8 on: April 06, 2019, 05:03 PM »

Hmm, I hope the custom ALTTP theme will still work with it, only themes I've seen support up to 1.10.1.
just do not update/replace menu.bin file want keep using custom theme
ED64 v2.0, 3.0 & X7 | EDMD v3 | MEGAED X7 M15 v2.01 | TED v2.4 | EDN8 v1.2N | SED v2.1 | SD2SNES rev E1 & PRO rev.B | EDGB v1.1 & X7 M17 rev B | EDGBA X5 M16 rev A
Super NT | Mega SG | Super Retro Advance | SGB v1 | PCE+SSD3

Offline the_randomizer

  • Full Member
  • ***
  • Posts: 165
  • Karma: +6/-0
    • View Profile
Re: Firmware v1.10.3 are out.
« Reply #9 on: April 06, 2019, 05:13 PM »

Hmm, I hope the custom ALTTP theme will still work with it, only themes I've seen support up to 1.10.1.
just do not update/replace menu.bin file want keep using custom theme

Um, I'm confused, isn't that part of the firmware update?

Offline lee4

  • codetype specialist
  • Hero Member
  • *****
  • Posts: 758
  • Karma: +43/-0
    • View Profile
    • gamehacking.org
Re: Firmware v1.10.3 are out.
« Reply #10 on: April 06, 2019, 06:06 PM »

Hmm, I hope the custom ALTTP theme will still work with it, only themes I've seen support up to 1.10.1.
just do not update/replace menu.bin file want keep using custom theme

Um, I'm confused, isn't that part of the firmware update?
menu.bin is just gui for sd2snes mkii non-pro

firmware.img is firmware file to update sd2snes mkii non-pro
ED64 v2.0, 3.0 & X7 | EDMD v3 | MEGAED X7 M15 v2.01 | TED v2.4 | EDN8 v1.2N | SED v2.1 | SD2SNES rev E1 & PRO rev.B | EDGB v1.1 & X7 M17 rev B | EDGBA X5 M16 rev A
Super NT | Mega SG | Super Retro Advance | SGB v1 | PCE+SSD3

Offline the_randomizer

  • Full Member
  • ***
  • Posts: 165
  • Karma: +6/-0
    • View Profile
Re: Firmware v1.10.3 are out.
« Reply #11 on: April 06, 2019, 06:21 PM »

Hmm, I hope the custom ALTTP theme will still work with it, only themes I've seen support up to 1.10.1.
just do not update/replace menu.bin file want keep using custom theme

Um, I'm confused, isn't that part of the firmware update?
menu.bin is just gui for sd2snes mkii non-pro

firmware.img is firmware file to update sd2snes mkii non-pro

That doesn't answer my previous question. The themes I've all seen only say "supported up to 1.10.0", which means, they won't work on the newest firmware. So, yeah, I'm screwed if I update to the latest, and can't use custom themes.

Site here: http://bmf.rustedlogic.net/sd2snes/ says "For use with firmware version 1.10.0" so yeah, is it compatible or not?
« Last Edit: April 06, 2019, 06:23 PM by the_randomizer »

Offline lee4

  • codetype specialist
  • Hero Member
  • *****
  • Posts: 758
  • Karma: +43/-0
    • View Profile
    • gamehacking.org
Re: Firmware v1.10.3 are out.
« Reply #12 on: April 06, 2019, 06:51 PM »

Hmm, I hope the custom ALTTP theme will still work with it, only themes I've seen support up to 1.10.1.
just do not update/replace menu.bin file want keep using custom theme

Um, I'm confused, isn't that part of the firmware update?
menu.bin is just gui for sd2snes mkii non-pro

firmware.img is firmware file to update sd2snes mkii non-pro

That doesn't answer my previous question. The themes I've all seen only say "supported up to 1.10.0", which means, they won't work on the newest firmware. So, yeah, I'm screwed if I update to the latest, and can't use custom themes.

Site here: http://bmf.rustedlogic.net/sd2snes/ says "For use with firmware version 1.10.0" so yeah, is it compatible or not?
theme made for menu.bin v1.10.0, they will work on firmware 1.10.0 to 1.10.10 includes 1.10.1, 1.10.2, 1.10.3 and 1.10.4
theme made for menu.bin v1.10.0 will not work on 1.11.0
« Last Edit: April 06, 2019, 06:53 PM by lee4 »
ED64 v2.0, 3.0 & X7 | EDMD v3 | MEGAED X7 M15 v2.01 | TED v2.4 | EDN8 v1.2N | SED v2.1 | SD2SNES rev E1 & PRO rev.B | EDGB v1.1 & X7 M17 rev B | EDGBA X5 M16 rev A
Super NT | Mega SG | Super Retro Advance | SGB v1 | PCE+SSD3

Offline the_randomizer

  • Full Member
  • ***
  • Posts: 165
  • Karma: +6/-0
    • View Profile
Re: Firmware v1.10.3 are out.
« Reply #13 on: April 07, 2019, 01:04 AM »

Hmm, I hope the custom ALTTP theme will still work with it, only themes I've seen support up to 1.10.1.
just do not update/replace menu.bin file want keep using custom theme

Um, I'm confused, isn't that part of the firmware update?
menu.bin is just gui for sd2snes mkii non-pro

firmware.img is firmware file to update sd2snes mkii non-pro

That doesn't answer my previous question. The themes I've all seen only say "supported up to 1.10.0", which means, they won't work on the newest firmware. So, yeah, I'm screwed if I update to the latest, and can't use custom themes.

Site here: http://bmf.rustedlogic.net/sd2snes/ says "For use with firmware version 1.10.0" so yeah, is it compatible or not?
theme made for menu.bin v1.10.0, they will work on firmware 1.10.0 to 1.10.10 includes 1.10.1, 1.10.2, 1.10.3 and 1.10.4
theme made for menu.bin v1.10.0 will not work on 1.11.0

So what's the difference between the firmware files themselves, and the menu.bin? Can I use a 1.10.3 with a theme that was made on 1.10.0?  That's what you're saying, correct?  I don't want to end up bricking it.

Offline lee4

  • codetype specialist
  • Hero Member
  • *****
  • Posts: 758
  • Karma: +43/-0
    • View Profile
    • gamehacking.org
Re: Firmware v1.10.3 are out.
« Reply #14 on: April 07, 2019, 02:59 AM »
1.10.3 is broken
ED64 v2.0, 3.0 & X7 | EDMD v3 | MEGAED X7 M15 v2.01 | TED v2.4 | EDN8 v1.2N | SED v2.1 | SD2SNES rev E1 & PRO rev.B | EDGB v1.1 & X7 M17 rev B | EDGBA X5 M16 rev A
Super NT | Mega SG | Super Retro Advance | SGB v1 | PCE+SSD3