Author Topic: SD2SNES stopped working  (Read 1383 times)

0 Members and 1 Guest are viewing this topic.

Offline fwannmacher

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
SD2SNES stopped working
« on: November 20, 2019, 01:25 AM »
I have a SD2SNES for a good amount of time and I didn't use it for more than a year. Today I tried to play some games and my cart won't boot the OS
Code: [Select]
===log opened===
derp
SD test... please insert card
=============================
data=111133b04504
crc1 = d805a1bf crc2 = d805a1bf   PASSED


RTC Test
========
setting clock to 2011-01-01 00:00:00
2011-01-01 00:00:00
waiting 5 seconds
new time: 2011-01-01 00:00:05
PASSED


FPGA test
=========
configuring fpga...
fpga_pgm: 212501 bytes programmed
FPGA configured
basic communication test...PASSED


RAM test
========
Testing RAM0 (128Mbit) - clearing RAM - writing RAM - verifying RAM -error @0x000001: expected 0x01, got 0x09
error @0x000003: expected 0x03, got 0x0b
error @0x000005: expected 0x05, got 0x0d
error @0x000007: expected 0x07, got 0x0f
error @0x000011: expected 0x11, got 0x19
error @0x000013: expected 0x13, got 0x1b
error @0x000015: expected 0x15, got 0x1d
error @0x000017: expected 0x17, got 0x1f
error @0x000021: expected 0x21, got 0x29
error @0x000025: expected 0x25, got 0x2d
error @0x000031: expected 0x31, got 0x39
error @0x000035: expected 0x35, got 0x3d
error @0x000041: expected 0x41, got 0x49
error @0x000045: expected 0x45, got 0x4d
error @0x000051: expected 0x51, got 0x59
error @0x000055: expected 0x55, got 0x5d
error @0x000061: expected 0x61, got 0x69
error @0x000067: expected 0x67, got 0x6f
error @0x000071: expected 0x71, got 0x79
error @0x000075: expected 0x75, got 0x7d
error @0x000081: expected 0x81, got 0x89
too many errors, aborting
RAM0 FAILED
Testing RAM1 (4Mbit) - writing RAM - verifying RAM...RAM1 PASSED


SD DMA test
===========
clearing RAM - loading test file - verifying -error @0x000001: expected 0x01, got 0x09
error @0x000003: expected 0x03, got 0x0b
error @0x000005: expected 0x05, got 0x0d
error @0x000007: expected 0x07, got 0x0f
error @0x000011: expected 0x11, got 0x19
error @0x000013: expected 0x13, got 0x1b
error @0x000015: expected 0x15, got 0x1d
error @0x000017: expected 0x17, got 0x1f
error @0x000021: expected 0x21, got 0x29
error @0x000023: expected 0x23, got 0x2b
error @0x000027: expected 0x27, got 0x2f
error @0x000031: expected 0x31, got 0x39
error @0x000035: expected 0x35, got 0x3d
error @0x000037: expected 0x37, got 0x3f
error @0x000041: expected 0x41, got 0x49
error @0x000045: expected 0x45, got 0x4d
error @0x000051: expected 0x51, got 0x59
error @0x000055: expected 0x55, got 0x5d
error @0x000061: expected 0x61, got 0x69
error @0x000065: expected 0x65, got 0x6d
error @0x000071: expected 0x71, got 0x79
too many errors, aborting
FAILED


Loading SNES test ROM
=====================



sysclk test
===========
measuring SNES clock...
21454013 Hz
21454012 Hz diff = 1  max = 1
21454012 Hz diff = 0  max = 1
21454012 Hz diff = 0  max = 1
   CPUCLK: 3470808
  READCLK: 0
 WRITECLK: 0
  PARDCLK: 0
  PAWRCLK: 0
  REFRCLK: 78645
ROMSELCLK: 0
PASSED


SNES test status: IRQ: 00   PA: 00   MEM: 00/00
Timeout! SNES appears to be dead!



TEST SUMMARY
============

flash check:   1111-4-33b04504-dfb09a7f-00-11-0 
Test      Result
----------------
SD        Passed
USB       not implemented
RTC       Passed
CIC       no run
FPGA      Passed
RAM       FAILED
SD DMA    FAILED
CLK       Passed
DAC       not implemented
SNES IRQ  FAILED
SNES RAM  FAILED
SNES PA   FAILED

I would appreciate any help! :-)

Offline Sarge

  • Sr. Member
  • ****
  • Posts: 327
  • Karma: +16/-0
    • View Profile
Re: SD2SNES stopped working
« Reply #1 on: November 20, 2019, 01:38 AM »
Given that it says to insert an SD card, I'm guessing either something went wrong on your SD, or something isn't making contact in the SD card slot properly.
Hardcore Retro Gaming - Discuss games ten years old or older! Now with a modern gaming section!

http://hardcoreretrogaming.boards.net/

Offline fwannmacher

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
Re: SD2SNES stopped working
« Reply #2 on: November 20, 2019, 01:58 AM »
I think that if the SD card was the problem it wouldn't even boot the diagnostic firmware

Offline Sarge

  • Sr. Member
  • ****
  • Posts: 327
  • Karma: +16/-0
    • View Profile
Re: SD2SNES stopped working
« Reply #3 on: November 20, 2019, 06:45 AM »
Whoops, I totally missed all the other lines of the log, and a little logic should have told me the SD card would need to work to get the log. My bad!

I'm not sure what's going on, but someone else had a similar issue in this thread:

https://krikzz.com/forum/index.php?topic=9290.0

And this one:

http://krikzz.com/forum/index.php?topic=7092.0

Could very well be solder joints giving an issue on that RAM chip.
« Last Edit: November 20, 2019, 06:47 AM by Sarge »
Hardcore Retro Gaming - Discuss games ten years old or older! Now with a modern gaming section!

http://hardcoreretrogaming.boards.net/

Offline fwannmacher

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
Re: SD2SNES stopped working
« Reply #4 on: November 20, 2019, 02:28 PM »
I'll try resoldering the memory chip and see what happens

Offline Sarge

  • Sr. Member
  • ****
  • Posts: 327
  • Karma: +16/-0
    • View Profile
Re: SD2SNES stopped working
« Reply #5 on: November 20, 2019, 06:40 PM »
If it's still under warranty, you might want to see if you can get it fixed that way. Although you might be a pro around a soldering iron! :)
Hardcore Retro Gaming - Discuss games ten years old or older! Now with a modern gaming section!

http://hardcoreretrogaming.boards.net/

Offline FeverDrive

  • Hero Member
  • *****
  • Posts: 1280
  • Karma: +54/-0
  • Blast Processing advocate
    • View Profile
Re: SD2SNES stopped working
« Reply #6 on: November 24, 2019, 06:04 AM »
Have you tried using another SNES console?
WELCO
METOT
HENEX
TLEVEL

Offline chadrowley

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: SD2SNES stopped working
« Reply #7 on: December 17, 2019, 06:04 AM »
thank you for your help it worked for me