Author Topic: GB X7 Read/Write Light Solid in Menus  (Read 750 times)

0 Members and 1 Guest are viewing this topic.

Offline EnderIII

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
GB X7 Read/Write Light Solid in Menus
« on: July 11, 2019, 08:55 AM »
Hello,

I have a question.  I am using an Everdrive GB X7 on two Game Boy Color devices.

On the first (a revision 3 mobo) the read/write light lights up and blinks a bit on boot, then turns off.  On the other (rev 04 mobo) it lights up and stays lit, lightly blinking, while on the menu.  It does not turn off until I boot a game.  It does seem to boot and run games.  But it freezes quite often.

I  have heard that this is a sign that there are power issues.  Does anyone know if this will cause issues for me?  And if so, how I can fix it?

Thank you.
« Last Edit: July 11, 2019, 09:24 AM by EnderIII »

Offline xythen

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: GB X7 Read/Write Light Solid in Menus
« Reply #1 on: July 23, 2019, 07:40 PM »
I just received a new X7 from Amazon today as an upgrade to my original model Everdrive GB, and noticed this issue too. It stood out because the original Everdrive GB didn't do it.

Testing on the three devices I have to hand, the light stays on (not fully bright, and flickering) when in the menu on my two GBA SPs (001 and 101 models, both unmodded). They both have fully charged batteries, and it happens while the charger is plugged in too. However, it doesn't seem to happen with my original Gameboy Color.

I've taken a picture to show what I mean:



The games seem to load and save fine, and the light turns off once a game is loaded, but I've not had a chance to test things extensively to see if there are any issues.

Could someone else test theirs on a GBA SP and see if it acts the same? (Mine says "Model 17, Rev.C" on the back). If it's a known characteristic of the X7 hardware when used in GBA SPs, and it's harmless, then that's fine. But if not, I'm concerned there could be a potential problem and might return to Amazon for a replacement.

Offline Richardragon87

  • SNESAdvance Revival Coder
  • Full Member
  • ***
  • Posts: 192
  • Karma: +3/-0
    • View Profile
Re: GB X7 Read/Write Light Solid in Menus
« Reply #2 on: July 23, 2019, 09:58 PM »
It's more likely due to the fact the X7 relies heavely on trying to load a whole folder directory before the roms are displayed, it's so fast it requires multiple light ups on a blank page before roms appear causing that issue,
[quote Random dating spambotJ

Quote
Post changed:

Great, the photo didn't load! Does anyone know how to fix this?
In any case, my other photos can be viewed here, I will be glad to meet you, I love flirt))

P.S Richardragon87! Don't write me again, dude! You're in ignore list!

Offline xythen

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: GB X7 Read/Write Light Solid in Menus
« Reply #3 on: July 23, 2019, 11:50 PM »
It's more likely due to the fact the X7 relies heavely on trying to load a whole folder directory before the roms are displayed, it's so fast it requires multiple light ups on a blank page before roms appear causing that issue,

No, that doesn't seem to be the issue. The light also remains on when using a completely blank sd card apart from the system folder, and doesn't switch off no matter how long you leave it. It only switches off after loading a game (and after the usual blinking that occurs during that process).

When operating normally on my GBC, the light is off, then flashes briefly when you navigate to new folders etc. On the GBA units, the light is on constantly at about half brightness, and flickers erratically as you navigate through folders and options.
« Last Edit: July 23, 2019, 11:52 PM by xythen »

Offline Richardragon87

  • SNESAdvance Revival Coder
  • Full Member
  • ***
  • Posts: 192
  • Karma: +3/-0
    • View Profile
Re: GB X7 Read/Write Light Solid in Menus
« Reply #4 on: July 24, 2019, 01:00 AM »
It's more likely due to the fact the X7 relies heavely on trying to load a whole folder directory before the roms are displayed, it's so fast it requires multiple light ups on a blank page before roms appear causing that issue,

No, that doesn't seem to be the issue. The light also remains on when using a completely blank sd card apart from the system folder, and doesn't switch off no matter how long you leave it. It only switches off after loading a game (and after the usual blinking that occurs during that process).

When operating normally on my GBC, the light is off, then flashes briefly when you navigate to new folders etc. On the GBA units, the light is on constantly at about half brightness, and flickers erratically as you navigate through folders and options.

Well that may be true, but from my exprience I noticed that constant flickering fast when they made later X versions of it.

For example take the old EDGB that used to freeze for a good 10 seconds it would just have a constant light lit up when acessing a random folder, lets say using an official Smokemonster ordered rom set this would show case every game in the folder whever it was 100 to even over 300.

So for basically a directory that said GB USA A-Z when clicked on it would freeze for a few seconds on HUD then load up the folder which would show every game in it.

While the EDGB X7 was so quick on loading games up instantly without a process bar it ends up loading the folder up before the roms had time to display in the folder this also means it will flicker every time you acess a new page, so what you should be seeing is a blank directory which would take around 10 seconds to load the list up... along with other pages of roms each and every time you exit out of a folder and enter a new one, and from the OP it also seems like it ran into an even bigger issue now than it was.

So from what I figured out is the light always flickers on the X7 due to the fact it needs to process every rom after a folder is acessed while the older X versions likely did this automatically in someway.
[quote Random dating spambotJ

Quote
Post changed:

Great, the photo didn't load! Does anyone know how to fix this?
In any case, my other photos can be viewed here, I will be glad to meet you, I love flirt))

P.S Richardragon87! Don't write me again, dude! You're in ignore list!

Offline xythen

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: GB X7 Read/Write Light Solid in Menus
« Reply #5 on: July 24, 2019, 02:42 AM »
I think I follow what you’re saying. And your theory might hold water if the third picture in my original post didn’t already disprove it. If the X7 is truly constantly accessing the sd while sitting idle on the menu as you believe, then why is the led off when the same card is used on my GBC? On that system it acts just like my older EDGB, with the led only flashing when it’s reading from the card, but is otherwise off.

Clearly there’s something else going on here, and it doesn’t appear to be intended behaviour. My question is whether this is a systemic feature of the hardware, or an issue with my particular card that may indicate something potentially more serious.