Author Topic: New 0xF3 FAT Error [Solved]  (Read 820 times)

0 Members and 1 Guest are viewing this topic.

Offline Cyberonix

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
New 0xF3 FAT Error [Solved]
« on: August 20, 2019, 07:46 AM »
I have an Everdrive 64 V3 that was working perfectly. I haven't used it for a while and decided to run Banjo-Kazooie. When I tried to launch the game, however, it only gives me an "ERROR 0xF3 FAT System Error" message. Thinking it might be a problem with the actual ROM I tried a different game, then another, but any ROM I try to load gives me that same error.

I had originally done some recent maintenance on the SD card which I though might have caused this but on closer inspection I don't think that's it.

It's a previously working 32GB card formatted as FAT32 32k cluster size. I re-installed the latest OS and re-copied my ROMs to it.

I think this might be a save ram issue. I noticed when I try to start any game it flashes a message for a split second that says "Save Memory" before immediately displaying the above error. I'm assuming it's trying to save the last loaded game's save ram and failing.

I looked over my last played games and it looks like Conker's Bad Fur Day was the last game I loaded and previous to that was Donkey Kong 64. I thought I'd read somewhere that Conker's has some unusual save ram. Could this be causing problems? As of right now I have a non-functional cartridge so any suggestions would be appreciated.

One thing that slipped by when trying to figure this out was that all roms in the menu displayed as zero kb. For some reason when I copied them from the SD card to my PC and then back again after doing some maintenance the majority of them contained no data (on either the hard drive or SD card). I have no idea why. Restoring them from a backup did the trick and the ED64 is working again.
« Last Edit: August 21, 2019, 08:00 AM by Cyberonix »

Offline Galron

  • Hero Member
  • *****
  • Posts: 625
  • Karma: +14/-0
    • View Profile
Re: New 0xF3 FAT Error [Solved]
« Reply #1 on: August 26, 2019, 03:26 AM »
I had this problem happen to me the other day, after trying to load a romhack game... I think it was Voyager of Time or Majora's Mask Master Quest. Now if I tried to load any other game I got the 0xF3 FAT Error. But I could still load the romhack from the 'previously played' menu.

I think I tried running the Debug Test, and also trying to load from the 'previously played' games list, and it loaded another game. Once I loaded one of the standard games that way, it then let me load new roms again without the error...

It was very strange.