Author Topic: Battery Has Run Dry  (Read 541 times)

0 Members and 1 Guest are viewing this topic.

Offline whitetea

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Battery Has Run Dry
« on: October 06, 2019, 07:49 PM »
Hi,

I'm having an issue with the EverDrive-GB x7.

The battery seems to have run dry. I've replaced it with a new battery, but I'm still getting the same warning on startup, RTC still resets and saves (both natives and emulator) still malfunction.

I've tested both batteries with a voltmeter and I can confirm the old one did actually run dry, but the new one should be fine.

The cartridge is a Model 17, Rev.A, dated 06.06.2017.

It worked perfectly fine until now.

I'm attaching a few pictures, hope any of them help debugging the issue.

The one of the voltmeter reading says 2.67, that's for the new battery, and it was reading ~2.9 before I left the battery inside the cartridge overnight, just after I bought it.

Can you help me figure out what's wrong? I'm wondering whether I somehow inserted the new battery incorrectly, or fear the EverDrive might have been damaged somehow.

Offline KRIKzz

  • Administrator
  • Hero Member
  • *****
  • Posts: 3091
  • Karma: +478/-2
    • View Profile
Re: Battery Has Run Dry
« Reply #1 on: October 06, 2019, 11:48 PM »
So battery drops from 2.9 to 2.67 for one night? This is abnormal power draws, may be something wrong with your cart.
Can you try to measure battery draws? Put the battery on the top of battery socket as on the photo and check how much it actually draws. Should be less than 1ua if everything fine.


Offline Marteicos

  • Sr. Member
  • ****
  • Posts: 271
  • Karma: +10/-0
    • View Profile
Re: Battery Has Run Dry
« Reply #2 on: October 13, 2019, 03:29 PM »
Check in Ever4.jpg
Isn't the battery inserted with the wrong polarity?
I hope it didn't break the cart.

The battery is upside down, the positive pole is up, not down.

Edit: checking the image again the battery is shorted, your cart is probably fine but you will need another battery.
« Last Edit: October 13, 2019, 03:30 PM by Marteicos »

Offline whitetea

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: Battery Has Run Dry
« Reply #3 on: October 15, 2019, 11:17 PM »
You're actually right Marteicos. My girlfriend saw I had inserted the battery the wrong way round a few days ago, but I haven't had time to come back here until now. Sorry for the late reply and false alarm! The EverDrive is working perfectly, as usual.

Thanks KRIKzz and Marteicos for the help!