Author Topic: Super Everdrive X5 - Glitches with Assault Suit Valken  (Read 436 times)

0 Members and 1 Guest are viewing this topic.

Offline Ybaresan

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Super Everdrive X5 - Glitches with Assault Suit Valken
« on: December 14, 2019, 10:47 AM »
Hello everyone,

I created this topic to indicate glitches with the Super Everdrive 5X on the game Assault Suit Valken. Here is a video of the problem:

https://youtu.be/MlAPnS8QWbI

White lines appear at the top right during the introduction. Big glitch during the presentation of the level. No glitch detected during the game.

OS version used: 1.01

These glitch have been observed on two different consoles: a switched Super Nintendo PAL and a Super Nintendo US. Two SD cards were used, with the same result. These glitches also appear with the US version of the game.

This bug obviously does not appear with the original version of the game on the same hardware, nor with another flash card ( Super UFO Pro 8 )

Any idea to solve this problem? OS bug? Everdrive card bug?

Offline Richardragon87

  • SNESAdvance Revival Coder
  • Full Member
  • ***
  • Posts: 213
  • Karma: +3/-0
    • View Profile
Re: Super Everdrive X5 - Glitches with Assault Suit Valken
« Reply #1 on: December 14, 2019, 07:26 PM »
The game is really buggy eventhough it has been a few months since I played it both on my GBA and actual SNES it has a habit of having that white line in the top screen of the intro nearly throughout the entire game on my CRT output. It also has a really weird glitch line in the profile screen when action kicks in most likely due to the layer of the profile avitar on the bottom left interacting with the explosions causing a rip in the bottom screen this also happens in the trainer of the English game Cybernator using the Beta version which retained the profile cards including a stage select to reach the deleted area cutscene.

The only thing which I don't recall is that flickering in the mission log.
« Last Edit: December 15, 2019, 04:38 PM by Richardragon87 »
[quote Random dating spambotJ

Quote
Post changed:

Great, the photo didn't load! Does anyone know how to fix this?
In any case, my other photos can be viewed here, I will be glad to meet you, I love flirt))

P.S Richardragon87! Don't write me again, dude! You're in ignore list!

Offline Ybaresan

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: Super Everdrive X5 - Glitches with Assault Suit Valken
« Reply #2 on: December 19, 2019, 03:43 PM »
Indeed, the game is slightly buggy with the translation. But I insist on the fact that the original version does not contain those glitches.

My question is : are there other bugs with other games with the Super Everdrive X5 ?


Offline Ybaresan

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: Super Everdrive X5 - Glitches with Assault Suit Valken
« Reply #3 on: December 27, 2019, 10:41 AM »
I just tried with version 1.00 of the OS, same result.

Krikzz, any idea?

Offline KRIKzz

  • Administrator
  • Hero Member
  • *****
  • Posts: 3217
  • Karma: +484/-2
    • View Profile
Re: Super Everdrive X5 - Glitches with Assault Suit Valken
« Reply #4 on: December 31, 2019, 12:03 AM »
I just tried with version 1.00 of the OS, same result.

Krikzz, any idea?


Problem fixed: http://krikzz.com/pub/support/super-everdrive/x-series/OS/SNESOS-v1.02.zip

Offline Ybaresan

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: Super Everdrive X5 - Glitches with Assault Suit Valken
« Reply #5 on: January 05, 2020, 03:09 PM »
Thank you for your answer.

Despite the new version of the OS (version 1.02), there is still a bug, very minimal, but which does not appear in the original version or on other flashcards ( like that of Tototek or SuperUFO Pro 8 ) which is a flashing of pixels at the top right of the screen.

I would make a video and post it on YouTube.

Offline Richardragon87

  • SNESAdvance Revival Coder
  • Full Member
  • ***
  • Posts: 213
  • Karma: +3/-0
    • View Profile
Re: Super Everdrive X5 - Glitches with Assault Suit Valken
« Reply #6 on: January 05, 2020, 03:20 PM »
Thank you for your answer.

Despite the new version of the OS (version 1.02), there is still a bug, very minimal, but which does not appear in the original version or on other flashcards ( like that of Tototek or SuperUFO Pro 8 ) which is a flashing of pixels at the top right of the screen.

I would make a video and post it on YouTube.

That bug you mean depends on what device is used. As my SNES for example is Native PAL it is letter boxes so you will see defections in the game while on NTSC these are hardly noticeable. I compared my original Krikzz 1st version SED plus the SED V2 and the two SD2SNES variants plus my Juusou Kihei Valken original cart adding it to my Super FX Pro converter with a PAL cart in one slot and a Japan cart in the other and it has the same issues. This means the glitches outside the profile data screen.

This also happens on some great battle series where you will see a VHS type line in the lower screen and sometimes on the top.
[quote Random dating spambotJ

Quote
Post changed:

Great, the photo didn't load! Does anyone know how to fix this?
In any case, my other photos can be viewed here, I will be glad to meet you, I love flirt))

P.S Richardragon87! Don't write me again, dude! You're in ignore list!