Author Topic: EverDrive-N8 PRO bug reports.  (Read 11547 times)

0 Members and 1 Guest are viewing this topic.

Offline KRIKzz

  • Administrator
  • Hero Member
  • *****
  • Posts: 3305
  • Karma: +495/-2
    • View Profile
Re: EverDrive-N8 PRO bug reports.
« Reply #75 on: May 28, 2020, 04:18 PM »
I will look on this game when i will work over next os update

Offline SkyNIC

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Re: EverDrive-N8 PRO bug reports.
« Reply #76 on: May 30, 2020, 09:34 AM »
Bug with Robocop 2 USA  rom.
My NES is a PAL system.
Start the game in level 1.
Try to enter in game menu pressing start+down buttons.
The console freezes with a weird screen. I have attached the screen.
Thank you and keep up this great job. I really enjoy Everdrive N8 pro.
I have same bug on my N8 Pro with AV Famicom

Offline MHzBurglar

  • Newbie
  • *
  • Posts: 24
  • Karma: +1/-0
    • View Profile
Re: EverDrive-N8 PRO bug reports.
« Reply #77 on: May 30, 2020, 10:02 PM »
I recently bought an Everdrive N8 Pro, and it has been working fine up until today.  Now, for some reason, I always get a solid grey screen when I turn my NES on, and I have to press reset to get the EDN8 Pro to actually boot.  It used to boot immediately without any issue...  Regular NES carts boot up right away, so it's just the Everdrive doing this.  I updated the firmware to 2.08 last week, but it's was working fine until today.

Any idea what's causing this?

Edit:  Just to test, I took the Everdrive N8 Pro out of my NES, unplugged the system, and pressed the power button to drain the residual power from the system.  After I plugged it back in, the EDN8 Pro started booting immediately on power on again.  Very strange.  At least my cart works just fine once it does boot.

Edit 2:  It happened again after the power cord was accidentally pulled from my NES while it was running.  This time, the 'power drain' trick on the NES didn't stop the grey-screen boot from occurring, but it did go away after leaving the EDN8 Pro disconnected from the NES for about half an hour.  After that, it was working perfectly again.  I thought it might have had to do with some kind of residual power in my NES/NESRGB board, but maybe it's actually the EDN8's FPGA that needs to discharge.

Hopefully this will help others who are seeing this issue.
« Last Edit: June 07, 2020, 03:16 AM by MHzBurglar »

Offline venalaine

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Re: EverDrive-N8 PRO bug reports.
« Reply #78 on: June 13, 2020, 12:33 AM »
I got brand new N8 Pro and RetroUSB AVS console couple of days ago. I added some European and USA roms into the N8 Pro and couple of days everything worked just fine. I played around 20 different games without any problems. However yesterday when I was playing Star Wars the system crashed (I did not use save states). I thought it was just a random error and after I tried the game another time, it worked well. Today I was playing Super Mario Bros 3 and it crashed same way as Star Wars. I booted the system and continued playing and the game crashed again. Before that I had played SMB3 several hours and used save state to save my game (I used only one save slot for several times). I would like to know if there are some known bugs in latest firmware? I think this issue is somehow related to save states because when the crash happened, the save state window popped up automatically during playing. This problem has happened only with Star Wars (Europe) and Super Mario Bros 3 (Europe).   

After the Super Mario Bros 3 crashed today, I formatted my MicroSD and started from the beginning. After that I played Star Wars maybe 15 minutes and played Super Mario Bros maybe 1,5 hours without any issues.

N8 Pro has latest firmware.
AVS has latest firmware.
AVS is connected to wall socket by using the USB cable which came with the console.
I am using original NES controller with AVS.
I am using SanDisk 16 gb MicroSD card.

Offline KRIKzz

  • Administrator
  • Hero Member
  • *****
  • Posts: 3305
  • Karma: +495/-2
    • View Profile
Re: EverDrive-N8 PRO bug reports.
« Reply #79 on: June 13, 2020, 05:16 PM »
I got brand new N8 Pro and RetroUSB AVS console couple of days ago. I added some European and USA roms into the N8 Pro and couple of days everything worked just fine. I played around 20 different games without any problems. However yesterday when I was playing Star Wars the system crashed (I did not use save states). I thought it was just a random error and after I tried the game another time, it worked well. Today I was playing Super Mario Bros 3 and it crashed same way as Star Wars. I booted the system and continued playing and the game crashed again. Before that I had played SMB3 several hours and used save state to save my game (I used only one save slot for several times). I would like to know if there are some known bugs in latest firmware? I think this issue is somehow related to save states because when the crash happened, the save state window popped up automatically during playing. This problem has happened only with Star Wars (Europe) and Super Mario Bros 3 (Europe).   

After the Super Mario Bros 3 crashed today, I formatted my MicroSD and started from the beginning. After that I played Star Wars maybe 15 minutes and played Super Mario Bros maybe 1,5 hours without any issues.

N8 Pro has latest firmware.
AVS has latest firmware.
AVS is connected to wall socket by using the USB cable which came with the console.
I am using original NES controller with AVS.
I am using SanDisk 16 gb MicroSD card.

Any tricks with sd reformation isn't need for n8 pro. Try to use iphone or some some other good quality usb charger for powering. Ones used in wall sockets usually isn't perfect.

Offline venalaine

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Re: EverDrive-N8 PRO bug reports.
« Reply #80 on: June 13, 2020, 06:06 PM »
Any tricks with sd reformation isn't need for n8 pro. Try to use iphone or some some other good quality usb charger for powering. Ones used in wall sockets usually isn't perfect.

Do you think this kind of crashes are usually related to charger (or power anyway)? I read some old topics and noticed that there was some discussion about power problems with AVS...

Actually I already changed another charger (some ASUS tablet charger) and played Super Mario Bros 2 and Super Marion Bros 3 and those both worked well. I should also have some other high quality chargers (at least Nokia and iPhone) and must try those if the issue still exists.

Offline KRIKzz

  • Administrator
  • Hero Member
  • *****
  • Posts: 3305
  • Karma: +495/-2
    • View Profile
Re: EverDrive-N8 PRO bug reports.
« Reply #81 on: June 14, 2020, 01:23 PM »
Do you think this kind of crashes are usually related to charger (or power anyway)? I read some old topics and noticed that there was some discussion about power problems with AVS...

It quite possible. Seems AVS has high requirements to the power supply quality, even cord quality matter.

Offline Zeroaire

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: EverDrive-N8 PRO bug reports.
« Reply #82 on: June 17, 2020, 04:22 PM »
Recently got a new Famicom N8 Pro, an Analogue NT (not mini, using HDMI out), and a RetroUSB AVS.

The N8 works on the analogue NT but acts buggy occasionally.  I ran a diagnostic on it and the diagnostic hangs at IO RD speed every time.  Have to restart the console.  Tried this with RetroUSB AVS and diagnostic shows no issues. 

I guess the question is....Is this an issue known with the Analogue NT?  The fact that diagnostics run fine on the AVS make me concerned something is wrong with the NT.

Thanks!

Offline kzd

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Re: EverDrive-N8 PRO bug reports.
« Reply #83 on: June 17, 2020, 11:54 PM »
Figured I'd try in here, since the topic I made about this isn't seeing much action. Thank you, Krikzz!


1. Graphical glitches in Metal Slader Glory (JP & EN translation patch). You can see it right away, during the introduction/opening.
2. Video & more details: http://krikzz.com/forum/index.php?topic=9934.0
3. English patch: http://www.romhacking.net/translations/3755/. JP ROM should be in no-intro set.
4. N/A - visible in opening sequence
5. AV Famicom with NESRGB installed. Using Triad 9V 2A PSU. Video output to XRGB Frame Meister. OS Version is 2.07.
6. Checksums confirmed valid.
7. No PAL ROMs involved, not a region issue.

Offline mario64

  • Full Member
  • ***
  • Posts: 137
  • Karma: +2/-0
    • View Profile
Re: EverDrive-N8 PRO bug reports.
« Reply #84 on: June 18, 2020, 04:57 AM »
Recently got a new Famicom N8 Pro, an Analogue NT (not mini, using HDMI out), and a RetroUSB AVS.

The N8 works on the analogue NT but acts buggy occasionally.  I ran a diagnostic on it and the diagnostic hangs at IO RD speed every time.  Have to restart the console.  Tried this with RetroUSB AVS and diagnostic shows no issues. 

I guess the question is....Is this an issue known with the Analogue NT?  The fact that diagnostics run fine on the AVS make me concerned something is wrong with the NT.

Thanks!
The N8 has compatibility issues with the original NT. Do a search and you’ll find the threads. I finally sold my NT and got a NT Mini for this exact reason.

Offline venalaine

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Re: EverDrive-N8 PRO bug reports.
« Reply #85 on: June 21, 2020, 12:59 AM »
I wrote some days ago about issues with N8 PRO and unfortunately it seems that there is something wrong with my cartridge. Last time I reported that save state window popped up automatically and the game crashed when I was playing Star Wars and later also with Super Mario Bros 3. Today it happened when I was playing Aladding and Jungle Book (both were PAL games). Now I must try older firmware and tomorrow I will go and buy a new microSD card if the problem is somehow related to my memory card. In any case I am not happy with this situation.

Things I have tried:
- Changed my power plug (it was said that AVS has had some power issues).
- Tried another controller
- Changed romset

Offline lee4

  • codetype specialist
  • Hero Member
  • *****
  • Posts: 771
  • Karma: +45/-0
    • View Profile
    • gamehacking.org
Re: EverDrive-N8 PRO bug reports.
« Reply #86 on: June 21, 2020, 01:03 AM »
Users with AVS please include firmware version number your AVS is running on.
ED64 v2.0, 3.0 & X7 | EDMD v3 | MEGAED X7 M15 v2.01 | TED v2.4 | EDN8 v1.2N | SED v2.1 | SD2SNES rev E1 & PRO rev.B | EDGB v1.1 & X7 M17 rev B | EDGBA X5 M16 rev A
Super NT | Mega SG | Super Retro Advance | SGB v1 | PCE+SSD3

Offline KRIKzz

  • Administrator
  • Hero Member
  • *****
  • Posts: 3305
  • Karma: +495/-2
    • View Profile
Re: EverDrive-N8 PRO bug reports.
« Reply #87 on: June 21, 2020, 01:42 AM »
I wrote some days ago about issues with N8 PRO and unfortunately it seems that there is something wrong with my cartridge. Last time I reported that save state window popped up automatically and the game crashed when I was playing Star Wars and later also with Super Mario Bros 3. Today it happened when I was playing Aladding and Jungle Book (both were PAL games). Now I must try older firmware and tomorrow I will go and buy a new microSD card if the problem is somehow related to my memory card. In any case I am not happy with this situation.

Things I have tried:
- Changed my power plug (it was said that AVS has had some power issues).
- Tried another controller
- Changed romset

If for sure not related to sd card.

Offline venalaine

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Re: EverDrive-N8 PRO bug reports.
« Reply #88 on: June 21, 2020, 01:43 AM »
I have latest firmware in my AVS: v1.40b4.

I changed N8 PRO firmware to v2.07 and still have same problem. Just tried to play Aladdin and it crashed.

Does anyone know AVS + N8 PRO firmware combination which should work?
« Last Edit: June 21, 2020, 01:44 AM by venalaine »

Offline venalaine

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Re: EverDrive-N8 PRO bug reports.
« Reply #89 on: June 21, 2020, 07:38 PM »
Today I played several hours and tried many games (Jungle Book, Aladdin, Mega Man 6, SMB3, Power Blade). It seemed that everything is fine because I did not experience any issues until I tried to use save states in Aladdin. It seems that the game crashes every time when trying to use save state. Attached is the picture which tells what happens when trying to save or load previously created save state.

I would really appreciate if you can try to repeat this issue.

Rom: Aladdin (Europe).nes
AVS firmware: v1.40b4
N8 PRO firmware: v2.08

« Last Edit: June 21, 2020, 09:33 PM by venalaine »