Author Topic: Everdrive N8 (original model) random freezing issue on firmware v1.23  (Read 2935 times)

0 Members and 1 Guest are viewing this topic.

Offline MHzBurglar

  • Newbie
  • *
  • Posts: 24
  • Karma: +1/-0
    • View Profile
I am encountering an issue where my games are randomly freezing.  When this happens, some graphics will slightly distort, the screen freezes and the sound stops.  I haven't been able to identify a trigger yet, but I have had this happen to me 3 times today playing the first Legend of Zelda game.  each time it seemed to happen following a screen transition or exiting a cave, but I haven't been able to faithfully replicate the issue.  The freeze occurs after roughly half an hour of playing.

I tested my original, authentic Legend of Zelda cartridge and played for an hour straight without any issues.  My NES is a frontloader with a Blinking Light Win pin adapter and both the pin adapter and cartridge pins are clean.  I am also using the original Nintendo power supply that came with the system.

I also had this issue occur in Super Mario Bros yesterday, but I had originally attributed it to an issue with the romhack I was playing (Super Mario Bros. Special X1.)  When that game froze, Mario had recently exited a pipe about 1-2 seconds before the freeze.

I am going to test on firmware version 1.16 shortly to see if the issue occurs on the older firmware as well.

Edit:  I played Zelda 1 on firmware 1.16 from the start of the game through to the end of the second dungeon without any issue.  I switched back to firmware 1.23, and started from the beginning of the game again, and got a freeze in the first dungeon in the room where you get the bow.  Here is what it looks like when the freeze occurs.  The background graphics and HUD mess up, but the sprites stay in place.  The sound will pause on the last note played and hold it indefinitely.
« Last Edit: April 05, 2020, 03:30 AM by MHzBurglar »

Offline nuu

  • Hero Member
  • *****
  • Posts: 1415
  • Karma: +68/-2
    • View Profile
The screen and sound freezing on a note sounds like PPU and APU are still working when something else fails. Maybe the cartridge, does this only happen with the Everdrive, never with any other cartridges? This is typical for dirty contacts as well but that sounds unlikely with an Everdrive and Blinking Light Win. Check the pins so that there are no resin or anything on them.

Offline MHzBurglar

  • Newbie
  • *
  • Posts: 24
  • Karma: +1/-0
    • View Profile
The screen and sound freezing on a note sounds like PPU and APU are still working when something else fails. Maybe the cartridge, does this only happen with the Everdrive, never with any other cartridges? This is typical for dirty contacts as well but that sounds unlikely with an Everdrive and Blinking Light Win. Check the pins so that there are no resin or anything on them.

Thanks for the suggestions.  I cleaned the pins on the Everdrive and port just in case, but they were already pretty clean so no dirt really came off them.  I then played for about an hour and got another freeze.  This only seems to happen with the Everdrive; my original NES games don't freeze regardless of how long I play them; I played a real cartridge of Zelda 1 today for about 4 hours without a single issue.

I didn't used to have this issue prior to updating to 1.23; I was previously running OS V16 without any freezing ever (I also used the OS v20 beta for a while, but I didn't play enough on it to know if it had the freexing issue.)

Edit:  I once again reverted my Everdrive N8 to OS16 (1.16), and was able to play through Super Mario Bros. Special up to world 8-4 without any freezing (I have been getting constant freezing on this game on v1.23.)  It definitely seems to be an issue with the latest firmware.
« Last Edit: April 06, 2020, 06:10 AM by MHzBurglar »

Offline Erai

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
It is, i have tons of visual glitches in kirby on 1.23 and startropics becomes glitchy after 2 hours playing, everything works on 1.16 for me too.

Mind you, everything works on 1.16 only after i got a replacement, the quality of the cart and software seems to be pretty low and there's no help coming from the creator.

Offline Turk182

  • Jr. Member
  • **
  • Posts: 89
  • Karma: +0/-0
    • View Profile
Hi,

I played  Zelda yesterday with my NES PAL and my Everdrive N8 V1.23 and I had no freeze, I enter in a couple of cave on the first level and everything was OK.
Can you give me more info to make more test by my side ?

Offline MHzBurglar

  • Newbie
  • *
  • Posts: 24
  • Karma: +1/-0
    • View Profile
Hi,

I played  Zelda yesterday with my NES PAL and my Everdrive N8 V1.23 and I had no freeze, I enter in a couple of cave on the first level and everything was OK.
Can you give me more info to make more test by my side ?

Unfortunately, there's no consistent way to trigger the freeze, which makes it very hard to troubleshoot.  It seems to happen randomly;  Sometimes it will work fine for a few hours, sometimes it'll only be a few minutes before a freeze happens.

Offline Turk182

  • Jr. Member
  • **
  • Posts: 89
  • Karma: +0/-0
    • View Profile
Hi Guys,

I played 2H yesterday and 2H today .. No Freeze at all.
My config :

N8 Original V1.23
Zelda Europe REV1 No-intro set
NES Pal Europe

Offline MarcoAG11

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
I have the same issue. Lots of freezing with any firmware after v1.16.

Offline Turk182

  • Jr. Member
  • **
  • Posts: 89
  • Karma: +0/-0
    • View Profile
I have the same issue. Lots of freezing with any firmware after v1.16.

Which hardware? PAL? which rom?

Offline Odin Belmont

  • Jr. Member
  • **
  • Posts: 58
  • Karma: +0/-0
    • View Profile
I have the same issue. Lots of freezing with any firmware after v1.16.

I have v1.23 on my original N8 and haven't had one issue at all.  Maybe you should reformat sd card or see if n8 is real everdrive and not a Chinese fake

Offline MHzBurglar

  • Newbie
  • *
  • Posts: 24
  • Karma: +1/-0
    • View Profile
Hi Guys,

I played 2H yesterday and 2H today .. No Freeze at all.
My config :

N8 Original V1.23
Zelda Europe REV1 No-intro set
NES Pal Europe

I'm using a US NTSC system with the US version of the ROM.  Maybe PAL systems aren't affected?

To completely rule out that my NES itself is the issue, I'm going to borrow another working NES from a friend and try that one.

I have v1.23 on my original N8 and haven't had one issue at all.  Maybe you should reformat sd card or see if n8 is real everdrive and not a Chinese fake

I bought it directly from Krikzz on this very site back in 2017, so my cart is legit.  (Can't speak for Erai though.)  I'll see how the other NES goes and report back.  I never had any issues with the V20 beta firmware, but 1.23 just seems to hate my cart/system.
« Last Edit: April 21, 2020, 08:47 PM by MHzBurglar »

Offline Daytony

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
I am having the EXACT same issues as the OP. I have a standard N8 and a Blinking Light Win connector kit installed. ALL capacitors replaced and new 78S05 voltage regulator. After upgrading to FW 1.23 I have had nothing but headaches with random freezing, missing player sprites and I cant see myself so I fall off edges. I bought my N8 from Stone Age Gamer and they even sent me a brand new N8 replacement this week and its still doing it. Ever since the N8 Pro got into the mix its been terrrible! Something is wrong with the firmware for sure.

Offline Odin Belmont

  • Jr. Member
  • **
  • Posts: 58
  • Karma: +0/-0
    • View Profile
Ever since the N8 Pro got into the mix its been terrrible! Something is wrong with the firmware for sure.

I have both the original N8 2018 from stone age gamer fw 1.23 and the new N8 Pro fw 2.06 and they both work perfectly.   So it's not the firmware.  It's something on your end?
« Last Edit: April 21, 2020, 10:37 PM by Odin Belmont »

Offline Daytony

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
It's the firmware. I went back to 1.16 and everything is fine now.

Offline MarcoAG11

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
I have the same issue. Lots of freezing with any firmware after v1.16.

Which hardware? PAL? which rom?

I'm on an Original Analogue NT HDMI. That means it has the Kevtris Hi-Def HDMI board in it which is known to not be 100% with EverDrives, but many games still run well on it. I's say around 80%.



I have the same issue. Lots of freezing with any firmware after v1.16.

I have v1.23 on my original N8 and haven't had one issue at all.  Maybe you should reformat sd card or see if n8 is real everdrive and not a Chinese fake

My EverDrive is indeed genuine. I bought it on this site on September of 2018. It says Krikzz on the inside. I have formatted various SD cards in every way possible, even going as far as to format at FAT16 64kb fir the largest allocation space. Same thing happens. As I stated above, I'm on an Original Analogue NT, so I've never had a perfect experience with the EverDrive, but I have much better compatibility with v1.16, and almost all games are unplayable with v1.20 and above.