Author Topic: SD2SNES dead? please help.  (Read 1749 times)

0 Members and 1 Guest are viewing this topic.

Offline rezendes

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
SD2SNES dead? please help.
« on: May 06, 2020, 12:34 AM »
I own an SD2SNES rev F.

I ordered an MSU1 addon board and followed the steps to install...

Seemed very simple and I've done more complex soldering.

It didn't work, I returned all components back to stock, still doesn't work.

I tested all solder points and all components I used tested fine before and after removing.

Diagnostic firmware doesn't even run assuming because test_log.txt never appears.

SD card fine and reformatted just to make sure.  Even checked and reflowed SD pins.

Regular SNES games run fine still.

Later I noticed the TS922IDT I used was actually a TS921IDT (supplier sent wrong one) which I fear has damaged my SD2SNES irreparably.  921 has different pinout than 922 but I don't know enough to say if/what would be damaged as a result of this.

Anyone with more knowledge I would really appreciate some help.

Offline FeverDrive

  • Hero Member
  • *****
  • Posts: 1292
  • Karma: +54/-0
  • Blast Processing advocate
    • View Profile
Re: SD2SNES dead? please help.
« Reply #1 on: May 06, 2020, 06:03 AM »
Did you test your SD2NES without a shell by any chance?
WELCO
METOT
HENEX
TLEVEL

Offline rezendes

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Re: SD2SNES dead? please help.
« Reply #2 on: May 06, 2020, 02:03 PM »
Yes I actually did because it was inconvenient to keep testing with the case.  I noticed only one time my ossc flashed a legit video input then disappeared and the lights were all doing something as if the thing had a brain again.  Only happened once.

Offline rezendes

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Re: SD2SNES dead? please help.
« Reply #3 on: May 06, 2020, 03:56 PM »
Progress (sort of)...

When I put either backwards or forwards pressure on the pcb without case, my ossc picks up a solid video signal but just a black screen on tv.

Diagnostic firmware still not creating a test_log.txt :(

Edit: that was due to dirty pins, now I have video signal but black screen without added pressure.
« Last Edit: May 06, 2020, 06:25 PM by rezendes »

Offline rezendes

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Re: SD2SNES dead? please help.
« Reply #4 on: May 06, 2020, 11:51 PM »
Ok so I feel a little like I'm talking to myself here but there's good news lol

test_log.txt created!

I reflowed and soldered every single pin on the thing except the bga, no thank you.

I get various colors on screen, after running for several minutes it ended up on a Green screen with Yellow light flashing and that seemed to be it's final state.

===log opened===
derp
SD test... please insert card
=============================
data=111133b04504
crc1 = d805a1bf crc2 = d805a1bf   PASSED


RTC Test
========
setting clock to 2011-01-01 00:00:00
2011-01-01 00:00:00
waiting 5 seconds
new time: 2011-01-01 00:00:00
FAILED


FPGA test
=========
configuring fpga...
fpga_pgm: 212501 bytes programmed
no response from FPGA trying to initiate configuration!

Offline Greg2600

  • Sr. Member
  • ****
  • Posts: 337
  • Karma: +8/-0
    • View Profile
Re: SD2SNES dead? please help.
« Reply #5 on: May 07, 2020, 10:33 PM »
so you were trying to do the audio amp/mod?  Did you ask Borti4938 (https://twitter.com/borti4938?lang=en) who designed the PCB? 

Offline rezendes

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Re: SD2SNES dead? please help.
« Reply #6 on: May 08, 2020, 04:32 AM »
Good idea, didn't think of that.

Offline rezendes

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Re: SD2SNES dead? please help.
« Reply #7 on: May 14, 2020, 09:02 PM »
So, I tweeted at him I think, I just used @hisname and a message... not sure how to use twitter at all.  No response though...  been a week or so.

Offline rezendes

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Re: SD2SNES dead? please help.
« Reply #8 on: May 25, 2020, 06:41 AM »
I got it to do this...

===log opened===
derp
SD test... please insert card
=============================
data=111033b04504
crc1 = d805a1bf crc2 = d805a1bf   PASSED


RTC Test
========
setting clock to 2011-01-01 00:00:00
2011-01-01 00:00:00
waiting 5 seconds
new time: 2011-01-01 00:00:00
FAILED


FPGA test
=========
configuring fpga...
fpga_pgm: 212501 bytes programmed
FPGA configured
basic communication test...PASSED


RAM test
========
Testing RAM0 (128Mbit) - clearing RAM - writing RAM - verifying RAM -error @0x000000: expected 0x00, got 0xa5
error @0x000001: expected 0x01, got 0xa5
error @0x000002: expected 0x02, got 0xa5
error @0x000003: expected 0x03, got 0xa5
error @0x000004: expected 0x04, got 0xa5
error @0x000005: expected 0x05, got 0xa5
error @0x000006: expected 0x06, got 0xa5
error @0x000007: expected 0x07, got 0xa5
error @0x000008: expected 0x08, got 0xa5
error @0x000009: expected 0x09, got 0xa5
error @0x00000a: expected 0x0a, got 0xa5
error @0x00000b: expected 0x0b, got 0xa5
error @0x00000c: expected 0x0c, got 0xa5
error @0x00000d: expected 0x0d, got 0xa5
error @0x00000e: expected 0x0e, got 0xa5
error @0x00000f: expected 0x0f, got 0xa5
error @0x000010: expected 0x10, got 0xa5
error @0x000011: expected 0x11, got 0xa5
error @0x000012: expected 0x12, got 0xa5
error @0x000013: expected 0x13, got 0xa5
error @0x000014: expected 0x14, got 0xa5
too many errors, aborting
RAM0 FAILED
Testing RAM1 (4Mbit) - writing RAM - verifying RAM...error @0x00000: expected 0x00, got 0xa5
error @0x00001: expected 0x01, got 0xa5
error @0x00002: expected 0x02, got 0xa5
error @0x00003: expected 0x03, got 0xa5
error @0x00004: expected 0x04, got 0xa5
error @0x00005: expected 0x05, got 0xa5
error @0x00006: expected 0x06, got 0xa5
error @0x00007: expected 0x07, got 0xa5
error @0x00008: expected 0x08, got 0xa5
error @0x00009: expected 0x09, got 0xa5
error @0x0000a: expected 0x0a, got 0xa5
error @0x0000b: expected 0x0b, got 0xa5
error @0x0000c: expected 0x0c, got 0xa5
error @0x0000d: expected 0x0d, got 0xa5
error @0x0000e: expected 0x0e, got 0xa5
error @0x0000f: expected 0x0f, got 0xa5
error @0x00010: expected 0x10, got 0xa5
error @0x00011: expected 0x11, got 0xa5
error @0x00012: expected 0x12, got 0xa5
error @0x00013: expected 0x13, got 0xa5
error @0x00014: expected 0x14, got 0xa5
too many errors, aborting
RAM1 FAILED

Offline dreimer

  • Sr. Member
  • ****
  • Posts: 304
  • Karma: +23/-0
    • View Profile
    • Reimi's Blog
Re: SD2SNES dead? please help.
« Reply #9 on: May 25, 2020, 04:59 PM »
Whatever you did wrong in the first place, first log says FPGA does not respond and whatever you fixed then fixed the FPGA, but now your RAM is dead. Dangerous, but did you try a hot air gun? Some pics of the current state (pcb I mean) would be nice. Maybe I can see something looking very different on mine. (RevE2 with Borti board)
« Last Edit: May 25, 2020, 05:02 PM by dreimer »

Offline rezendes

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Re: SD2SNES dead? please help.
« Reply #10 on: May 26, 2020, 02:27 AM »
Well, I have finally resorted to a hot air gun.  After manually reflowing every single pin on both sides with leaded solder.  I checked all the pins with tweezers to see if they moved.  In between I've been trying the diagnostic firmware several times and right now it doesn't even run at all.  I'm convinced it's not making perfect contact with the snes cartridge slot even though my test game works perfectly every time.  I try with and without the plastic case for the sd2snes and try lifting it up a tiny bit and pushing back and forward... Right now I reflowed the BGA chip and it doesn't even run the diagnostics, although I do get the Green light to come on sporadically while the yellow light flashes a few times quickly and it repeats that for who knows how long, left it on for like an hour and no log created.  Now the board has scorch marks around where I reflowed the bga.  I have a sonic cleaner I plan to run the board through once I get some cleaning solution I ordered.  After that, I'm gonna try to send it to Krikzz.

Offline rezendes

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Re: SD2SNES dead? please help.
« Reply #11 on: June 01, 2020, 03:41 AM »
After sonic cleaning for only 10 mins, I have my best results included below.  Note: it says the SNES appears dead however the SNES runs multiple legit cartridges such as Starfox and Pitfall perfectly fine every time.

===log opened===
derp
SD test... please insert card
=============================
data=111033b04504
crc1 = d805a1bf crc2 = d805a1bf   PASSED


RTC Test
========
setting clock to 2011-01-01 00:00:00
2011-01-01 00:00:00
waiting 5 seconds
new time: 2011-01-01 00:00:05
PASSED


FPGA test
=========
configuring fpga...
fpga_pgm: 212501 bytes programmed
FPGA configured
basic communication test...PASSED


RAM test
========
Testing RAM0 (128Mbit) - clearing RAM - writing RAM - verifying RAM -error @0x000010: expected 0x10, got 0x30
error @0x000011: expected 0x11, got 0x31
error @0x000012: expected 0x12, got 0x32
error @0x000013: expected 0x13, got 0x33
error @0x000014: expected 0x14, got 0x34
error @0x000015: expected 0x15, got 0x35
error @0x000016: expected 0x16, got 0x36
error @0x000017: expected 0x17, got 0x37
error @0x000018: expected 0x18, got 0x38
error @0x000019: expected 0x19, got 0x39
error @0x00001a: expected 0x1a, got 0x3a
error @0x00001b: expected 0x1b, got 0x3b
error @0x00001c: expected 0x1c, got 0x3c
error @0x00001d: expected 0x1d, got 0x3d
error @0x00001e: expected 0x1e, got 0x3e
error @0x00001f: expected 0x1f, got 0x3f
error @0x000020: expected 0x20, got 0x30
error @0x000021: expected 0x21, got 0x31
error @0x000022: expected 0x22, got 0x32
error @0x000023: expected 0x23, got 0x33
error @0x000024: expected 0x24, got 0x34
too many errors, aborting
RAM0 FAILED
Testing RAM1 (4Mbit) - writing RAM - verifying RAM...RAM1 PASSED


SD DMA test
===========
clearing RAM - loading test file - verifying -error @0x000010: expected 0x10, got 0x30
error @0x000011: expected 0x11, got 0x31
error @0x000012: expected 0x12, got 0x32
error @0x000013: expected 0x13, got 0x33
error @0x000014: expected 0x14, got 0x34
error @0x000015: expected 0x15, got 0x35
error @0x000016: expected 0x16, got 0x36
error @0x000017: expected 0x17, got 0x37
error @0x000018: expected 0x18, got 0x38
error @0x000019: expected 0x19, got 0x39
error @0x00001a: expected 0x1a, got 0x3a
error @0x00001b: expected 0x1b, got 0x3b
error @0x00001c: expected 0x1c, got 0x3c
error @0x00001d: expected 0x1d, got 0x3d
error @0x00001e: expected 0x1e, got 0x3e
error @0x00001f: expected 0x1f, got 0x3f
error @0x000020: expected 0x20, got 0x30
error @0x000021: expected 0x21, got 0x31
error @0x000022: expected 0x22, got 0x32
error @0x000023: expected 0x23, got 0x33
error @0x000024: expected 0x24, got 0x34
too many errors, aborting
FAILED


Loading SNES test ROM
=====================



sysclk test
===========
measuring SNES clock...
21481150 Hz
21481148 Hz diff = 2  max = 2
21481148 Hz diff = 0  max = 2
21481147 Hz diff = 1  max = 2
   CPUCLK: 3475204
  READCLK: 0
 WRITECLK: 0
  PARDCLK: 0
  PAWRCLK: 0
  REFRCLK: 78740
ROMSELCLK: 0
PASSED


SNES test status: IRQ: 00   PA: 00   MEM: 00/00
Timeout! SNES appears to be dead!



TEST SUMMARY
============

flash check:   1110-3-33b04504-dfb09a7f-00-11-0 
Test      Result
----------------
SD        Passed
USB       not implemented
RTC       Passed
CIC       no run
FPGA      Passed
RAM       FAILED
SD DMA    FAILED
CLK       Passed
DAC       not implemented
SNES IRQ  FAILED
SNES RAM  FAILED
SNES PA   FAILED