General > EverDrive N8

Weird problem with games not loading on original N8

(1/1)

Margatroid:
I have an Everdrive N8 that I bought years ago directly from Krikzz. It has always worked fine for me on my toaster NES, and recently I upgraded the OS to 1.26. Everything seemed to be working fine, and I played a few games with it. Today I tried to load up an English translation of Megami Tensei, and the game would not load at all. It just game me a blackscreen. Looking at the old compatibility list here, I see that the game does not work with savestates or Powerpak on the N8: https://krikzz.com/forum/index.php?topic=340.0

However, the mapper is supported, so the game should load. I have a bigger problem now, though. After this failure to load Megami Tensei, I now can no longer load nearly any ROM, including ones I have played many times like Super Mario Brothers 2 and Super C. The only games I can seem to load just happen to be ones I recently played, like Batman: Return of the Joker and Ganbare Goemon Gaiden.

Thinking maybe the problem is the 1.26 OS, I installed 1.25 instead. But the problem persists. I can't load any games, except Goemon and Batman. Do you think somehow this patched version of Megami Tensei messed up something with the N8's mapper functionality? That's the only guess I can make, but I'm not a programmer. In any case this problem seems very bizarre. I hope someone has an idea what it might be!


Edit: I deleted the EDFC folder and re-copied everything fresh, including the 1.26 OS, and the problem seems to be solved.

It would be nice if Krikzz or someone else would make a simple guide for installing new OS revisions. I tried to google one when I was installing 1.26 and I could not find one. It would have saved me some time with this problem, and many other people as well I'm sure.

nuu:
I think so too, as there are many people installing the OS incorrectly. Some just overwrites the old OS with the new one, which could be bad.

Navigation

[0] Message Index

Go to full version