EverDrive Forum

General => EverDrive N8 => Topic started by: sqwirral on March 09, 2017, 04:48 PM

Title: Legend of Zelda (never mind...)
Post by: sqwirral on March 09, 2017, 04:48 PM
I'm playing through the No-Intro ROM Legend of Zelda, The (USA).nes, using Everdrive N8 Famicom, on an AV Famicom.

There's a memory related bug where I'm in a dungeon, say Level 5 or 6, I press start to bring up the menu, and I'm instantly taken back to a specific part of the overworld map far away from the dungeon. My money, health, items are reset back to where they were about an hour ago, losing any progress I'd recently made.

So I'm wondering if this is a known bug with this version of Zelda, possibly fixed in the Legend of Zelda, The (USA) (Rev A).nes version, or if this is an Everdrive bug.

I couldn't find any mention of it being a known Zelda issue.

I'll probably end up having to start playing again from scratch using the Rev A version (or see if I can edit the save to make it work) but just wondered if anyone had any insight.
Title: Re: Legend of Zelda memory bug
Post by: Thomas83Lin on March 09, 2017, 05:45 PM
could you possibly be triggering a save state??
Title: Re: Legend of Zelda memory bug
Post by: sqwirral on March 09, 2017, 08:39 PM
Haha, wow, I bet that's what it was.  :-[

I totally forgot you could do save states. Just checked what the shortcut is set to and yes it's Up+Start.

What. An. Idiot.

Cheers!
Title: Re: Legend of Zelda (never mind...)
Post by: Thomas83Lin on March 09, 2017, 11:01 PM
 :) yeah I've never seen a bug that takes you back to the past. but you never know.lol  8)
Title: Re: Legend of Zelda (never mind...)
Post by: MP2E on March 10, 2017, 01:18 AM
I've done this in Holy Diver before and was pretty confused, I keep the save state feature off now :P